Topic locked

About Vuforia Video Playback sample

November 15, 2012 - 12:51am #1

I run the Vuforia Video Playback sample ,and everthing works fine.

Then I drag the Video prefab into my own scene then run it again(path same as the one in the sample).

The icon become "icon play" but When I click on it,nothing happened...

And I'm sure the video is prepared,I just can't play it.

 

 

 

About Vuforia Video Playback sample

January 5, 2015 - 2:07am #19

Hi jiarongkoh ,

the error message in your logs says:

java.lang.NoClassDefFoundError: com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession

This suggests the APK was not properly built or packaged, or there was some project setup issue related to your classpath.

You may want to check again the getting started guide for Vuforia Android:

https://developer.vuforia.com/resources/dev-guide/getting-started-android-native-sdk

and in particular:

https://developer.vuforia.com/resources/dev-guide/step-3-compiling-running-vuforia-sample-app

About Vuforia Video Playback sample

December 29, 2014 - 7:40am #18

Hi all, I just started on Vuforia and I'm trying out on the video playback sample app. But I can't seem to get it to work, the app crashes after hitting the start button. Here is my Logcat:

12-29 23:34:15.702: D/OpenGLRenderer(3558): Render dirty regions requested: true
12-29 23:34:15.705: D/Atlas(3558): Validating map...
12-29 23:34:15.738: I/OpenGLRenderer(3558): Initialized EGL, version 1.4
12-29 23:34:15.753: D/OpenGLRenderer(3558): Enabling debug mode 0
12-29 23:34:15.756: D/mali_winsys(3558): new_window_surface returns 0x3000
12-29 23:34:16.265: I/WebViewFactory(3558): Loading com.google.android.webview version 37 (1602158-arm) (code 111201)
12-29 23:34:16.275: I/LibraryLoader(3558): Loading: webviewchromium
12-29 23:34:16.278: I/LibraryLoader(3558): Time to load native libraries: 4 ms (timestamps 2520-2524)
12-29 23:34:16.279: I/LibraryLoader(3558): Expected native library version number "",actual native library version number ""
12-29 23:34:16.293: V/WebViewChromiumFactoryProvider(3558): Binding Chromium to main looper Looper (main, tid 1) {f31e907}
12-29 23:34:16.296: I/LibraryLoader(3558): Expected native library version number "",actual native library version number ""
12-29 23:34:16.296: I/chromium(3558): [INFO:library_loader_hooks.cc(106)] Chromium logging enabled: level = 0, default verbosity = 0
12-29 23:34:16.306: I/BrowserStartupController(3558): Initializing chromium process, renderers=0
12-29 23:34:16.308: W/art(3558): Attempt to remove local handle scope entry from IRT, ignoring
12-29 23:34:16.325: W/chromium(3558): [WARNING:resource_bundle.cc(315)] locale_file_path.empty()
12-29 23:34:16.327: I/chromium(3558): [INFO:aw_browser_main_parts.cc(63)] Load from apk succesful, fd=47 off=46780 len=2953
12-29 23:34:16.327: I/chromium(3558): [INFO:aw_browser_main_parts.cc(78)] Loading webviewchromium.pak from, fd:48 off:229484 len:643667
12-29 23:34:16.330: W/AudioManagerAndroid(3558): Requires BLUETOOTH permission
12-29 23:34:16.387: W/chromium(3558): [WARNING:proxy_service.cc(901)] PAC support disabled because there is no system implementation
12-29 23:34:16.389: W/chromium(3558): [WARNING:data_reduction_proxy_settings.cc(403)] SPDY proxy OFF at startup
12-29 23:34:16.399: W/art(3558): Attempt to remove local handle scope entry from IRT, ignoring
12-29 23:34:16.402: W/AwContents(3558): onDetachedFromWindow called when already detached. Ignoring
12-29 23:34:16.454: D/mali_winsys(3558): new_window_surface returns 0x3000
12-29 23:34:16.699: I/chromium(3558): [INFO:SkUtilsArm.cpp(179)] Device supports ARM NEON instructions!
12-29 23:34:32.593: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.595: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.597: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.620: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.620: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.622: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.622: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.623: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.623: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.623: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.623: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.624: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.624: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.627: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.627: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.627: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.628: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.628: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.632: D/VideoPlayback(3558): onCreate
12-29 23:34:32.632: I/art(3558): Rejecting re-init on previously-failed class java.lang.Class<com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession>
12-29 23:34:32.633: D/AndroidRuntime(3558): Shutting down VM
12-29 23:34:32.634: E/AndroidRuntime(3558): FATAL EXCEPTION: main
12-29 23:34:32.634: E/AndroidRuntime(3558): Process: com.qualcomm.vuforia.samples.VideoPlayback, PID: 3558
12-29 23:34:32.634: E/AndroidRuntime(3558): java.lang.NoClassDefFoundError: com.qualcomm.vuforia.samples.SampleApplication.SampleApplicationSession
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at com.qualcomm.vuforia.samples.VideoPlayback.app.VideoPlayback.VideoPlayback.onCreate(VideoPlayback.java:119)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at android.app.Activity.performCreate(Activity.java:5933)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1105)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2251)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2360)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at android.app.ActivityThread.access$800(ActivityThread.java:144)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1278)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at android.os.Handler.dispatchMessage(Handler.java:102)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at android.os.Looper.loop(Looper.java:135)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at android.app.ActivityThread.main(ActivityThread.java:5221)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at java.lang.reflect.Method.invoke(Native Method)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at java.lang.reflect.Method.invoke(Method.java:372)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:899)
12-29 23:34:32.634: E/AndroidRuntime(3558): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:694)
12-29 23:37:39.214: I/Process(3558): Sending signal. PID: 3558 SIG: 9

someone pls help!

 

About Vuforia Video Playback sample

August 11, 2014 - 10:34pm #17

Hello  oscarsernarosero

 

Thank you for your reply, even though it do not slove my problem. I found that soukya is right and you could see here https://developer.vuforia.com/forum/faq/unity-how-do-i-create-simple-videoplayback-app  if you have the same button problem. before, the cause the video can't play after  I press the play button is that I named the new script(right name is VideoPlaybackController) a wrong name carelessly.(ㄒoㄒ) When I fix the name , the problem is solved.

 

Thank you again

About Vuforia Video Playback sample

August 11, 2014 - 12:29pm #16

Hello  pool611,

 

well, in my case, it was really simple. I created an empty GameObject and I named it SceneManager and added to it the SceneViewManager script. The next step was to create another empty GameObject and this time I named it AppManager, I added to it the videoPlayBackAppManager script and the videoPlayBackUIEventHandler script. After this, I selected the SceneViewManager in the hirarchy window and, in the inspector window, clicked the AppManager options and selected the AppManager and that was it.

Please let me know if this helped you to solve your problem and if you still being stocked please let me know what exactly is the problem you are facing.

 

Regards.

About Vuforia Video Playback sample

August 11, 2014 - 7:28am #15

oscarsernarosero wrote:

Hi NalinS,

 

I have just resolved the issue. It needed just some basic steps to configure the SceneManager properly, finally I figured it out by my self, it's a kind of hard at begining, sorry.

 

Anyway, thank you again for your reply NaliinS.

 

Hi,oscarsernarosero

I have the same problem and that is I press the "play" button, however nothing happen. It plays in auto mode. Could you tell me how to configure the SceneManager properly?

Thank you very much

About Vuforia Video Playback sample

August 1, 2014 - 2:36am #14

Hi 

The autopay works fine. However to make work the play button see here https://developer.vuforia.com/forum/faq/unity-how-do-i-create-simple-videoplayback-app 

I had the same issue, now it works. 

About Vuforia Video Playback sample

March 14, 2014 - 3:20am #13

No worries, glad you solved the problem :)

N

About Vuforia Video Playback sample

March 13, 2014 - 3:33pm #12

Hi NalinS,

 

I have just resolved the issue. It needed just some basic steps to configure the SceneManager properly, finally I figured it out by my self, it's a kind of hard at begining, sorry.

 

Anyway, thank you again for your reply NaliinS.

 

About Vuforia Video Playback sample

March 13, 2014 - 8:48am #11

I just can´t push the play button

I do not understand what the problem is?

 

N

About Vuforia Video Playback sample

March 13, 2014 - 8:14am #10

Thank you for reply, NalinS.

 

May I ask what could be the problem with my project? everything works pretty fine, I just can´t push the play button so I think it's a script configuration that I'm missing or doing in the wrong way but I can't figure it out.

 

Thank you very much for your help NainS.

About Vuforia Video Playback sample

March 13, 2014 - 4:10am #9

That's because the latest release contains new samples with new code.

N

About Vuforia Video Playback sample

March 13, 2014 - 12:41am #8

Hello there!

 

I am experimenting the same issue and looking at this post I notice you talk about a Video PlayBack controller but I don´t realise which one script it is in my project. I have some scripts like VideoPlayBackAppManager, ....Behavior, ...Editor, ...UIEventHandler, ...UIViwe and ...Helper, which one of this is the VideoPlayBack controller? or is it just missing in my project? also, I watched at the AR camera in the sample project and I didn´t see a script different than the usuals so I just could not identify it altough I made sure to set my AR camera extactly like the AR camera from the sample project. please let me know if you guys know the answer. I would really appreciate it.

 

Thank you.

Note:

I checked the AutoPlay checkbox to make sure everything else is ok and it is, video plays automatically very well.

 

 

About Vuforia Video Playback sample

August 14, 2013 - 3:49am #7

Please create a new thread for your issue, and do it in English if you want enyone to respond.

Thanks

N

About Vuforia Video Playback sample

August 13, 2013 - 1:02pm #6

Hola, alguien puede explicarme paso a paso como correr la aplicación de ejemplo de playback

Ya he podido mostrar una imagen 3D, pero necesito correr el sample que se descarga desde esta pagina pero no logro hacerlo, no se cuales son los pasos para hacerlo, por ejemplo supongamos 1:agregar la ARcamera, 2:agregar el imageTarget, 2 seleccionar las casillas, 3: cargar los dataSet (stones) despues no se como seguir para que el video pueda verse! 

por favor si pueden ayudarme paso a paso 

esto es lo que estoy obteniendo al hacer los pasos tal cual como se hace con un modelo 3D se que me esta faltando algo

 

AttachmentSize
Image icon prueba.jpg216.38 KB

About Vuforia Video Playback sample

November 16, 2012 - 2:35am #5

If you are using Unity, then u can search for Video Playback controller script in project panel, drag and drop it to the AR camera available in the Hierarchy panel.

That will do add it.

About Vuforia Video Playback sample

November 16, 2012 - 1:49am #4

Hello, I got the same question

But I don't understand how to add the Scripts in the AR Camera,

Could you explain how to add it?

Thanks.

About Vuforia Video Playback sample

November 15, 2012 - 6:25pm #3

Soooo much thanks!

I forgot to add the VideoPlayback Controller Script to ARCamera...Laughing

About Vuforia Video Playback sample

November 15, 2012 - 5:13am #2

hi kknd2gsoul,

Can I just check that in your own scene you have the same structure as the Vuforia-VideoPlayback scene?

Chances are that something must have got left out along the way, possibly a script or a checkbox was not checked?

I was able to create a new AR scene containing a new ImageTarget that could run a video.  

Learning from this experience, here are a few things you might like to check:

  • ARCamera - check the dataset is activated and the checkbox ticked for loading
  • ARCamera - ensure that the VideoPlayback Controller Script is added to this
  • ImageTarget - for the ImageTargetBehaviour script check that the dataset is selected and the correct Image Target selected
  • ImageTarget - check that the TrackableEventHandler script is attached to this, as it is this that calls the VideoPlayback Controller Script to play video

HTH

N

Topic locked