Topic locked

adding sound to a target image

March 31, 2014 - 12:56am #1

i am trying to  add a sound to the image target but having some problem . when i start my application it starts my sound i want to start the sound when my target image is detected . i added the sound to the image target and enabled the play on awake option if i disable this option my sound doesnt play. plz reply thanks .

adding sound to a target image

March 9, 2015 - 12:05am #4

As mentioned in the tutorial, you may need to adjust your 3D sound settings of your Audio Source:

  • in the 3D Sounds Settings of your Audio Source, adjust the Max Distance so to make sure that the sound will be able to reach the audio listener of your ARCamera even when the distance from the Image Target is large (otherwise you may not be able to hear the sound); for example, increase the default value from 500 to 5000 (or whatever is appropriate to your specific scene setup)
  • optionally, you may want to change the Volume Rolloff settings to use a Linear rolloff instead of a Logarithmic one (this is optional and up to your specific application needs)

Note that sound playback is ultimately controlled by Unity, not by Vuforia, so you may want to check the Unity documentation:

http://docs.unity3d.com/ScriptReference/AudioSource.html

http://docs.unity3d.com/ScriptReference/AudioSettings.html

 

 

adding sound to a target image

March 7, 2015 - 3:18pm #3

I have tried this tutorial and it works BUT the sound QUALITY was terrible.

How to fix it ?

 

thanks in advance

adding sound to a target image

March 31, 2014 - 2:14am #2
Topic locked