Log in or register to post comments

Android build

August 29, 2013 - 5:34am #1

Hi,

 

I am using unity 4.2.0

In that if i import sample vuforia package it works well at Runtime

i didn't change anything in sample project,

If,i take apk,

Camera not working.

but

i can see the gui button i used,

 

 

I tried it in unity 3.5

it works well at runtime as well as apk also,

Can you help me solve this problem.

Android build

September 3, 2013 - 11:17pm #12

Good to hear. You're welcome.

Android build

September 3, 2013 - 10:12pm #11

Hello Al,

I was also experiencing problems with my codes. I searched the forum and found this thread. I followed your steps and was able to get the codes work.

Thanks a lot for this soution.

Regards,

-B

Android build

August 31, 2013 - 8:40am #10

Great !

 

Android build

August 30, 2013 - 10:33pm #9

Hi Sir,

Thanks,

I followed the Procedure and Problem Solved.

Android build

August 30, 2013 - 6:26am #8

Ok, got the files now. thanks.

Well, your APK indeed does not work, but there is something wrong in your project, 

as if I try to open it in Unity, when I build and run it on device (from Unity), it shows black screen.

So, perhaps something went wrong when you imported the sample package.

 

Here is what I recommend to do (same as I did, which works fine with Unity 4.2.0):

- Open Unity and create a New project

- In the main Menu bar, go to "Assets > Import Package > Custom package..." and select the image-targets sample package, i.e. "imagetargets-2-6-7.unitypackage" , and import the package.

- Then open the Vuforia-4-ImageTargets scene

- Go to "File > Build > Build Settings" --> select "Android" and make sure to add the 4 sample scenes to the "Scenes in Build", 

- Then click Build and run.

Note: needless to say, but don't forget to add the scenes to the "Scenes in Build", otherwise you will just get a black screen.

 

 

 

AttachmentSize
Image icon BuildSettings.jpg59.58 KB

Android build

August 30, 2013 - 4:24am #7

Sorry sir,

File Got corrupted while uploading.

I reattached

1.Project (I used sample project  only)

2.Build of sample project (APK)

Here is the link to download above files

http://we.tl/dr1CVux4xd

 

 

 

Android build

August 30, 2013 - 3:14am #6

I tried to install your APK, but I get error message like "not a valid ZIP file"

But I would recommend that you make a test using one of our samples (instead of your own project), to see if the error is reproducible with them.

 

Android build

August 30, 2013 - 2:51am #5

Hello Sir,

 

Thanks for your effect,

 

As per above instuctions i followed,Still same problem

 

So,i attached my project file and APK

 

This are the links,

 

http://enool.co/swap/APK%20file/forbuild1.apk

http://enool.co/swap/APK%20file/forbuild1.rar

 

Please check it Sir,

 

Eagerly waiting for your feedback.

 

 

Android build

August 30, 2013 - 2:01am #4

I just tested with Unity 4.2.0, using the Image Targets sample, and it seems to work fine.

Here is the procedure I followed:

- Open Image Targets sample in Unity 4.2.0, build and run it on the connected device (using the Unity editor menu "File > Build Settings > Build and run" ); this runs fine on the device

- Uninstall the apk from the device (using the Application Manager on the device)

- Using the cygwin console, installing the APK manually, with this command:

adb  -d  install  my_app.apk

- Then running the app from the device; this also works fine

Could you try the same ? this should just work.

 

 

Android build

August 29, 2013 - 9:10pm #3

No Sir,

 

I didn't take build(.apk),it working only at Runtime.

 

Then,

i take apk, and copied it in USB device,then installed it manually

it doesn't work(Camera not working).

 

Android build

August 29, 2013 - 7:44am #2

Hi, just to make sure we understand correctly:

  • if you import the sample into Unity 4.2.0, and then you build and run on the USB-connected device, the app works
  • but if you take the APK and you manually install it into the device, the app fails (camera not working)

Is that a correct understanding ?

 

Log in or register to post comments