Log in or register to post comments

Android camera issue

May 3, 2016 - 7:23am #1

Hi devs,

I've got a problem with the ARCamera on Android devices (tested on Samsung Tab S2 and Nexus 5X). The scene works in the Unity Editor and the iOS unity cloud build works on an iPhone 6.

Find attached two screenshots from Android and Unity Editor. On Android if I move the device I can see some colors in 2/3 of the screen. Color depens on what the camera sees.

Any thoughts?
Thanks

Android camera issue

May 6, 2016 - 6:30pm #6

Have you moved between Unity versions during migration or just Vuforia versions?

If going from 4.2.3 to 5.5.9, you may want to check both migration guides to verify that no steps were missed:

https://developer.vuforia.com/library//articles/Solution/Migrating-Unity-Projects-to-Vuforia-5

https://developer.vuforia.com/library//articles/Solution/Migrating-Unity-Projects-to-Vuforia-5-5

 

Android camera issue

May 6, 2016 - 2:00am #5

Hi dm3d,

Unity 5.3.1f3 (32 bit Windows) and ImageTarget 5.5.9 works.

Like I said I guess there went something wrong with the migration from 4.2.3 to 5.5.9. I guess I have to setup the project again with the clean 5.5.9 project. I hoped you guys have an idea what could be wrong. Basically the background video plane isn't showing on Android. Maybe there's an easy fix for that. What files are responsible for the video plane rendering? I could compare them from the working clean project and the broken version of my migrated project.

Thanks

Android camera issue

May 5, 2016 - 4:25pm #4

Can you try creating a new Unity project and importing the ImageTargets 5.5.9 sample and see if the issue is reproducible?

Android camera issue

May 4, 2016 - 5:29am #3

Hi dm3d,

here are the answers. I guess the problem is with the migration from a previous version. I'm gonna try to reimport the 5.5.9 unity package again.

Started with 4.2.3
Made migration to 5.x
Now using 5.5.9
 
Unity 5.3.1p3
 
Tab S2 Android 5.0.2
Nexus 5X 6.0.1
 
Settings seem ok, I double-checked that.
I also created a new scene just with the ARCamera and ImageTarget prefab. Still the same issue with the camera on Android.
 
Any idea which setting(s) or file(s) can cause the rendering issues? Where can I look or what can I check?
Thanks

Android camera issue

May 3, 2016 - 5:44pm #2

  • What version of Vuforia?
  • What version of Unity?
  • What Android OS version on Tab S2 and Nexus 5X?

The pixelation looks like rendering issue. Are you using OpenGL ES 2.0? Do your output settings from Unity match these:

https://developer.vuforia.com/forum/faq/unity-player-settings

 

Log in or register to post comments