Log in or register to post comments

Android Deployment Failing to Open Scene

March 10, 2015 - 12:25pm #1

I have been trying my darndest to set up a simple image tracking application just as a tutorial for a larger project in the near future but for the life of me, I cannot get the android app to actually do anything.

I have followed the directions on the Image Target tutorial on YouTube, with a few customizations such as a different image target and using a cylinder instead of a dragon. And it runs fine on my laptop's webcam. But I cannot get it to run on my Android device.

I  am using:

  • Unity 4.6.1f1
  • Nexus One
    • Android 2.3.6

I can build the .apk fine enough. Then I use adb to push to the external storage device on the phone (work-around because I'm running out of space) then use the package installer to install. It is installed with permission to use the camera, too. The Player Settings are set up mostly default except the minimum API level is 2.3.3. The correct scene is in the build.

Whenever I start the application, there is no UI present (I never implemented one), just a completely blank screen. Maybe once every 7 or 8 tries, Android OS will pop up with a message about the application not responding as I home button out of the application.

Does anybody have any suggestions as to what to do next? I've tried:

  • restarting phone
  • restarting unity and redeploying

I am happy to follow up with any more details if requested. Thanks.

Android Deployment Failing to Open Scene

March 17, 2015 - 1:40pm #2

Could you compile one of the Android (non-Unity) samples and see if those run on your 2.3.6 device?

https://developer.vuforia.com/downloads/samples

 

Log in or register to post comments