Log in or register to post comments

Android whitewashed video

December 12, 2014 - 12:37pm #1

My app plays videos perfectly on IOS but the same app ported out to Android does play the videos but they are very faded sort of over exposed looking?

I've played the sample video app and that works perfect and I have taken the videos in my own app and placed in the vuforia sample and they work perfect too.

Problem is...I don't know enough about Android to figure out the problem.  As it works perfect in IOS on all IOS devices I'm struggling to see what could be the issue with Android?

Anyone got any clues as to what features/settings I might need to check?

Android whitewashed video

December 16, 2014 - 7:45am #3

OK thanks, that helps me to know where to start looking ;-)

Android whitewashed video

December 15, 2014 - 4:19am #2

I've played the sample video app and that works perfect ...

...and I have taken the videos in my own app and placed in the vuforia sample and they work perfect too.

OK, if the Vuforia Samples can play the video perfectly, as you say,   one thing you may want to check is whether you are performing some performing something different in your App in terms of rendering (for example, using special Shaders or other rendering FX);   what I'm guessing here is that perhaps the rendering of the videos might get influenced somehow by other rendering effects in your app..... maybe something that affect the GPU but only shows up on Android devices and not on iOS ones.

 

Log in or register to post comments