Log in or register to post comments

Animating an Object within Unity

May 7, 2012 - 3:21pm #1

Hi,
I'm doing a simple animation test but not having much luck. Everything is hooked up right regarding the AR static mesh. The object appears fine in my iPhone when it's pointing at the imageTarget, but no animation. In Unity, when I play the scene, the animation is working, just not in the AR scene. The object is a child of the imageTarget in the Hierarchy window and I animated the object within Unity's own animation window. The "play automaticaly" box is checked.

I'm sure I'm missing something, some sort of check box someplace. Any ideas anyone?

Re: Animating an Object within Unity

May 7, 2012 - 9:37pm #4

Check out the Unity docs - http://unity3d.com/support/documentation/ScriptReference/Animation.Play

If you can post a screen grab of your scene w/ the Hierarchy expanded, I may be able to help you get this running. Animations should play as expected. So there's likely something about the way that you've constructed the scene that's interfering w/ the animation's activation.

Feel free to PM me if you don't want to post this publicly.

Re: Animating an Object within Unity

May 7, 2012 - 9:00pm #3

Hey, unfortunately, scripting is like an alien language to me. I guess I can try to figure out how to do that. Also, setting it to "loop" does nothing.

Don't know what else to try. Does anyone know if there are better tutorials for working with this AR plug-in? The docs on the "how-to's" is a bit lacking, I think.

Re: Animating an Object within Unity

May 7, 2012 - 6:02pm #2

Have you tried activating the animation procedurally (e.g. animation.Play() )?
You can also check the animation state this way.

What happens if you set the animation wrap mode to Loop?

Log in or register to post comments