Log in or register to post comments

Any android apk build by Unity 5.5.0f3 crashes after importing new version of vuforia-unity-6-2-6.unitypackage

January 8, 2017 - 5:28am #1

vuforia-unity-6-2-6.unitypackage

Any android apk build by Unity 5.5.0f3 crashes after importing new version of vuforia-unity-6-2-6.unitypackage.

Hi,

Right after importing any vitoria 6-2-6 packages to Unity, whether it be vuforia-unity-6-2-6.unitypackage or vuforia-samples-core-unity-6-2-6.zip or vuforia-samples-advanced-unity-6-2-6.zip, the unity editor is working all normal with no difficulties, but every time I try to build an APK for my android Tango tablet, the app crashes right after lunch.

I don't face this problem when I import the older versions of Vuforia sdk like 6-1-17. Any how it would be great if you can help me fix this issue cause I don't have access to all vuforia packages for lower versions (6-1-17) since they're not downloadable from vuforia's developer page anymore. 

Thanks in advance :)

Here's my adb logcat attached to this post:

https://developer.vuforia.com/sites/default/files/adb%20logcat.txt

 

AttachmentSize
Plain text icon adb logcat.txt41.3 KB

Any android apk build by Unity 5.5.0f3 crashes after importing new version of vuforia-unity-6-2-6.unitypackage

February 9, 2017 - 12:54pm #8

Reproduced this issue with  my "Project Tango Tablet Development Kit", Android 4.4.2 .

Btw, Spatializer Plugin is "none", old version (before Vuforia upgrade) works fine

Any android apk build by Unity 5.5.0f3 crashes after importing new version of vuforia-unity-6-2-6.unitypackage

January 16, 2017 - 5:18pm #7

atazahedi wrote:

The only error I find in my Project Tango Tablet Development Kit adb logcat is:

E/Unity   (21587): Unable to find AudioPluginOculusSpatializer

That error is not related to Vuforia. You may want to see what you have set for Spatializer Plugin in "Edit -> Project Settings -> Audio".

Any android apk build by Unity 5.5.0f3 crashes after importing new version of vuforia-unity-6-2-6.unitypackage

January 14, 2017 - 3:08am #6

Hi,

mine is a "Google Tango Tablet Development Kit" : 

https://developers.google.com/tango/hardware/tablet

Android Version: 4.4.2

Kernel version: 3.10.24-gd25b167

 

Any android apk build by Unity 5.5.0f3 crashes after importing new version of vuforia-unity-6-2-6.unitypackage

January 13, 2017 - 3:13pm #5

What model and OS version is your Tango device?

I'm running VuforiaSamples 6.2.6 with Unity 5.5.0f3 on a Lenovo Phab 2 Pro (6.0.1) Tango device and it works fine.

Any android apk build by Unity 5.5.0f3 crashes after importing new version of vuforia-unity-6-2-6.unitypackage

January 13, 2017 - 2:53am #4

Hello again,

can somebody please help me in this matter? it's really urgent!

The only error I find in my Project Tango Tablet Development Kit adb logcat is:

E/Unity   (21587): Unable to find AudioPluginOculusSpatializer

I'm quite new to using Unity, but I have nothing to do with Oculus in my project.

In the meanwhile as I said I even get this bug even with an empty scene, or also on another pc with fresh installation of Unity and Android Studio. 

I would appreciate any suggestion please!

Thanks,

Ata

Any android apk build by Unity 5.5.0f3 crashes after importing new version of vuforia-unity-6-2-6.unitypackage

January 10, 2017 - 1:59am #3

Project Tango Tablet Development Kit 

Any android apk build by Unity 5.5.0f3 crashes after importing new version of vuforia-unity-6-2-6.unitypackage

January 9, 2017 - 12:42pm #2

Hello,

What is the model number of your device? Please provide the string under Settings->About phone->Model number

Thanks.

Log in or register to post comments