Log in or register to post comments

App Freezes Back to Previous Scene When ImageTarget Children are

January 18, 2016 - 11:00pm #2

Hi guys,

been encountering a weird anomaly while working on my project. Will put it down in point form for easier reading:

  • Scene "0" is a VR scene that uses the native Google Cardboard SDK.
  • Scene "1" uses Vuforia, with stereo camera enabled.
  • I can transition from scene 0 to scene 1 on my phone fine enough. BUT, when the image target is tracked AND when the image target children (in this case my UI, Gameobjects, etc) are loaded and instantiated, my app freezes back to scene "0" from scene "1".
  • I thought it might have something to do with the image target children, so i instatiated all Game objects not as children of the image target prefab and it still freezes up.
  • Funny thing is, earlier versions of my projects are now plagued with the same problem too!! And they worked fine beforehand.
  • The only thing I remembered tweaking in my "sandbox version" is adding DateTime calculations and some GUIs. But even so, why are my previous stable builds all weird now too??

Troubleshooting I have tried:

  • Change license keys.
  • Change Target images.
  • Disable all Virtual Buttons and GameObjects (when it is only the image target in the scene it works, sort of. I mean, at least it didn't freeze up).
  • Go back to previous stable builds and test it from there.
  • Run on two phones running on two versions of android (4.4.4 and 5.1.1).
  • Built on both Mac and Windows computers.

I think the issue might have something to do with:

  • The fact I copy the project between my Mac and Windows PC (but that shouldnt be an issue, since in previous stable build it was fine)
  • Unity itself is corrupted in some way.
  • Vuforia license keys or target managers is screwed up somehow?? (I have 5 images in my target database, but i highly doubt that's the problem neither)
  • Problems in the code (but unlikely neither since I said it is affecting my previous stable builds, which are now too corrupted).

I am at my rope's end trying to solve this issue, I think it has something to do with Unity itself, going to consider migrating the project to a lower version of Unity, but I highly doubt that's the case. Can anybody please help?

Some information that might be useful:

  1. running on Unity 5.3.1f1 using C#
  2. Developed on Windows 7, and Mac OS X Yosemite
  3. Used two phones (One Plus One android version 5.1.1, & Xiao Mi 3 android version 4.4.4)

App Freezes Back to Previous Scene When ImageTarget Children are

January 20, 2016 - 5:42am #1

Okay, 

So I did not exactly find a solution for my problem, but what I did was:
 

  • Created a whole new project and salvage whatever asset I could from the previous built.
  • Reimported the Cardboard SDK as well as Vuforia SDK.

I think it might have something to do with the SDKs, some conflict or whatever it is, I dont know the exact problem unfortunately. So for now, the only solution to such an issue is to re-do the entire project :/ sucks I know.
 

If anybody has a proper fix do let me know!

Log in or register to post comments