Log in or register to post comments

Application.LoadLevel

January 9, 2012 - 2:41am #1

Hello,

I'm trying to use Application.LoadLevel ("..scene.."); With a menu that has multiple Application.LoadLevel ("") options. But when I load this on my mobile it doesn't show my models.

example code:

if ( GUI.Button (Rect (Screen.width/10f*2.5, Screen.height/10f*3 , Screen.width/10f*5 , Screen.height/10f*0.9), "AR Voorbeeld 1"))

{

Application.LoadLevel ("Ar03");

displayOptions = false;

}

if ( GUI.Button (Rect (Screen.width/10f*2.5, Screen.height/10f*4 , Screen.width/10f*5 , Screen.height/10f*0.9), "AR Voorbeeld 2"))

{

Application.LoadLevel ("Ar02");

displayOptions = false;

}

if ( GUI.Button (Rect (Screen.width/10f*2.5, Screen.height/10f*5 , Screen.width/10f*5 , Screen.height/10f*0.9), "AR Voorbeeld 3"))

{

Application.LoadLevel ("Ar01");

displayOptions = false;

}

is there a way to create multiple AR scenes in 1 app with unique GUI?

Re: Application.LoadLevel

January 11, 2012 - 2:02am #3

I checked it again, and what you said was true.
It did work, but the object was so smal the camera coudn't see it.
Fixed it now. Thank you for your respons

Re: Application.LoadLevel

January 9, 2012 - 5:53pm #2

This should work, could you attach the log?

What version of QCAR are you using? If you are using 1.5 make sure the correct datasets are being loaded and activated in the ARCamera's DataSetLoadBehaviour component (see the Inspector view).

Did you add all of the scenes to the Build Settings "Scenes in Build" menu?

- Kim

Log in or register to post comments