Log in or register to post comments

Black screen after loading the AR scene

February 25, 2017 - 4:36am #1

Hello! I have a problem with loading the AR scene into a project. What I'm doing is:

1. Create the scene with following components:

  • Directional Light,
  • ImageTarget, containing several prefabs,
  • ARCamera.

At this point everything works fine - the image target is being tracked and I see my models.

2. Export the scene into Asset Bundle.

3. In another project, I download the Asset Bundle and use SceneManager.LoadScene() to load the scene.

4. The scene is succesfully loaded, there are no errors, there are logs of Vuforia's succesful initialization and Vuforia starting, but the screen is black. My other observations:

  • TextureBufferMesh in DonDestroyOnLoad correctly shows the texture of my webcam,
  • BackgroundPlane of ARCamera is black (black circle in VideoMaterial),
  • suprisingly, the ImageTarget is being tracked and I see the models, while the screen remains black.

Do I need to do something different during the Vuforia initialization? I tried delaying the Vuforia Initialization and then initializating in Start() of the script attached to ARCamera, but that doesn't change anything.

Black screen after loading the AR scene

April 22, 2020 - 7:23pm #7

Final work!  My Screen is not Pink in Model Target finally .

i have tried these methods .

 1. i remove post processing in the ArCamera

 2. used  OpenGLES3 first , second is Metal  in  Other Setting .

*3. add an arcamera in your firstScene but not active (i think this answer is close to the solution)

4.reinstall Vuforia SDK in package manager

if someone have face the same problem , please let me know 

Black screen after loading the AR scene

April 20, 2020 - 1:44am #6

Hi , did you Solved the problem ?

i use Model target , and Vuforia 8.6.7 ,unity 2019.2.6f1 , got similar problem . 

in ios Device , i use  SceneManager.LoadSceneAsync(name); assetbundle cannot load success , but show the load scene , and screen is pink , Model target still can worked ! 

but i work fine in unity mac editor .

Can you help me thank you ?

Black screen after loading the AR scene

August 13, 2019 - 5:30am #5


This is working for me.

I changed Graphics settings from Open GL 3.0 to Open GL 2.0 and application working.

Black screen after loading the AR scene

June 30, 2018 - 2:01pm #4

I was having the same problem but even farther from figuring out what was going wrong. I then saw veit270's post about the ARCamera working when it is the first scene after the Unity splash screen and try that. IT FINALLY WORKED! I then was able to create a work around for this problem by putting the ARCamera on the first scene and making a script do a DoNotDestroyOnLoad(ARCamera) for the ARCamera GameObject. I then can load my scene I want and the camera is NO LONGER BLACK. Make sure you make the ARCamera some kind of singleton so DoNotDestroyOnLoad(ARCamera) only gets called once or you will have multiple ARCameras in your scenes and funky things start happening.

Black screen after loading the AR scene

June 13, 2018 - 8:25pm #3

Same problem. Any answers?? 

Black screen after loading the AR scene

May 24, 2017 - 4:24am #2

This is a rendering issue since long in vudoria sdk. just change the graphics in (File>Build>Player settings> Other Setting> Graphics) to Open Gl 2.0 and it should be solved.

Log in or register to post comments