Log in or register to post comments

Black screen when app installed first time

May 29, 2015 - 3:49am #1

I generated the apk and installed the apk but when i installed the app first time and open the app, when goes to camera view, i'm getting black screen. 

Black screen when app installed first time

November 10, 2015 - 11:20am #32

i have problem black screen please help me

Black screen when app installed first time

November 10, 2015 - 11:20am #31

i have problem black screen please help me

Black screen when app installed first time

June 3, 2015 - 11:52am #30

I'm using video playback sample app only but it was working fine with Unity4.5.2 and after upgrade the app i can't able to click the play button. When i try to click the play button, i can't able to click it.

Black screen when app installed first time

June 3, 2015 - 11:30am #29

It works fine when using 4.6.5 and when i scan the image the video keyframe texture is showing

Glad to hear it now works with Unity 4.6.

 

...but i can't able to click the button and watch the video. Which file should i check the code for click the play icon and video play

That depends on where you have put that code in your project; if you have taken inspiration from the VideoPlayback sample code, the Play() method is in a script called VideoPlayerHelper.cs; if you start from that and you look for references to that function call in your project, you should be able to find out the code that triggers the Play.

 

Black screen when app installed first time

June 3, 2015 - 11:22am #28

It works fine when using 4.6.5 and when i scan the image the video keyframe texture is showing but i can't able to click the button and watch the video. Which file should i check the code for click the play icon and video play

Black screen when app installed first time

June 2, 2015 - 10:23am #27

Oh, yes, you shold upgrade to Unity 4.6 (ideally to the latest Unity 4.6.5), or even to Unity 5.

Vuforia 4.2 supports Unity 4.6 and above.

 

Black screen when app installed first time

June 2, 2015 - 9:42am #26

Which version of unity are you using? I'm using 4.5.2. Does it cause the problem? Because still the app is crashing when open

Black screen when app installed first time

June 2, 2015 - 9:17am #25

I've tried to run the adb logcat *:E and i got the attached value when the app crashed.

AttachmentSize
Image icon command.JPG117.17 KB

Black screen when app installed first time

June 2, 2015 - 8:12am #24

The logs do not reveal an error message, however they show multiple attempts of the TargetFinder to retrieve the init state; so, something must be broken in your project; 

the black camera shown in the video is not a "crash"; it looks like you might be doing something incorrect at initialization time in some of your script.

Again, try to isolate the issue in a minimal repro-case;    in my previous post (see post #16) I already posted the test code that you can use (which works correctly here with Vuforia 4.0 as well as Vuforia 4.2.3); 

if you can reproduce a crash log using such minimal repro-case, then we can look at it and verify whether there is a problem in Vuforia,  but otherwise it sounds more like an App specific issue that you need to debug first within your app.

 

Black screen when app installed first time

June 2, 2015 - 8:01am #23

Can you please give your project link to download and check?  Please check the video of the app working and it showing black screen only.

www.xplorear.com/Unity/projects/20150602_194151.mp4

 

Last 10days i'm facing with this issue. Please help on this.

Black screen when app installed first time

June 2, 2015 - 7:17am #22

Now open the app it crashed. See the logs,

 

 
C:\Users\Arun\Desktop>TITLE Show unity output
 
C:\Users\Arun\Desktop>ECHO MAKE SURE YOUR DEVICE IS CONNECTED TO THIS COMPUTER ~
 Angelic App ~
MAKE SURE YOUR DEVICE IS CONNECTED TO THIS COMPUTER ~ Angelic App ~
 
C:\Users\Arun\Desktop>cd/D "C:\projectsdev\android\android-sdk\platform-tools"
 
C:\projectsdev\android\android-sdk\platform-tools>adb logcat -s QCAR Unity
--------- beginning of /dev/log/main
D/Unity   (24290): GL_EXT_debug_marker GL_OES_texture_npot GL_OES_compressed_ETC
1_RGB8_texture GL_OES_standard_derivatives GL_OES_EGL_image GL_OES_depth24 GL_AR
M_rgba8 GL_ARM_mali_shader_binary GL_OES_depth_texture GL_OES_packed_depth_stenc
il GL_EXT_texture_format_BGRA8888 GL_EXT_blend_minmax GL_OES_EGL_image_external
GL_OES_EGL_sync GL_OES_rgb8_rgba8 GL_EXT_multisampled_render_to_texture GL_EXT_d
iscard_framebuffer GL_OES_get_program_binary GL_ARM_mali_program_binary GL_EXT_s
hader_texture_lod GL_EXT_robustness GL_OES_depth_texture_cube_map
I/Unity   (24290): Setting BehaviourComponentFactory
I/Unity   (24290):
I/Unity   (24290): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (24290):
I/Unity   (24290): Trackable  lost
I/Unity   (24290):
I/Unity   (24290): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (24290):
D/QCAR    (24290): Setting Unity version 4.5.2
D/QCAR    (24290): QCAR Extension version 4.2.3
D/QCAR    (24290): Initializing Vuforia...
I/Unity   (24290): QCAR initialization successful
I/Unity   (24290):
I/Unity   (24290): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (24290):
D/QCAR    (24290): trackerManagerInitTracker
D/QCAR    (24290): trackerManagerInitTracker
I/Unity   (24290): SetHint
I/Unity   (24290):
I/Unity   (24290): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (24290):
I/Unity   (24290): SetHint
I/Unity   (24290):
I/Unity   (24290): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (24290):
I/Unity   (24290): SetHint
I/Unity   (24290):
I/Unity   (24290): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (24290):
I/Unity   (24290): StartQCAR
I/Unity   (24290):
I/Unity   (24290): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (24290):
D/QCAR    (24290): cameraDeviceInitCamera
D/QCAR    (24290): cameraDeviceGetVideoMode
I/Unity   (24290): Using default scene scale for device: 1
I/Unity   (24290):
I/Unity   (24290): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (24290):
D/QCAR    (24290): cameraDeviceSelectVideoMode
D/QCAR    (24290): cameraDeviceStartCamera
D/QCAR    (24290): markerTrackerStart
D/QCAR    (24290): objectTrackerStart
D/QCAR    (24290): targetFinderStartInit
D/QCAR    (24290): targetFinderGetInitState
D/QCAR    (24290): cameraDeviceGetVideoMode
D/QCAR    (24290): targetFinderGetInitState
D/QCAR    (24290): cameraDeviceGetVideoMode
D/QCAR    (24290): targetFinderGetInitState
D/QCAR    (24290): targetFinderGetInitState
D/QCAR    (24290): targetFinderGetInitState
D/QCAR    (24290): targetFinderGetInitState
--------- beginning of /dev/log/system
D/Unity   (26000): GL_EXT_debug_marker GL_OES_texture_npot GL_OES_compressed_ETC
1_RGB8_texture GL_OES_standard_derivatives GL_OES_EGL_image GL_OES_depth24 GL_AR
M_rgba8 GL_ARM_mali_shader_binary GL_OES_depth_texture GL_OES_packed_depth_stenc
il GL_EXT_texture_format_BGRA8888 GL_EXT_blend_minmax GL_OES_EGL_image_external
GL_OES_EGL_sync GL_OES_rgb8_rgba8 GL_EXT_multisampled_render_to_texture GL_EXT_d
iscard_framebuffer GL_OES_get_program_binary GL_ARM_mali_program_binary GL_EXT_s
hader_texture_lod GL_EXT_robustness GL_OES_depth_texture_cube_map
I/Unity   (26000): Setting BehaviourComponentFactory
I/Unity   (26000):
I/Unity   (26000): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (26000):
I/Unity   (26000): Trackable  lost
I/Unity   (26000):
I/Unity   (26000): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (26000):
D/QCAR    (26000): Setting Unity version 4.5.2
D/QCAR    (26000): QCAR Extension version 4.2.3
D/QCAR    (26000): Initializing Vuforia...
I/Unity   (26000): QCAR initialization successful
I/Unity   (26000):
I/Unity   (26000): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (26000):
D/QCAR    (26000): trackerManagerInitTracker
D/QCAR    (26000): trackerManagerInitTracker
I/Unity   (26000): SetHint
I/Unity   (26000):
I/Unity   (26000): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (26000):
I/Unity   (26000): SetHint
I/Unity   (26000):
I/Unity   (26000): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (26000):
I/Unity   (26000): SetHint
I/Unity   (26000):
I/Unity   (26000): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (26000):
I/Unity   (26000): StartQCAR
I/Unity   (26000):
I/Unity   (26000): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (26000):
D/QCAR    (26000): cameraDeviceInitCamera
D/QCAR    (26000): cameraDeviceGetVideoMode
I/Unity   (26000): Using default scene scale for device: 1
I/Unity   (26000):
I/Unity   (26000): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (26000):
D/QCAR    (26000): cameraDeviceSelectVideoMode
D/QCAR    (26000): cameraDeviceStartCamera
D/QCAR    (26000): markerTrackerStart
D/QCAR    (26000): objectTrackerStart
D/QCAR    (26000): targetFinderStartInit
D/QCAR    (26000): targetFinderGetInitState
D/QCAR    (26000): cameraDeviceGetVideoMode
D/QCAR    (26000): targetFinderGetInitState
D/QCAR    (26000): cameraDeviceGetVideoMode
D/QCAR    (26000): targetFinderGetInitState
D/QCAR    (26000): targetFinderGetInitState
D/QCAR    (26000): targetFinderGetInitState
D/QCAR    (26000): targetFinderGetInitState
 

Black screen when app installed first time

June 2, 2015 - 7:11am #21

The logs you pasted do not show any error or useful details on why the crash might occur; 

try one of these commands from the console:

adb logcat -s QCAR Unity

(this will show all Logs that are logged by the Vuforia native SDK and by Unity)

 

or, you can filter the Logs by level; for example, the following will report all errors:

adb logcat *:E

 

 

Black screen when app installed first time

June 2, 2015 - 7:01am #20

Please check the log and when i scan the image i'm getting metadata value but after that suddenly the app is crashing.

 

GL_EXT_debug_marker GL_OES_texture_npot GL_OES_compressed_ETC
1_RGB8_texture GL_OES_standard_derivatives GL_OES_EGL_image GL_OES_depth24 GL_AR
M_rgba8 GL_ARM_mali_shader_binary GL_OES_depth_texture GL_OES_packed_depth_stenc
il GL_EXT_texture_format_BGRA8888 GL_EXT_blend_minmax GL_OES_EGL_image_external
GL_OES_EGL_sync GL_OES_rgb8_rgba8 GL_EXT_multisampled_render_to_texture GL_EXT_d
iscard_framebuffer GL_OES_get_program_binary GL_ARM_mali_program_binary GL_EXT_s
hader_texture_lod GL_EXT_robustness GL_OES_depth_texture_cube_map
I/Unity   (22515): Setting BehaviourComponentFactory
I/Unity   (22515):
I/Unity   (22515): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (22515):
I/Unity   (22515): Trackable  lost
I/Unity   (22515):
I/Unity   (22515): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (22515):
I/Unity   (22515): QCAR initialization successful
I/Unity   (22515):
I/Unity   (22515): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (22515):
I/Unity   (22515): SetHint
I/Unity   (22515):
I/Unity   (22515): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (22515):
I/Unity   (22515): SetHint
I/Unity   (22515):
I/Unity   (22515): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (22515):
I/Unity   (22515): SetHint
I/Unity   (22515):
I/Unity   (22515): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (22515):
I/Unity   (22515): StartQCAR
I/Unity   (22515):
I/Unity   (22515): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (22515):
I/Unity   (22515): Using default scene scale for device: 1
I/Unity   (22515):
I/Unity   (22515): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (22515):
I/Unity   (22515): Cloud Reco initialized
I/Unity   (22515):
I/Unity   (22515): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (22515):
I/Unity   (22515): Metadata : {"http://studio.xplorear.com/media/0PtSk1spWWhsXX.
jpg"}
I/Unity   (22515):
I/Unity   (22515): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (22515):
I/Unity   (22515): Trackable Cloth lost
I/Unity   (22515):
I/Unity   (22515): (Filename: ./artifacts/AndroidManagedGenerated/UnityEngineDeb
ug.cpp Line: 49)
I/Unity   (22515):

Black screen when app installed first time

June 2, 2015 - 3:24am #19

Could you check the logs with adb logcat and see if there is any error message around the crash ?

Also, check again all the steps in the Migration guide:

https://developer.vuforia.com/library/articles/Solution/How-To-Migrate-a-Unity-Project

and make sure to Close your Unity project, delete the Library folder as well as the "obj" and "Temp" directories, then reopen the Unity project and verify that your Unity project does not reveal any error in the Console. 

Black screen when app installed first time

June 2, 2015 - 3:03am #18

I don't know what and where is the error. Still it crashing the app. Please help me.

Black screen when app installed first time

June 2, 2015 - 1:28am #17

Same code i'm using and the same code working fine with 4.0.103 but it's not working with 4.2.3. It's working fine with unity editor but it's not working in mobile. Please help me and already i sent my project link for download and test because i tried all the ways what you mentioned. No luck. Please do the needful.

Black screen when app installed first time

June 2, 2015 - 1:25am #16

I tested the Tutorial setup and code on 3 different devices and I did not observe any crash;

this is the complete test code I used:

using UnityEngine;
using System.Collections;
using Vuforia;

public class SimpleCloudHandler : MonoBehaviour, ICloudRecoEventHandler
{
    public ImageTargetBehaviour ImageTargetTemplate;

    private CloudRecoBehaviour mCloudRecoBehaviour;
    
    private bool mIsScanning = false;
    private string mTargetMetadata = "";

    // Use this for initialization
    void Start()
    {
        // register this event handler at the cloud reco behaviour
        mCloudRecoBehaviour = GetComponent<CloudRecoBehaviour>();
        if (mCloudRecoBehaviour)
        {
            mCloudRecoBehaviour.RegisterEventHandler(this);
        }
    }

    public void OnInitialized()
    {
        Debug.Log("Cloud Reco initialized");
    }

    public void OnInitError(TargetFinder.InitState initError)
    {
        Debug.Log("Cloud Reco init error " + initError.ToString());
    }

    public void OnUpdateError(TargetFinder.UpdateState updateError)
    {
        Debug.Log("Cloud Reco update error " + updateError.ToString());
    }

    public void OnStateChanged(bool scanning)
    {
        mIsScanning = scanning;

        if (scanning)
        {
            // clear all known trackables
            ObjectTracker tracker = TrackerManager.Instance.GetTracker<ObjectTracker>();
            tracker.TargetFinder.ClearTrackables(false);
        }
    }

    // Here we handle a cloud target recognition event
    public void OnNewSearchResult(TargetFinder.TargetSearchResult targetSearchResult)
    {
        // do something with the target metadata
        mTargetMetadata = targetSearchResult.MetaData;

        Debug.Log("Metadata : " + targetSearchResult.MetaData);

        if (ImageTargetTemplate)
        {
            // enable the new result with the same ImageTargetBehaviour:
            ObjectTracker tracker = TrackerManager.Instance.GetTracker<ObjectTracker>();
            ImageTargetBehaviour imageTargetBehaviour =
                (ImageTargetBehaviour)tracker.TargetFinder.EnableTracking(
                    targetSearchResult, ImageTargetTemplate.gameObject);
        }

        // stop the target finder (i.e. stop scanning the cloud)
        mCloudRecoBehaviour.CloudRecoEnabled = false;
    }

    void OnGUI()
    {
        // Display current 'scanning' status
        GUI.Box(new Rect(100, 100, 200, 50), mIsScanning ? "Scanning" : "Not scanning");

        // Display metadata of latest detected cloud-target
        GUI.Box(new Rect(100, 200, 200, 50), "Metadata: " + mTargetMetadata);

        // If not scanning, show button 
        // so that user can restart cloud scanning
        if (!mIsScanning)
        {
            if (GUI.Button(new Rect(100, 300, 200, 50), "Restart Scanning"))
            {
                // Restart TargetFinder
                mCloudRecoBehaviour.CloudRecoEnabled = true;
            }
        }
    }
}

The setup is using an App License Key for SDK 4.2.3 (which I generated few hours ago on my test account) and the Cloud Access and Secret Keys copy-pasted from the official Cloud Reco sample of Vuforia SDK 4.2.3  

 

The result shows a Cube when the stones (or chips) target is detected; the GUI allows the user to restart the scanning.

See also attached screenshot.

 

AttachmentSize
Image icon CloudReco-simple-cube-test.png1.48 MB

Black screen when app installed first time

June 2, 2015 - 12:40am #15

The code what you given in the link is working fine with 4.0.103. This is what i'm telling from first but the same code don't work with 4.2.3. Please check early and let me know because i need to release my app soon.

https://developer.vuforia.com/forum/faq/unity-how-do-i-create-simple-cloud-reco-app

Black screen when app installed first time

June 1, 2015 - 11:50pm #14

Let me double check again; I'll make the same exercise and let you know..

Black screen when app installed first time

June 1, 2015 - 11:47pm #13

Hello,

 I've setup with new project and when i installed the app first time it gets crashed and when i scan the tracker image then the camera freeze and the app crasshed. Not sure, what is happening. Please it's frustrating because i thought to release my app on last week but due to this issue it's getting too late. 

 

Android version 4.3, 4.4.1, 4.4.4, 5 not working but it works fine in unity editor.

Black screen when app installed first time

June 1, 2015 - 11:16pm #12

Have you tried the Video Playback sample and the Cloud Reco sample unity-packages from 4.2.3 ? 

Regarding the Cloud Reco code that you reported below, I believe you're referring to this little tutorial (as the code snippets seem to be basicaly copied from there):

https://developer.vuforia.com/forum/faq/unity-how-do-i-create-simple-cloud-reco-app

This should work fine on 4.0 as well as 4.2.3; a quick test to try is to setup a fresh new mini project with 4.2.3 and the code of the Tutorial above and see if that works.

 

Black screen when app installed first time

June 1, 2015 - 1:41pm #11

@Alessandro: Did you check your unity video playback 4.2.3 sample code? Does it works fine? I tried to run your sample code into unity and when i run into android mobile then scan the tracker image, it's crashing. So, maybe you've some issue in your cloud reco code. that's why for me also getting error.

Please check proper and let me know.

 

Black screen when app installed first time

June 1, 2015 - 1:25pm #10

Please anyone help on this. Why the app is crashing when use below line, mCloudRecoBehaviour.CloudRecoEnabled = false;

Black screen when app installed first time

June 1, 2015 - 12:15pm #9

I've done that but when i scan the image then the app cameraview is freezing. I've combined cloud reco and video playback. Do i need to change anything? When i use below line then the app is crashing but when i don't use this line, the camera is freezing when target detect.

mCloudRecoBehaviour.CloudRecoEnabled = false;

 

public CloudRecoBehaviour mCloudRecoBehaviour;

 

void Start () {
 
mCloudRecoBehaviour = GetComponent<CloudRecoBehaviour>();
if (mCloudRecoBehaviour)
{
mCloudRecoBehaviour.RegisterEventHandler(this);
}
}
 
public void OnInitialized() {
Debug.Log ("Cloud Reco initialized");
}
 
public void OnInitError(TargetFinder.InitState initError) {
Debug.Log ("Cloud Reco init error " + initError.ToString());
}
 
public void OnUpdateError(TargetFinder.UpdateState updateError) {
Debug.Log ("Cloud Reco update error " + updateError.ToString());
}
 
public void OnStateChanged(bool scanning) {
 
mIsScanning = scanning;
 
if (scanning)
{
ObjectTracker tracker = TrackerManager.Instance.GetTracker<ObjectTracker>();
tracker.TargetFinder.ClearTrackables(false);
}
}
 
public void OnNewSearchResult(TargetFinder.TargetSearchResult targetSearchResult) {
 
if (!ImageTargetTemplate) { // is it ok to put it here ???
return;
}
 
 
mTargetMetadata = targetSearchResult.MetaData; // this is  the JSON URL
Debug.Log ("Metadata="+ mTargetMetadata);
 
JSONObject json = JSONObject.Parse(mTargetMetadata);
 
mCloudRecoBehaviour.CloudRecoEnabled = false;
 
}
 
 
 

 

Black screen when app installed first time

June 1, 2015 - 12:03pm #8

Have you also removed the libVuforia.so in Plugins/Android/lib/armeab-v7a ?

 

Black screen when app installed first time

June 1, 2015 - 9:12am #7

I tried to upgraded into vuforia 4.2 of my app but when i install the app, the app is crashing in my mobile. I tried below for upgraded,

Deleted Scripts folder under Editor/QCAR
Deleted PostProcessingBuilder under Editor
Deleted Qualcomm Augmented Reality Folder
Deleted vuforia, QCARUnityPlayer jar under plugins/Android
Imported 4.2.3 version
 
as an additional tip, you could close Unity, remove the Library folder under your project directory, then reopen the project in Unity.

Black screen when app installed first time

June 1, 2015 - 9:11am #6

Hi,

There wasn't any error. There was even "QCAR initialization succesfull" message. The error appears on Android 4.4.2, but  on 4.4.4 and 5 are no longer. After that error I can't use default camer app from system, until I reboot device. App works well on iOS becasue I don't use split obb.

Also "black screen' it's camera color from unity.  

I fix this error by upgrading app with Vuforia 4.2.

Black screen when app installed first time

June 1, 2015 - 9:08am #5

I'm running with unity Android not iOS. I'm facing with all version of OS. But when i connect the mobile to the unity edtior and run then it's working fine but when i generated the apk and copy into mobile device then install, i'm getting black screen error. I'm not sure why this happening but same code working fine with vuforia 3 version. But in vuforia 4.0.103 is not working.

In Unity Editor it's working fine.

Black screen when app installed first time

June 1, 2015 - 8:52am #4

Hi,

you mention a generic "black screen" issue, but it is hard to tell what it is about, without any additional information about your application and your device and OS version;

however, this sounds like an initialization error, which you can reveal by checking the Logs of your App using "ADB logcat";  it is possible that you're facing an error like "Invalid App Key", "Missing App Key" or "Network connection error";

Also, are you using an Init Error Handler ? Vuforia provides a convenient Default Initialization Error Handler script that you can attach to your ARCamera and which will display a dialog on the screen if an error occurred at initialization time; this may tell what goes wrong.

The Vuforia Samples also provide an example of Init Error Handler usage.

 

 

Black screen when app installed first time

June 1, 2015 - 7:37am #3

I'm using unity 4.5.2 and vuforia 4.0.103 but i don't have any split obb, i've generated only apk file with size of 18MB. What i've to do. Tomorrow i've plan to release my app but getting this issue. Any other solution to fix this? Please help

Black screen when app installed first time

June 1, 2015 - 1:17am #2

Hi,

I have simmilar problem. I use Unity 4.6.3 and Vuforia 4.0.103. Apps with obb split have black screen on camera view at first run.

Log in or register to post comments