Topic locked

Camera preview Black (not working) on some Android devices

October 2, 2015 - 10:22am #1

Hello!

I have received reports of Vuforia problems in some android devices. This is the app: https://play.google.com/store/apps/details?id=com.TreflSA.Roar

The problem is that when the user enters the scene with the camera preview, nothing is there, just black background. Exiting, reinstalling the app or updating android doesn't solve the issue.

This is not happening in iOS, only some android devices. This makes it hard to debug, so I would like to know if the problem is not related to the plugin but the permissions or something like this that could be avoided in a simple way.

The app has been built with different versions of Unity and the plugin and all had the same issue. At the moment is Unity 5.1 and Vuforia 5.

This are the devices that had the issue:

  • Modecom Freetab 9000 IPS
  • Dell Venue 8 7840 running Lollipop

Thanks a lot for your help,

Juan

Camera preview Black (not working) on some Android devices

October 20, 2015 - 8:51am #4

Check also the Unity 5 Player Settings:

https://developer.vuforia.com/forum/faq/unity-player-settings

A black camera / screen with Vuforia on Unity 5 is very often  caused by an incorrect setting of the Android Player Settings, in particular:

the Graphics API must be set to OpenGL ES 2.0 (and must not include any other graphics API in the list)  

and the Device Filter must be set to ARMv7 only (and not to x86 or FAT (x86 + Armv7))

Camera preview Black (not working) on some Android devices

October 5, 2015 - 12:20am #3

Please provide as many information as possible as detailed here:

https://developer.vuforia.com/forum/device-support/how-report-device-issue

 

Camera preview Black (not working) on some Android devices

October 4, 2015 - 2:42am #2

Same issue observed for me not able to display anything black flikaring screen 

I am using Unity 5.2.0.

Device Lenevo K3 Note

Please let me know if issue sorted.

Topic locked