Log in or register to post comments

Camera preview Black (not working) on some Android devices Follo

January 4, 2016 - 8:49am #1

Hello. this is a continuation of this thread: https://developer.vuforia.com/forum/unity-extension-technical-discussion/camera-preview-black-not-working-some-android-devices

This was the problem:

JuanMofables wrote:

I have received reports of Vuforia problems in some android devices. This is the app: https://play.google.com/store/apps/details?id=com.TreflSA.Roar

The problem is that when the user enters the scene with the camera preview, nothing is there, just black background. Exiting, reinstalling the app or updating android doesn't solve the issue.

This is not happening in iOS, only some android devices. This makes it hard to debug, so I would like to know if the problem is not related to the plugin but the permissions or something like this that could be avoided in a simple way.

The app has been built with different versions of Unity and the plugin and all had the same issue. At the moment is Unity 5.1 and Vuforia 5.

This are the devices that had the issue:

  • Modecom Freetab 9000 IPS
  • Dell Venue 8 7840 running Lollipop

This was the solution:

AlessandroB wrote:

Check also the Unity 5 Player Settings:

https://developer.vuforia.com/forum/faq/unity-player-settings

A black camera / screen with Vuforia on Unity 5 is very often  caused by an incorrect setting of the Android Player Settings, in particular:

the Graphics API must be set to OpenGL ES 2.0 (and must not include any other graphics API in the list)  

and the Device Filter must be set to ARMv7 only (and not to x86 or FAT (x86 + Armv7))

The situation now: Changing the Device Filter to ARMv7 only fixed the issue for some devices like the Samsung Galaxy Tab. This is fantastic! :D ...but I'm still getting reports of it.

In particular this devices still have issues:

  • MODECOM FREETAB 7001HDIC
  • LG G4

Any idea how to proceed?

Thanks a lot. :)

Camera preview Black (not working) on some Android devices Follo

March 23, 2018 - 11:18pm #5

Possible Solution:

I was using my "Samsung Galaxy Tab A6" as a "Webcam" for my "Unity Editor" with the help of "AirDroid" app. What you have to is to close/stop broadcasting "AirDroid" in order to free your camera for "Vuforia-AR" plugin to use and access.

The "Vuforia" team should provide a callback if the camera is already using by another instances.

Thanks for the solution you provided @Juan

Camera preview Black (not working) on some Android devices Follo

May 19, 2016 - 11:09am #4

I am having similar issues with the Google Pixel C. The funny thing is that I have two version in my project. One where their is a physical model using Objec Targets and another where it detects Image Targets. Object Targets never have an issue but the Image Targets randomly get the black screen. I have multiple scenes and one time it may work and another time that same scene may just go black. I have a back button that goes to the main scene and even after trying to go back with a new AR camera it's still black. tried on multiple devices and same issues. Using Unity 5.3.3 and Vuforia .5.9. I never get any errors. It just happens at random.

Camera preview Black (not working) on some Android devices Follo

January 10, 2016 - 7:52am #3

I will update here when I have the answer to the test

 

Thank you! :)

Camera preview Black (not working) on some Android devices Follo

January 7, 2016 - 3:26pm #2

Tested the LG G4 (5.1) handset with ImageTargets sample app and it works fine. Can you try to reproduce issue with G4 using new Unity project and ImageTargets sample?

https://developer.vuforia.com/downloads/samples

Log in or register to post comments