Log in or register to post comments

Camera viewport gone crazy

December 31, 2012 - 6:21am #1

Hi,

I'm having a quite strange issue here: for some reason on iOS the camera is rendered on the top right part of the screen and is not full screen. Can't pinpoint what causes this nor how to get the camera image in full screeen... I did try everything including putting the AR Camera alone in an empty scene... it's driving me crazzy... Any pointers?

Thanks,

Pino

 

Camera viewport gone crazy

January 16, 2015 - 1:00am #34

Cloud Reco will be supported in the final (non-beta) release of 4.0; this is expected soon.

I cannot share any exact date for this, but I would say you may want to keep an eye on the Vuforia website over the next few weeks.

 

Camera viewport gone crazy

January 15, 2015 - 7:47pm #33

Hi Allesandro,

 

Thank you for the suggestion. Unfortunately, we are using cloud recognition, which appears to not be supported in the latest Vuforia 4.0 beta. Do you know how soon it will be before cloud recognition is supported?

 

Thanks,
Patrick

Camera viewport gone crazy

January 15, 2015 - 4:05am #32

The camera background rendering has been revised in SDK 4.0;  so you may want to try the SDK 4.0 in its current "beta" version, which you can download from:

https://developer-beta.vuforia.com

Should you decide to upgrade, make sure to read the migration guide:

https://developer-beta.vuforia.com/library/articles/Solution/How-To-Migrate-a-Unity-Project

 

Camera viewport gone crazy

January 13, 2015 - 3:19pm #31

We are seeing this issue on Android devices (Samsung Galaxy S3, S4, and S5), using vuforia for unity 3.0.9, with Unity 4.6.0f3. The problem is intermittent. Usually on first install, the problem occurs, but after killing the app and restarting, it sometimes resolves itself.

Camera viewport gone crazy

December 4, 2014 - 12:58am #30

With vuforia-unity-android-ios-3-0-9, I noticed the same IPad3 problem, presumably an x-y offset
or scaling error for the AR camera position, when in unity, resolution = "best performance" is selected.
I think the solution of franciscoivolve would work. He was mentioning IPad4 as well.

My question is: which are the currently known ios and android devices for which the
same problem holds? And: Is the symptom the same on these other devices?

(For my app, framerate is way more important than resolution, so if it's only a
few devices, it may be worthwhile to create workarounds for them)

Camera viewport gone crazy

September 22, 2014 - 4:05pm #29

Is this occuring w/ an existing project that you've upgraded? - do you see the same w/ our latest samples?

If this is only occuring w/ an upgraded project, check our migration guides to confirm that you've ugraded correctly - https://developer.vuforia.com/resources/dev-guide/transitionmigration-guide

Camera viewport gone crazy

September 22, 2014 - 8:54am #28

Hi,

I'm having the same problem here.

I'm working on an Android device though and I recently updated both Unity and Vuforia to the newest versions.

When the AR Camera is activated on my Samsung Tab 8" its a small square at the bottom left of the screen and when it's on my Samsung Galaxy 3 phone, the screen is completely black, no camera view at all. You say about setting it to the native resolution but I cant find where abouts this is.

I've seen two things that could be related: on the AR Camera under QCARBehaviour (script), Camera Device Mode Setting is currently set to MODE_DEFAULT with other options of MODE_OPTIMIZED_SPEED and MODE_OPTIMIZED_QUALITY. Or could it be on the Image Target under Image Target Behaviour (script) there is a width (currently set to 482) and a height (currently set to 313.706)?

Thanks in advance

Camera viewport gone crazy

January 9, 2014 - 11:31am #27

@Marjan: I guess, in the Editor, if there's no BackgroundCamera, it creates one at runtime (BackgroundCamera(Clone) object) and that's how it renders video in the Editor. On devices, it uses the device native camera interface by default but when the BackgroundCamera object is present it uses that.

Camera viewport gone crazy

January 9, 2014 - 10:57am #26

ok.

But hampKaushik workaround is working. You just need to make sure you set the layers correctly.

I wasted already 2 hours trying to find BackgroundCamera(Clone) as i see that in unity, but it turned out this object is not there on the final iPad build.

I wonder though, if this setup is not there on the device, how is the video image then being rendered instead?

Camera viewport gone crazy

January 9, 2014 - 8:37am #25

On IPAd3,   only the native resolution is supported.

Camera viewport gone crazy

January 9, 2014 - 8:18am #24

Doesn´t work here with 2.8.x and Unity 4.3.2.

The camera image is shifted from bottom Left to center when setting another resolution than ipad 3 s native one.

 

Should this be fixed now? or what am i missing, since the last comment said everything was fine.

Camera viewport gone crazy

December 17, 2013 - 2:52pm #23

Works perfectly with this version!
Also noticed other improvements like the preview fully working when I hit Play in Unity.

Thanks much!

Camera viewport gone crazy

December 16, 2013 - 11:00pm #22

The 2.8 release is now available - https://developer.vuforia.com/resources/sdk/unity

Be sure to consult the migration guide when upgrading your project - https://developer.vuforia.com/resources/dev-guide/transitionmigration-guide

Camera viewport gone crazy

December 16, 2013 - 8:52am #21

thank you both for the replies!  I will try out both solutions and I look forward to the upcoming new version.  cheers!

Camera viewport gone crazy

December 15, 2013 - 10:53am #20

This is a known issue between 4.3 and 2.6.7 that will be resolved in the next release, which is due very soon. In the interim, we recommend using earlier 4.x versions of Unity.

Camera viewport gone crazy

December 15, 2013 - 10:34am #19

I faced the same problem with a Nexus 4 - camera feed is only showing on the bottom left corner. This happened once I upgraded to Unity 4.3. So, I'm guessing Unity is breaking the Vuforia camera feed pipeline somewhere as I've been using this version of Vuforia (2.6.7) for a few months now. I found a quick workaround the problem though - using Vuforia's BackgroundVideoTexture. Basically dropped in the BackgroundCamera prefab from Vuforia's standard Unity package and then added the VideoTextureBehaviour script (that is part of the BackgroundTextureAccess sample package) to the plane that is the child of the prefab. The background camera should only render the layer that the child plane belongs to.

AttachmentSize
Package icon VideoTextureBehaviour.cs_.zip3.56 KB

Camera viewport gone crazy

December 13, 2013 - 1:08pm #18

Hi,

I'm experiencing the same problem (camera image shows up in only upper left quadrant of phone screen) on my Android device (nexus 5).  However the setting for selecting Native Resolution doesn't seem to exist under Player Settins for an Android build.  Is there anything else I can do?

As for the workaround which involves adding the 2 lines of code, I'm not sure where to put them for version 2.6.7 of the extension.  Could someone describe where to insert the 2 lines instead of just the line number.  That should help people with future versions as well.

Any help is much appreciated!

Ahmad

Camera viewport gone crazy

June 26, 2013 - 2:51am #17

Just to reiterate what I stated in another thread:

At present non-native resolutions in Unity are not explicitly supported at present.  We are aware of this issue but can give no timescale on its resolution.

 

thanks

N

Camera viewport gone crazy

June 26, 2013 - 2:44am #16

Tank you,

I've been across the same problem. Unity version 4.1.3 for Mac OSX / building for Ipad 3 

File > Build Settings  click on Player Settings... button, the on the Configuration > Target Resolution set to Native

Also one of my team developer did originally change this parameter to enforce performance on his Samsung Galaxy Tab2

Camera viewport gone crazy

June 20, 2013 - 4:42am #15

hi nalin,

just sent you a pm with the link.

best,

stefan

Camera viewport gone crazy

June 20, 2013 - 2:47am #14

Hi Stefann,

Are you able to reproduce the leak with a sample Image Targets application?

If so then please send me a link where I can download the project and I will aim to investigate.

cheers,

 

N

Camera viewport gone crazy

June 19, 2013 - 7:56am #13

UPDATE for v2.5.8:

unfortunately the memory leak was not adressed. 

the code of the QCARBehaviour.cs changed a bit and these two lines now have to be added after line 299:

config.position.x -= config.size.x/2;
config.position.y -= config.size.y/2;

best,

stefan

Camera viewport gone crazy

June 17, 2013 - 7:12am #12

hi,

thanks for posting your method. i tried it and at the first moment it seems to work fine. however i found one serious problem. when implementing your modification and setting the screen resolution to 768p, there is a big memory leak (according to XCode Instruments about 0.5MB Real Mem and another o.5MB Virtual Mem). i can't see this in the unity profiler so i assume it must be some leak in the vuforia plugin.

also any other combination (code change + native resolution || no code change + 768p resolution || no code change + native resolution) works fine. i tested on an iPad 3.

are you experiencing the same or is there any workaround for that?

best,

stefan

Camera viewport gone crazy

January 30, 2013 - 1:42am #11

Thanks for this and please do let me know how you get on here with other resolutions.

N

Camera viewport gone crazy

January 29, 2013 - 2:37pm #10

 

I think I've found a workaround to that problem, I don't know if it will work on other Target Resolutions and devices, but it solves the problem for me on 720p and iPad 4 that i'm currently using on my project

Open QCARBehaviour and after line 282 add 2 new lines of code:

 

        config.position.x -= config.size.x/2;
        config.position.y -= config.size.y/2;
 

Camera viewport gone crazy

January 29, 2013 - 3:35am #9

Hi

We are investigating this issue as to why there may be a problem for other resolutions.

In the meantime please consider Native *default device" as the only Target Resolution that is currently supported by Vuforia.

thanks,

N

Camera viewport gone crazy

January 28, 2013 - 9:29pm #8

I can confirm the problem, It's not working when you set the resolution to anything different from "Target Resolution native" on iOS. Anyone has a fix for this bug?

Thanks for the report. The

January 2, 2013 - 8:52am #7

Thanks for the report. The native device resolution is significant to calibration. You can effect the render quality on the ARCamera's QCARBehaviour using the Camera Device Mode settings.

I have same problem

January 2, 2013 - 2:22am #6

I have tried all my projects and this is a consistent problem across the board.

using ipad 3, iOS 6.0.1, unity4, Xcode 4.5.2, vuforia Version 2

if you select native screen resolution when you build all is ok but if you select anything below the native resolution then the camera is only displayed in a quarter of the screen, This is a bug that i have also tried in a new blank project with the same results.

Ok - thanks. A quick test to

January 2, 2013 - 1:54am #5

Ok - thanks.

A quick test to validate this would be to create a new project and then import the Image Targets sample app via the package - should not take more than a few minutes.

Let me know if the same thing happens.

cheers

N

Solved

January 1, 2013 - 12:53pm #4

Hi there,

I've just found out what was the origin of the problem. One team dev did set the project options "Target Resolution" to "Auto (Best Performance)" and that was it. I've reverted it to "Native (Default device resolution)"  and now I have the camera rendered at full screen. 

I think that this is a bug because you should detect that and resize the render plane accordingly.

Best,

Pino

Hi, I have no image target in

January 1, 2013 - 9:12am #3

Hi,

I have no image target in the scene (yet). I'm familiarizing with the product so I've just created an empty scene and I've dragged the ARCamera prefab in it, just that, nothing else. On iPhone 4 I get the camera view like a 60% of the screen size, while on both iPhone 4S and iPad 2 it's presented at 75% of the screen size. 

This happens using the current version of Unity 4 (Pro) and the Vuforia plugin 2.0.30 downloaded from this website. I guess it's some parameter that has to be set, but I can't pinpoint which one is it.

Thanks,

Pino

 

What happens when you run the

January 1, 2013 - 4:01am #2

What happens when you run the Image Target sample right out of the box?

Does the same problem occur?

If not what causes it?

Also, what device / iOS is it and is there any way to reproduce?

 

N

Log in or register to post comments