Log in or register to post comments

Can't compile to WebGL if Vuforia it's present on project

May 16, 2015 - 3:45am #2
Unity it's multiplatform and I think there shouldn't be any problem having two different versiones of an app using Vuforia on mobile platforms and not using it in other platforms (for example, WebGL).

Now I can't and I think that it has to do with WebCamTexture references not wrapped with "#if !UNITY_WEBGL" in "Qualcomm.Vuforia.UnityExtensions.dll".


-----CompilerOutput:-stdout--exitcode: 1--compilationhadfailure: True--outfile: Temp/Assembly-CSharp-firstpass.dll

The class UnityEngine.WebCamTexture could not be loaded, used in UnityEngine, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null

-----CompilerOutput:-stderr----------



Unhandled Exception: System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.



  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)



  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 



  at Mono.CSharp.RootNamespace.ComputeNamespaces (System.Reflection.Assembly assembly, System.Type extensionType) [0x00000] in <filename unknown>:0 



  at Mono.CSharp.RootNamespace.ComputeNamespace (Mono.CSharp.CompilerContext ctx, System.Type extensionType) [0x00000] in <filename unknown>:0 



  at Mono.CSharp.GlobalRootNamespace.ComputeNamespaces (Mono.CSharp.CompilerContext ctx) [0x00000] in <filename unknown>:0 



  at Mono.CSharp.Driver.LoadReferences () [0x00000] in <filename unknown>:0 



  at Mono.CSharp.Driver.Compile () [0x00000] in <filename unknown>:0 



  at Mono.CSharp.Driver.Main (System.String[] args) [0x00000] in <filename unknown>:0 

-----EndCompilerOutput---------------

 

Can't compile to WebGL if Vuforia it's present on project

November 19, 2019 - 2:43am #1

Bump. This is a big issue for us. Such a hassle to do every time we update Vuforia or start a new project.

Log in or register to post comments