Log in or register to post comments

Carboard + Vuforia + Unity integration problem

September 28, 2015 - 5:40am #1

When I follow the steps described here:
https://developer.vuforia.com/library/articles/Solution/Integrating-Cardboard-to-the-ARVR-Sample
and here: https://developer.vuforia.com/library/articles/Solution/Integrating-Cardboard-SDK-050

I use Unity 5.2.1f1 32 bit, vuforia plugin 5.0.5 and Cardboard SDK 0.5.1

The application starts as expected but when I point the camera at a target (stone), the frustrum seems to move instead of showing the image I want to display on top of the target. Does anyone know what I am doing wrong?

I attached two screenshot to illustrate my problem

Carboard + Vuforia + Unity integration problem

September 29, 2015 - 7:25am #4

what is the size of your Target(s) (as specified in your Dataset.xml file...)

what value are your Near and Far Clipping Planes set to ?

 

 

Carboard + Vuforia + Unity integration problem

September 29, 2015 - 4:53am #3

Thanks for the answer! I tried to set stereo Multiplier in the Main camera of the CardboardMain asset to 0 and I updated stereo cameras. I rebuilt and run the application. Sadly it did not solve my problem. The AR/VR demo works fine with both cameras works fine. I am quite perplex.

 

Carboard + Vuforia + Unity integration problem

September 29, 2015 - 1:13am #2

It sounds like you may need to reduce the Stereo Multiplier parameter in the Cardboard "Main Camera" object (under Cardboaed Head); try to first set it to zero, then if that solves the problem, try to increase it a bit, e.g. using values between [0.01 and 0.1] for example, until you find one that looks good to you.

 

Log in or register to post comments