Log in or register to post comments

CommandInvokationFailure: Failed to re-package resource

September 19, 2016 - 9:00am #1

Greetings,

Firstly -thanks for a fantastic library :)

Im running into an issue when deploying my app and was hoping someone could help.  Ive searched around for some time today but altho there are many CommandInvokationFailure errors around on google none of the posts seemed to be the same as my issue.  

Steps to create issue:

  1. Create Fresh Unity app,
  2. Import vuforia-unity-6-0-117.unitypackage,
  3. Set UnityPlayer variables to be able to build (com.package etc)
  4. Build and run

Received Error:

CommandInvokationFailure: Failed to re-package resources.

E:\MyInstalls\ADK\build-tools\21.1.2\aapt.exe package --auto-add-overlay -v -f -m -J gen -M AndroidManifest.xml -S "res" -I "E:/MyInstalls/ADK\platforms\android-24\android.jar" -F bin/resources.ap_

stderr[

res\values\strings.xml:4: error: Error parsing XML: junk after document element

]



< SNIP>

This error is happening when it recreates the strings.xml file in the staging area in the unity project folder (at \Temp\StagingArea\res\values).When you open the strings.xml file afterward i can see the Junk it refers to - as it generates the last line of xml (line 4) as:

</resources>s>

Deleting the superfluous "s>" does not work as its generated on each build.

Things ive tried :

  • Completely deleting android SDK and re-downloading from scratch
  • Tried 2 different versions of the vuforia plugin (6.0.114 and 6.0.117)
  • Using 32 bit instead of 64 bit Unity
  • Using different versions of build tools (24,22,21,20)

Other info:

  • Im using win 10 with Unity 5.4.0
  • Im left scratching my head.  Where does it get that file from during the packaging process so i can delete the superfluous characters?
  • Any help is really appreciated.

Best regards

Log in or register to post comments