Log in or register to post comments

Could Not Connect Pins

March 28, 2013 - 6:51am #1

Things were working fine until about 5:30 last night, when I got this error:

 

Could not connect pins - RenderStream()
UnityEngine.WebCamTexture:Play()
WebCamTexAdaptorImpl:Play() (at Assets/Qualcomm Augmented Reality/Scripts/Internal/WebCamTexAdaptorImpl.cs:63)
WebCamImpl:StartCamera() (at Assets/Qualcomm Augmented Reality/Scripts/Internal/WebCamImpl.cs:228)
CameraDeviceImpl:StartCameraDevice() (at Assets/Qualcomm Augmented Reality/Scripts/Internal/CameraDeviceImpl.cs:370)
CameraDeviceImpl:Start() (at Assets/Qualcomm Augmented Reality/Scripts/Internal/CameraDeviceImpl.cs:115)
QCARBehaviour:StartQCAR() (at Assets/Qualcomm Augmented Reality/Scripts/QCARBehaviour.cs:553)
QCARBehaviour:Start() (at Assets/Qualcomm Augmented Reality/Scripts/QCARBehaviour.cs:358)

 

I have no idea what it means or how to fix it, as nothing I did in my code effects it (that is, hitting undo a bunch of times has no effect).

Could Not Connect Pins

April 8, 2016 - 3:44am #7

Solved the issue.

It proved to be a directshow filter problem, not vuforia specific.

Skype and other applications had no problems using webcam, but unity WebCamTexture displayed this error.

The fix turned out to be - install K Lite codec pack. During early installation it detects codec problems - and fixes them automatically. Other direct show filter issue detectors did not work for me.

 

Thx K-Lite!

Could Not Connect Pins

April 6, 2016 - 4:56am #6

Hving just the same error right now.

Unit 5.1 & 5.3, different projects - all showing the same error - could not connect video pins.

Reinstalling unity won't help.

Reenabling webcam too.

Attaching other webcams does not help either.

Other webcam applications work perfectly fine with all the cameras tested.

 

Win 10 64, Unity 32, Vuforia 559

Could Not Connect Pins

March 29, 2013 - 6:52am #5

Will do

Could Not Connect Pins

March 28, 2013 - 10:37am #4

 

Good. If you encounter the problem again, you may want to submit a bug to Unity immediately after the event so that he error is captured in the Editor log. Then PM me w/ the ID and I'll track it as well.

Could Not Connect Pins

March 28, 2013 - 10:04am #3

Windows 7, Unity  3.5.7f

The component inspector didn't show any errors and there were no pre-build errors.

Know what fixed it?

Unplugging and replugging the webcam.

Could Not Connect Pins

March 28, 2013 - 7:55am #2

What is the OS of your dev system and which Unity version are you using?

Also please check the WebCam Behaviour component panel in the Inspector to see whether there are any error messages. Sometimes Unity doesn't properly recognize its license version, which can affect interactions w/ the WebCam Texture. If there is a problem, you'll see a warning in the Inspector.

And try unplugging your webcam a/o testing another.

That pin error likely arises from the underlying capture graph - a 'pin' is an I/O connection between filters.

 

Log in or register to post comments