Log in or register to post comments

Critical Error: Could not start graph

March 26, 2013 - 1:13pm #1

I get the following two errors when using this new webcam I bought today.

 

Could not start graph
UnityEngine.WebCamTexture:Play()
WebCamTexAdaptorImpl:Play() (at Assets/Qualcomm Augmented Reality/Scripts/Internal/WebCamTexAdaptorImpl.cs:63)
WebCamImpl:StartCamera() (at Assets/Qualcomm Augmented Reality/Scripts/Internal/WebCamImpl.cs:228)
CameraDeviceImpl:StartCameraDevice() (at Assets/Qualcomm Augmented Reality/Scripts/Internal/CameraDeviceImpl.cs:370)
CameraDeviceImpl:Start() (at Assets/Qualcomm Augmented Reality/Scripts/Internal/CameraDeviceImpl.cs:115)
QCARBehaviour:StartQCAR() (at Assets/Qualcomm Augmented Reality/Scripts/QCARBehaviour.cs:553)
QCARBehaviour:Start() (at Assets/Qualcomm Augmented Reality/Scripts/QCARBehaviour.cs:358)

 

Could not pause pControl
UnityEngine.WebCamTexture:Play()
WebCamTexAdaptorImpl:Play() (at Assets/Qualcomm Augmented Reality/Scripts/Internal/WebCamTexAdaptorImpl.cs:63)
WebCamImpl:StartCamera() (at Assets/Qualcomm Augmented Reality/Scripts/Internal/WebCamImpl.cs:228)
CameraDeviceImpl:StartCameraDevice() (at Assets/Qualcomm Augmented Reality/Scripts/Internal/CameraDeviceImpl.cs:370)
CameraDeviceImpl:Start() (at Assets/Qualcomm Augmented Reality/Scripts/Internal/CameraDeviceImpl.cs:115)
QCARBehaviour:StartQCAR() (at Assets/Qualcomm Augmented Reality/Scripts/QCARBehaviour.cs:553)
QCARBehaviour:Start() (at Assets/Qualcomm Augmented Reality/Scripts/QCARBehaviour.cs:358)
 

Critical Error: Could not start graph

August 23, 2016 - 6:20pm #7

it seemed that the it cannot share the camera with other applications.

Critical Error: Could not start graph

May 23, 2013 - 2:38pm #6

That is working  David, however sometimes it will release it on its own and  sometimes I have to kill the process manually.  It is not consistent.  Thanks for the help diagnosing.

Critical Error: Could not start graph

May 23, 2013 - 2:22pm #5

The screen position error is a known issue arising from Unity, but it's not critical.

It sounds like Hangout isn't releasing the camera. If you're using a USB cam, you might try unplugging it. Otherwise you could check your task manager to see if you can ID the responsible process and kill it.

Critical Error: Could not start graph

May 23, 2013 - 2:15pm #4

I'm getting the same  errors. If I launch Google Hangout I can't use AR again  without restarting my computer.

Could it be reappropriating the camera or something?  I am also getting a continuous stream of "Screen Position  out of view frustrum", but the coordinates it is giving me are withing the camera  rect it is also giving me.

Critical Error: Could not start graph

March 28, 2013 - 10:07am #3

Windows 7, Unity  3.5.7f Pro

The webcam (which is now working) is a Microsoft LiveCam...something.  High end one with a 1080 resolution.

But I got those errors right after installing it, and they went away on their own some few hours later.

Critical Error: Could not start graph

March 26, 2013 - 2:13pm #2

Do you have a Unity Pro license? And Which webcam are you seeing this error with?

Log in or register to post comments