Log in or register to post comments

Culling mask for main camera not working as expected

November 14, 2013 - 11:54am #1

I'm using Unity 4.2 and can't seem to hide objects on a certain layer from the main camera. In my ARCamera game object, I go to where is says Camera in the inspector and changed the culling mask to not include a layer I want to hide but the objects are still being rendered. How am I supposed to hidhe layers with the ARCamera?

Culling mask for main camera not working as expected

November 15, 2013 - 11:28am #5

hmm.. can you post or PM me a screen shot of your expanded hierarchy w/ the ARCamera highlighted in the Inspector?

 

* I see that you've resolved the issue - congratulations ;)

Culling mask for main camera not working as expected

November 15, 2013 - 10:45am #4

So I tried again setting the culling mask to NONE, and nothing was rendered. So I tried it again with the layer I want off being culled, and it's working as expected. Not sure what the issue was, but it's fine now.

Culling mask for main camera not working as expected

November 14, 2013 - 3:19pm #3

Yes it says mixed, and the layer I want to be culled is unchecked. The objects are two planes at y=0 that have a collider so I can do raycasting and to allow objects to rest on top of them. I even set the ARCamera's camera component's culling mask to NONE, and everything was still rendered.

Culling mask for main camera not working as expected

November 14, 2013 - 1:46pm #2

That approach should work. Does the ARCamera culling mask field say 'mixed', and have you unchecked the layer you're trying to hide?

What types of objects are in that layer?

Log in or register to post comments