Log in or register to post comments

DataSetLoadBehaviour Issue after update to Vuforia-Unity 2.32 in iOS

May 3, 2013 - 10:26am #1

I have the problem that my Unity iOS application (after update to Vuforia-Unity 2.32) crashes immediately after the start.  If I disable Load Data Set, my application is started (there is no camera image->black screen). 

The crash occurs in the DataSetLoadBehaviour_Awake...

Here is a log Section:

0xdac94:  beq    0xdacc0                   ; DataSetLoadBehaviour_Awake + 372
0xdac98:  ldr    r0, [r10]
0xdac9c:  ldr    r0, [r0]
0xdaca0:  ldr    r0, [r0, #8]
0xdaca4:  ldr    r0, [r0, #8]
0xdaca8:  ldr    r1, [pc]                  ; DataSetLoadBehaviour_Awake + 356
0xdacac:  b      0xdacb4                   ; DataSetLoadBehaviour_Awake + 360
0xdacb0:  .long  0x01248758                ; unknown opcode
0xdacb4:  ldr    r1, [pc, r1]
0xdacb8:  cmp    r0, r1
0xdacbc:  blne   0xdae20                   ; DataSetLoadBehaviour_Awake + 724
0xdacc0:  mov    r5, r10
0xdacc4:  mov    r0, r10

Where is the problem?

Thank you!

Russel

DataSetLoadBehaviour Issue after update to Vuforia-Unity 2.32 in

May 8, 2013 - 12:55am #3

Thanks for the update.

Sorry for not seeing the post earlier, as I think the forum gremlins are back :(

Keep us posted.

 

N

 

DataSetLoadBehaviour Issue after update to Vuforia-Unity 2.32 in

May 6, 2013 - 1:49am #2

Ok I could solve the problem :). When I deleted the app from the device manually, the build worked fine (clean install)

The ARCamera Black Screen comes from Neatplug Admob plugin. Here I'll try to fix the problem.

Log in or register to post comments