Log in or register to post comments

Disable masking of objects on MultiTargets?

September 6, 2012 - 6:32am #1

Hi,

I've just got a basic multitarget that displays a skybox with a little planet. The idea is you can walk around the planet as it floats in space. The only issue is that it's automatically masked out by the MultiTarget so it vanishes and due to the fact I'm using a skybox (so obviously you can't see what the camera is seeing) it appears to vanish behind a silhouette of a box.

 

Is there a way to dissable this?

 

Chris

Disable masking of objects on MultiTargets?

September 18, 2012 - 9:24am #5

You can try replacing the depthmask material in Qualcomm Augmented Reality / Materials with a dummy material that doesn't use a depth masking shader. You'll need to name this DepthMask, because the MultiTarget's child targets are configured to use this material by default.

Disable masking of objects on MultiTargets?

September 6, 2012 - 6:35pm #4

I've looked at occlusion and I don't think that's what I'm after. Basically I don't want Vuforia to go to the effort of clipping objects so that they appear to go behind something, I just want everything to be visible.

Disable masking of objects on MultiTargets?

September 6, 2012 - 9:26am #3

Take a look at the Occlusion Management sample - is that the effect that you're trying to create?

Also the advice to try a depthmask is worth investigating.

Disable masking of objects on MultiTargets?

September 6, 2012 - 7:45am #2

Hi,

Maybe you could use the DepthMask shader, to hide some object. I think it comes with the API package, or you could find it here

Log in or register to post comments