Log in or register to post comments

Does anyone run it on NexusOne ?

November 12, 2010 - 10:52am #1

I downloaded ARExtension for Unity3.
I tried bundled sample scenes and also just ARCamera to see the video preview, however I just get blinking screen in many colors.
It seems the application is installed and running but camera input or preview has some problems.
I am using Mac OSX 10.6.4, Unity 3.1, Android 2.2 on NexusOne.

I will be appreciate that if anyone tell me it is able to run or it has problem running it.

Re: Does anyone run it on NexusOne ?

November 24, 2010 - 2:46pm #14

Switching to GLES 2.0 fixed the problem for me too. Thanks!

It still shows static garbage when launching application without killing it first, but that's fine for now.

Re: Does anyone run it on NexusOne ?

November 24, 2010 - 8:29am #13

Excellent, I'm glad it's working for you now :)

I just tested the My Trackables tool, and it seems to be working fine here. What browser are you using? I'm not sure that it works with outdated IE browsers, for instance. Also, be sure your image is under 2 MB before uploading.

If it's still not working, please open a separate thread for us to discuss. Let's keep this thread for talking about the video background bugs.

Thanks!

- Kim

Re: Does anyone run it on NexusOne ?

November 24, 2010 - 8:17am #12

Doing this change in Open GL did work for my Nexus One with Android 2.2.1! I was able to build and test the simple included image trackable file!

My next issue is how do you build your own images? I am uploading the images, the Qualcomm site is processing them (takes forever), and then returns a white screen. I then go back to "my trackables" area, two versions on the image are listed. When I try to analyze I get this message:

Failed to open file : /var/www/webapps/qdevnet/sites/default/files/users/TheLorax/Marker_Test/marker_jpg/marker_jpg.quick_report.xml

If I try to to download for a Unity Project, I get "Error creating zip file."

Again,thanks for the "fix" and any ideas on the trackable issue would be appreciated.

TheLorax

Re: Does anyone run it on NexusOne ?

November 23, 2010 - 5:56pm #11

No word just yet, other than we are making some progress.

I do want those of you who are having issues to try something though. In Unity, set your project to use OpenGL ES 2.0 instead of 1.1. To do this, go to Edit > Project Settings > Player, choose the Android icon, and expand the Other Settings section. Set the Graphics Level to OpenGL ES 2.0.

This might fix the problem in some, but not all, cases. Let me know what the results are, and be assured we're working on this!

- Kim

Re: Does anyone run it on NexusOne ?

November 22, 2010 - 8:09pm #10

Any word on the update? I would love to have something before the holiday break, but then, I'm just being greedy!!! ;) Any news welcomed.

Thanks,

TheLorax

Re: Does anyone run it on NexusOne ?

November 19, 2010 - 3:59pm #9

>Kim

I sent my logcat output and device info.
Hope it helps you in some bit :)

Re: Does anyone run it on NexusOne ?

November 19, 2010 - 2:39pm #8

Hi all,

Sorry for the lack of news, I was really hoping we'd have a fix for you this week, but it isn't ready yet.

To make things clearer, there are two separate (but perhaps related) issues here:

1) For most people, the video typically works on a fresh launch of the app (that is, the app isn't being restored from the background). It usually works when the app is restored by holding the home button and selecting it from the recent app list. It sometimes fails when the app is launched from the app list on the device.

2) For some people, the video never shows in the background (the background is either black or filled with visual artifacts). This includes a fresh launch of the app from Unity, even after a device reboot.

In either case, there may be an occasional hard crash of the device, especially on Android 2.2 devices. This is a well-known "cpu pegged" bug, and you will see that message over and over in the log output.

I'd like to get a sense of how many people are experiencing the second issue (no video at all), and what devices / OS version they are using. Also, if possible please send us the logcat output for a clean run of the ImageTargets sample app (included in the AR Unity Extension package on our website). You can send the log output in an email to this address:

Sorry for the delay on a fix, hopefully we'll have something next week!

- Kim

Re: Does anyone run it on NexusOne ?

November 19, 2010 - 10:57am #7

I get the #3 issue, black background with 3D objects displaying when pointed at the marker. Nexus One with Android 2.2.1 Really looking forward to a fix! Thanks for this.

TheLorax

Re: Does anyone run it on NexusOne ?

November 18, 2010 - 10:48am #6

Any news on an update? ;-)

Re: Does anyone run it on NexusOne ?

November 15, 2010 - 1:11pm #5

I have the same problem (on Nexus One). It would be nice to see this fixed...

Re: Does anyone run it on NexusOne ?

November 15, 2010 - 10:06am #4

Resetting the device helps only in that it's more likely to get scenario #3 from my list above. And, yes, I'm very careful to make sure it's a fresh run every time (I use Task Manager on the phone to kill the old instance or reset the phone). Also I hooked up the back key in my Unity app to actually quit instead of just going back down the activity stack and leaving it running in the background.

Glad to know it's a known issue. Looking forward to trying a refresh of the beta to see how it goes! Any idea on when that might be? (Chomping at the bit to get into this!)

Re: Does anyone run it on NexusOne ?

November 14, 2010 - 8:05am #3

This is a known issue, although it is currently unclear which devices are affected under which circumstances. We have had instances where it works perfectly well on the Nexus One (2.1 and 2.2) but other situations where it seems unstable. We're working on a fix, and hopefully there will be an update this week.

The problem seems to occur more often in low-memory conditions, where perhaps several apps are running in the background or the device's application memory is nearly full. Try rebooting your device. Also, try launching the app from Unity rather than from the device itself (this forces a fresh launch of the app).

Hopefully I'll have more information soon!

- Kim

Re: Does anyone run it on NexusOne ?

November 13, 2010 - 3:55pm #2

I have the same problem. I tried it from Windows, too, and had the same result. If I run it many times, the best I ever get (about 1 run out of 6) is that my 3D objects from Unity will appear correctly, but with no camera image behind them (only a black background). But if I aim the camera away from the image target then it crashes - a hard crash, too (have to reset the phone to get out of it).

I've tried on a Nexus One and on a Samsung Vibrant so far. I don't expect the Vibrant to work correctly due to Unity issues until Android 2.2 is released for it, but even on the Nexus One the results every run are either:

1. Crash on startup
2. Blinking colors on screen and nothing else
3. Unity objects showing up and correctly moving when the device is moved, but black background, with eventual crash once you aim the camera away from the surface.

I can provide logcat output if anyone wants it. But with such basic failures, surely this is some kind of known problem with this early beta? Is it supposed to actually be functional at all yet? Or should we be using some other devices?

Thanks for any info.

Log in or register to post comments