Log in or register to post comments

Errors in Unity After Updating to Unity 4.5.2 and Vuforia 3.0.9

August 5, 2014 - 9:05pm #1

Hi All,

 

I'm stuck.  Ever since I upgraded to Unity 4.5.2 and Vuforia 3.0.9, I've been getting compiler errors.  I followed the migration steps and I tried a bunch of other things without success.  Here are the errors I've been getting:

Assets/QCAR/SampleImport/SampleImport.cs(8,7): error CS0246: The type or namespace name `UnityEditor' could not be found. Are you missing a using directive or an assembly reference?
 
Assets/QCAR/VideoPlaybackScripts/VideoPlaybackEditor.cs(18,7): error CS0246: The type or namespace name `UnityEditor' could not be found. Are you missing a using directive or an assembly reference?
 
I haven't altered either of these scripts. Both are original code.
 
Anyone know how to fix this?
 
Thanks for your help.
 
Daniel

 

Errors in Unity After Updating to Unity 4.5.2 and Vuforia 3.0.9

August 11, 2014 - 9:03pm #4

Thank you jnagaraj :)

Errors in Unity After Updating to Unity 4.5.2 and Vuforia 3.0.9

August 11, 2014 - 9:53am #3

Glad to hear you fixed it. 

For future reference, here's a recommended way to upgrade any vuforia unity project from 2.8 to 3.0 or higher:

https://developer.vuforia.com/resources/dev-guide/migrating-your-unity-project

Also, you need to delete SampleImport folder.

 

 

Errors in Unity After Updating to Unity 4.5.2 and Vuforia 3.0.9

August 9, 2014 - 1:55am #2

Fixed.  There was an extra copy of the QCAR folder.  I deleted it and made sure all above files were in the /Assets/Editor directory.

Log in or register to post comments