Log in or register to post comments

How to manage QCAR init failure

May 26, 2015 - 3:11pm #1

Hello,

I'm using Unity 5 and Vuforia 4.105 (imageTarget, no cloud reco), and after tests on various devices I decided to test on an old smartphone, with no internet connection active, with a brand new install from Unity.

When I activated ARCamera I received an error message on a full screen panel, with a Close button. I activated the wifi, tried again, worked, disconnected wifi, worked again.

I guess on the first run it needed to perform the licence check and needed the internet connection, so my questions are:

- is the check performed only on the first run? if not, how often? may my user be unable to use the app without the internet connection for licence check?

- how can I manage the error? I don't want the black camera and the Vuforia standard error message, I'd like to do the test and activate the ARCamera only if QCAR is ok.
I've read in the help of the QCARInitErrorCallback how can I implement it?

- how is licence checking changing with Vuforia 4.2.3? (I'm not using it because of some issues with Unity 5 that I've read in the forum)

Thanks,

Mattia

 

 

How to manage QCAR init failure

May 27, 2015 - 9:43pm #2

Vuforia 4.2.3 no longer requires an Internet connection to validate the license key.

https://developer.vuforia.com/library/articles/FAQ/License-Manager-FAQ

Vuforia 4.0.105 needs an initial connection to validate the key.

You can register for the error callback using RegisterQCARInitErrorCallback().

 

Log in or register to post comments