Log in or register to post comments

Huge performance issue (camera lags like hell)

October 19, 2016 - 6:50am #1

Unity 5.4.1p4

vuforia-unity-6-0-117

Empty Project with vuforia only

Default ARcamera prefab in scene

Basic unity input field

Android build (tested on note4, galaxy s6 and galaxy s7)

 

Every time you click on the input field and the keyboard pops up, vuforia camera will lag more and more until its unusable. (3-4 keyboard pops)

It is possible that it has something to do with the OnApplicationFocus method of unity that stacks up lags on vuforia camera only (unity keeps running smoothly).

It seems that the method OnApplicationPause releases the pressure and the camera doesn't lag after it's called

 

Profilers won't show any performance issues.

 

P.S, the same lags happen when I try to use NativeToolkit to bring up native popups of messages from android or anything else thats native.

 

I need a solution

Thanks.

 

Huge performance issue (camera lags like hell)

January 15, 2018 - 11:26pm #7

I'm experiencing the same problem. I managed to sorted it out by a small trick. But looking for a better solution.

My application does not lags at the first time, but after couple of seconds (~20 seconds) camera starts to lag heavily.

Even though I'm not doing any processor intensive tasks, just looking at the marker from AR camera. Issue is still there.

Simple solution is put a UI button and assign a method to restart the current scene. This will simply solve the problem but we will lost the current state of the scene.

Another improved way is to watch app performance and after some threshold value (when lagging starts) execute commands to restart scene or restart vuforia tracking. During restart period of 1-3 seconds we can show UI message. (Or may be switching to another scene with that UI message and swithcing back to unity scene after 1 second) 

 

 

Huge performance issue (camera lags like hell)

November 27, 2017 - 11:22am #6

JimJamesJimJim wrote:

This is STILL an issue

Vuforia 6.5.22

Unity 2017.2.0f3

 

The ARCamera lagging after an input field is selected is a known issue within Unity. We are currently waiting for their solution on this issue.

Are you also seeing the camera lag when you change the wifi state as described by tangoyzx?

Thanks,

-Vuforia Support

Huge performance issue (camera lags like hell)

November 24, 2017 - 10:27am #5

This is STILL an issue

Vuforia 6.5.22

Unity 2017.2.0f3

 

Huge performance issue (camera lags like hell)

April 10, 2017 - 8:26pm #4

I am facing the problem like this, the camera will lag when i switch network, like connect to wifi , disconnect to wifi, connect, disconnect.....

 

 

Unity 5.4.1f1

vuforia 6.2.10

Empty Project with vuforia only

Default ARcamera prefab and a cube in a ImageTarget in scene

 

 

Huge performance issue (camera lags like hell)

April 10, 2017 - 2:01am #3

i am also facing the same Problem, Arcamera lags a lot and after returning from pause it works properly . Please Post a solution if you overcome this problems 

Huge performance issue (camera lags like hell)

February 1, 2017 - 1:57am #2

Did you find a solution for this?

Log in or register to post comments