Log in or register to post comments

I can't get the app to run on my Android

March 25, 2012 - 2:44pm #1

I just followed the tutorial and im getting these errors on runtime as soon as i open the app it errors and closes

03-25 14:43:07.435: E/AndroidRuntime(15314): java.lang.NoSuchMethodError: com.unity3d.player.UnityPlayer.windowFocusChanged
03-25 14:43:07.435: E/AndroidRuntime(15314): at com.qualcomm.QCARUnityPlayer.QCARPlayerSharedActivity.onWindowFocusChanged(QCARPlayerSharedActivity.java:345)
03-25 14:43:07.435: E/AndroidRuntime(15314): at com.qualcomm.QCARUnityPlayer.QCARPlayerNativeActivity.onWindowFocusChanged(QCARPlayerNativeActivity.java:77)
03-25 14:43:07.435: E/AndroidRuntime(15314): at com.android.internal.policy.impl.PhoneWindow$DecorView.onWindowFocusChanged(PhoneWindow.java:2060)
03-25 14:43:07.435: E/AndroidRuntime(15314): at android.view.View.dispatchWindowFocusChanged(View.java:3971)
03-25 14:43:07.435: E/AndroidRuntime(15314): at android.view.ViewGroup.dispatchWindowFocusChanged(ViewGroup.java:681)
03-25 14:43:07.435: E/AndroidRuntime(15314): at android.view.ViewRoot.handleMessage(ViewRoot.java:2110)
03-25 14:43:07.435: E/AndroidRuntime(15314): at android.os.Handler.dispatchMessage(Handler.java:99)
03-25 14:43:07.435: E/AndroidRuntime(15314): at android.os.Looper.loop(Looper.java:150)
03-25 14:43:07.435: E/AndroidRuntime(15314): at android.app.ActivityThread.main(ActivityThread.java:4369)
03-25 14:43:07.435: E/AndroidRuntime(15314): at java.lang.reflect.Method.invokeNative(Native Method)
03-25 14:43:07.435: E/AndroidRuntime(15314): at java.lang.reflect.Method.invoke(Method.java:507)
03-25 14:43:07.435: E/AndroidRuntime(15314): at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:846)
03-25 14:43:07.435: E/AndroidRuntime(15314): at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:604)
03-25 14:43:07.435: E/AndroidRuntime(15314): at dalvik.system.NativeStart.main(Native Method)

Re: I can't get the app to run on my Android

March 25, 2012 - 6:12pm #2

Try updating Unity, Vuforia 1.5 requires Unity 3.4.2 as a minimum.

- Kim

Log in or register to post comments