Log in or register to post comments

Imported Animation Orientation Problem

March 9, 2013 - 11:59am #1

HI

 

I recently had an animation created (it was done in Lightwave) and then exported to FBX. Pretty much all of the smoke and fire animations don't work and I have made peace with that and I am creating them in Unity using the Particle System. 

The next issue I have is that no matter how many times I align the animation with my Image Targe,t when I deploy to my phone the animation always plays 90 degrees / perpendicular to the Image Target.

I was hoping someone might have experienced these issues before ? I am not sure if its a problem with the actual animation that was created and somehow when it deploys to my phone it resets to some phantom co ordinate system, or if theres a way I can fix this problem in unity.

In the preview camera the animation plays as I defined: in front of the trackable, its just when I deploy to my Galaxy s2 that I see the issue of the animation orientation change.

 

Regards

Leon

Imported Animation Orientation Problem

March 23, 2013 - 2:00pm #3

Hi

 

Thanks for the feedback. The game object worked better than my earlier attempts.

Though even though I have lined the animation  perfectly using the game object when I view the deployed app, the border is not flush with the image target.  One side seems to be elevated, I tried to offset this by offsetting the actual animation on the image target but this doesnt work as well.

I am really puzzled. I can share the FBX file I have perhaps ? or send some screenshots.

regards

Leon

Imported Animation Orientation Problem

March 9, 2013 - 3:32pm #2

The first thing to try, is to add an empty game object as a child of your ImageTarget, and then make your animated model(s) a child of that game object. Animations are often designed w/ the assumption that they are running in world space, but when they are parented by an ImageTarget they are running in the local space of the ImageTarget instance, which can cause problems. Intermediating the parenting w/ another game object enables the animation to run independently of the ImageTarget space.

Vuforia doesn't have any effect on animations, it's the Unity hierarchy that is affecting the animation.

Also you should be able to get the particle animation to run. Here is an example of one working in a Vuforia AR scene - http://www.youtube.com/watch?v=R01m6A-Wli4

If these tips don't help, please post or PM me a screen grab of your project Hierarchy.

Log in or register to post comments