Log in or register to post comments

Importing Vuforia 6.1.7 into Unity 5.5.0f3 causes errors

December 19, 2016 - 1:26pm #1

On Windows 10 64bit, I am running Unity 5.5.0f3.  When I attempt to import Vuforia 6.1.7, I get these warnings:

Assembly: 'Assets/Vuforia/Scripts/Internal/Vuforia.UnityExtensions.dll' uses obsolete Unity API (UnityUpgradable)

OnLevelWasLoaded was found on KeepAliveBehaviour

This message has been deprecated and will be removed in a later version of Unity.

Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

OnLevelWasLoaded was found on WebCamBehaviour

This message has been deprecated and will be removed in a later version of Unity.

Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

Assets/Vuforia/Scripts/Utilities/VRIntegrationHelper.cs(100,29): warning CS0618: `UnityEngine.Camera.SetStereoProjectionMatrices(UnityEngine.Matrix4x4, UnityEngine.Matrix4x4)' is obsolete: `SetStereoProjectionMatrices is deprecated. Use SetStereoProjectionMatrix(StereoscopicEye eye) instead.

'Assets/Vuforia/Scripts/Utilities/VRIntegrationHelper.cs(101,30): warning CS0618: `UnityEngine.Camera.SetStereoProjectionMatrices(UnityEngine.Matrix4x4, UnityEngine.Matrix4x4)' is obsolete: `SetStereoProjectionMatrices is deprecated. Use SetStereoProjectionMatrix(StereoscopicEye eye) instead.'

OnLevelWasLoaded was found on KeepAliveBehaviour

This message has been deprecated and will be removed in a later version of Unity.

Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

OnLevelWasLoaded was found on WebCamBehaviour

This message has been deprecated and will be removed in a later version of Unity.

Add a delegate to SceneManager.sceneLoaded instead to get notifications after scene loading has completed

Can I ignore these or do I need to change something?

 

Importing Vuforia 6.1.7 into Unity 5.5.0f3 causes errors

November 25, 2018 - 2:06am #3

anyone figure this out? i have the same problem

Importing Vuforia 6.1.7 into Unity 5.5.0f3 causes errors

December 28, 2016 - 2:27pm #2

They are just deprecation warnings. Let Unity 5.5 upgrade the scripts when you import Vuforia 6.1 or 6.2. It should still work fine.

Log in or register to post comments