Log in or register to post comments

ios 6.0 building error with unity 3.5.2f2

September 25, 2012 - 4:30am #1

Hi guys!

i can't build my project on my ipad with ios 6.0 with unity 3.5.2f2 + xcode 4.5

errors:

 

Ld /Users/Home/Library/Developer/Xcode/DerivedData/Unity-iPhone-bgtzgvyxjfcdyjhfayasijpgqwow/Build/Products/logoloop.app/logoloop normal armv7

    cd /Users/Home/Desktop/INIMAN/AR/LAVORI/LOGOLOOP_AR/BUILDS/LOGOLOOP00

    setenv IPHONEOS_DEPLOYMENT_TARGET 5.0

    setenv PATH "/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/usr/bin:/Applications/Xcode.app/Contents/Developer/usr/bin:/usr/bin:/bin:/usr/sbin:/sbin"

    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang++ -arch armv7 -isysroot /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS6.0.sdk -L/Users/Home/Library/Developer/Xcode/DerivedData/Unity-iPhone-bgtzgvyxjfcdyjhfayasijpgqwow/Build/Products -L/Users/Home/Desktop/INIMAN/AR/LAVORI/LOGOLOOP_AR/BUILDS/LOGOLOOP00 -L/Users/Home/Desktop/INIMAN/AR/LAVORI/LOGOLOOP_AR/BUILDS/LOGOLOOP00/Libraries -F/Users/Home/Library/Developer/Xcode/DerivedData/Unity-iPhone-bgtzgvyxjfcdyjhfayasijpgqwow/Build/Products -filelist /Users/Home/Library/Developer/Xcode/DerivedData/Unity-iPhone-bgtzgvyxjfcdyjhfayasijpgqwow/Build/Intermediates/Unity-iPhone.build/Debug-iphoneos/Unity-iPhone.build/Objects-normal/armv7/logoloop.LinkFileList -dead_strip -all_load -weak_framework CoreMotion -weak-lSystem -fobjc-link-runtime -miphoneos-version-min=5.0 -framework Security -framework Foundation -framework UIKit -framework OpenGLES -framework QuartzCore -framework OpenAL -liconv.2 -lQCAR -lQCARUnityPlayer -lVuforiaMedia -liPhone-lib -framework AudioToolbox -framework CFNetwork -framework MediaPlayer -framework CoreLocation -framework SystemConfiguration -weak_framework iAd -framework CoreMedia -framework CoreVideo -weak_framework AVFoundation -framework CoreGraphics -weak_framework CoreMotion -weak_framework GameKit -o /Users/Home/Library/Developer/Xcode/DerivedData/Unity-iPhone-bgtzgvyxjfcdyjhfayasijpgqwow/Build/Products/logoloop.app/logoloop

 

Undefined symbols for architecture armv7:

  "ConvertToUnityScreenOrientation(int, EnabledOrientation*)", referenced from:

      -[UnityViewController shouldAutorotateToInterfaceOrientation:] in AppController.o

      -[UnityViewController willRotateToInterfaceOrientation:duration:] in AppController.o

      -[UnityViewController didRotateFromInterfaceOrientation:] in AppController.o

ld: symbol(s) not found for architecture armv7

clang: error: linker command failed with exit code 1 (use -v to see invocation)

 

 "ConvertToUnityScreenOrientation(int, EnabledOrientation*)", referenced from:

 

 -[UnityViewController shouldAutorotateToInterfaceOrientation:] in AppController.o

 

 -[UnityViewController willRotateToInterfaceOrientation:duration:] in AppController.o

 

 -[UnityViewController didRotateFromInterfaceOrientation:] in AppController.o

 

 Symbol(s) not found for architecture armv7

 

 Linker command failed with exit code 1 (use -v to see invocation)

 

 

could it be the old unity version?

any suggestions?

 

thanks a lot guys

 

Francesco

 

 

 

 

 

 

 

 

 

 

ios 6.0 building error with unity 3.5.2f2

November 15, 2012 - 11:42am #4

"ConvertToUnityScreenOrientation(int, EnabledOrientation*)", referenced from:

yeah im on unity 3.5.2 i want to upgrade to 3.5.6 but when i click update it tries to force me to updateto 4.0, 

alas my licences are valid with 3x only so i need to find a legacy installer of 3.5.6......

anyone happen to have this?

 

ios 6.0 building error with unity 3.5.2f2

November 7, 2012 - 4:55am #3

You need to upgrade to the latest version of Unity 3.5.6f4.

Check their release notes :)

N

ios 6.0 building error with unity 3.5.2f2

November 6, 2012 - 3:17pm #2

same problem wirh unity 3.5.0 , xcode 4.5.2 and ios 6.0.1 

everything just to work fine. 

Log in or register to post comments