Topic locked

iOS Linker Error Undefined symbols?

January 15, 2015 - 8:08am #1

Hi All,


I am trying to build a Vuforia application for iOS and I am getting a strange linker error:

Undefined symbols for architecture armv7:

  "_setSurfaceRecreated", referenced from:

      -[VuforiaRenderDelegate onAfterMainDisplaySurfaceRecreate] in VuforiaRenderDelegate.o

  "_UnitySetGraphicsDevice", referenced from:

      -[VuforiaNativeRendererController shouldAttachRenderDelegate] in VuforiaNativeRendererController.o

ld: symbol(s) not found for architecture armv7

clang: error: linker command failed with exit code 1 (use -v to see invocation)


I've tried following the iOS/Unity suggestions stickied on here, but I can't seem to get past this error. I've removed arm64 architecture.


I am running

Xcode 6.1.1

Unity 4.6.1

iOS Linker Error Undefined symbols?

January 20, 2015 - 7:01am #3

I'm not 100% sure what fixed it, but I tracked it down to some kind of conflict due to Vuforia and another plugin (in my case Soomla). I had to reimport the Vuforia unity package as well as the Soomla package and it seemed to fix the problem. Just wanted to share with everyone else in case they run into this weird issue.

iOS Linker Error Undefined symbols?

January 19, 2015 - 4:40pm #2

You might want to try compiling an empty Unity project to your iOS device to verify your system settings are working. If that works, try compiling a simple scene with a Unity camera and a cube and if that works, then compile one of the Vuforia sample projects.


Topic locked