Log in or register to post comments

Jittery Tracking

August 20, 2014 - 2:09pm #22

I've been using Vuforia for a couple of years now. Usually, even low-rated targets track very well. But recently, it seems to have gotten worse. Even 5-star targets are jittery in the latest version of Vuforia (3.0.9) with the latest version of Unity (4.5.3). I recently upgraded two projects (followed the upgrade guide as I have done many times before) to stay up to date with the latest versions of Vuforia and Unity. Now they both are experiencing jittery tracking that nobody noticed before but is immediately noticeable now.

I did a test -- I compared an old demo app from summer 2012 to a new app I just created with the latest versions of Vuforia and Unity (both running on an iPad 3). The apps use the same target, a 3-star rated page from a book. The older app has steady tracking with no noticeable jitter, while the new app is jittery.

Has anyone else experienced this? I'm not sure what to try next. I've tried it on other devices and a client has reported jitters on their end as well, so it's not a faulty camera. I've tried all the usual adjustments (no extended tracking, camera auto-focus mode, changed lighting conditions). I'll continue testing and update if I find out what's going wrong.

Thanks for your help.

Jittery Tracking

August 26, 2014 - 1:18pm #21

If I create a a new project (Unity 4.5.3) and download/import the ImageTarget sample with the stones/chips/tarmac targets, the tracking is very jittery. It's worst on the iPad 3. It's less noticeable but still there on the iPhone 5 and on an Android Galaxy S3. Also less noticeable in the editor/webcam. I can best describe it as constant small movements and jumping. I can't be the only person experiencing this. I haven't had any problems like this in the past.

Jittery Tracking

August 28, 2014 - 4:47pm #20

Garing, we are facing the same issue here using latest version of unity 4.5.3 and Vuforia Unity SDK 3.0.9

Jittery Tracking

August 28, 2014 - 6:12pm #19

I reverted to Unity 4.3.4 and Vuforia 2.8.7 and tracking is much more stable. I tried a bunch of different combinations and couldn't quite figure out where exactly things went wrong as I ran into some other issues. I'll stick with this combo until a new version of Vuforia comes out.

Jittery Tracking

September 3, 2014 - 2:02pm #18

Is the jittery tracking present when using Unity 4.3.4 and Vuforia 3.0.9? I am using Unity 4.5.1f3 and Vuforia 3.0.9 and the tracking appears solid.

Jittery Tracking

September 4, 2014 - 5:42am #17

Yes, Unity 4.3.4 and Vuforia 3.0.9 is jittery.

Here are some gifs from this combination... I created a new project and imported 3.0.9 and the latest ImageTarget sample. I replaced the "chips" target with another 5-star target. App is running on an iPad 3. I am recording with my phone, tried to keep my hand movement minimal but there is some hand movement. The jitters are much  worse on the custom target.

Custom target: http://i.imgur.com/2AtCCsi.gif

Stones target: http://i.imgur.com/3YUlWmF.gif

Jittery Tracking

September 4, 2014 - 9:53pm #16

I looked at your custom target in the Target Manager and while it may have received 5 stars (for lots of edge points and distribution), lots of text (i.e. repetitive patterns) on a page can be difficult to track which might explain the tracking difference between it and the stones. I do notice subtle jitters on your stones GIF. I tried to reproduce the same issue with the stones target and the ImageTargets sample app compiled from Unity, but my tracking was solid. What version of iOS are you running on your iPad3? Have you tried some of these tips from our FAQ on tracking stability:


Other troubleshooting steps I would suggest:
1. Closing all open apps
2. Turning on airplane mode
3. Rebooting the device
4. Running the ImageTargets sample with stones target


Jittery Tracking

September 5, 2014 - 5:46am #15

The iPad 3 is running iOS 7.1.2. I've tried the tips from the FAQ and tried the steps you suggested. Same results. It's also apparent, although much less noticeable, on the iPhone 5. It's very noticeable on the iPad Air, although I don't have one to test on regularly (my clients do). I was hoping it's just a bad target, but that would not explain why a demo I made two years ago (with 3-star target) has much better tracking compared to the same demo recreated with new versions, both on the same iPad 3.

It may be worthy to note that it's not as if I'm losing the target or have any trouble recognizing it. It tracks and stays tracked, but the object does not stay still. It's as if the target is shaking. In the past, if I had any issues with tracking, the problem would be that I'd lose the target or not pick it up at all. This is different.

Jittery Tracking

September 5, 2014 - 6:38am #14


you mentioned:

I did a test -- I compared an old demo app from summer 2012 to a new app I just created for this test with the latest versions of Vuforia and Unity (both running on an iPad 3). The apps use the same target, a 3-star rated page from a book.

Are you using the same actual Dataset file with the old (2012) and the new 3.0.9 ?

or have you re-uploaded the same image to the Target Manager and re-created a new Dataset for testing with 3.0.9 ?


Jittery Tracking

September 5, 2014 - 6:40am #13

It's the same dataset from the Target Manager. Did not re-upload.

Jittery Tracking

September 5, 2014 - 6:46am #12

OK, good to know. In fact, the Datasets created with the Target Manager of 2 years ago (probably at the time of Vuforia 1.5 or Vuforia 2.0 ) are not compatible with Vuforia 3.0, meaning that the results are not predictable.

If you use Vuforia 3.0, you need to re-create your Dataset with the latest Target Manager (the "compatibilty break" occurred in 2013, at the time of the 2.5 release);

so, you should take the same original image of 2012 and re-upload it today to the Target Manager to generate an up-to-date Dataset which is compatible with SDK 3.0.

Then, you can re-run the tests.

NOTE: it is possible that the same image will result in different (possibly higher) Star Rating with respect with what you got in 2012



Jittery Tracking

September 5, 2014 - 8:58am #11

I reuploaded the same image to the Target Manager, this time it received 5 stars instead of 3. I created a new project (Unity 4.5.3, Vuforia 3.0.9) and imported the new dataset and the same model with a different color material so that the different versions are more easily distinguished. I compared the app from 2012 to the one I just created:

2012 -- http://i.imgur.com/kNBKJeH.gif

2014 -- http://i.imgur.com/Gydy5YY.gif

Hopefully you can tell from the poor quality gifs that the 2012 version is completely still, and the 2014 version is very shaky.

These gifs don't demonstrate it as well but I'll include anyway:

2012 -- http://i.imgur.com/1QL8Pis.gif

2014 -- http://i.imgur.com/lT0JHnW.gif

However, the 2014 build seems to be fine on the iPhone 5 (iOS 7.1.2) and even the iPad 2 (iOS 7.1.1).
I still don't think the issue is my device as I've seen the jitters on the iPad Air, but I don't have access to one at the moment.
I will give an update if I get a chance to test on other devices.

I'd be glad to add you to a TestFlight team to see if you get the same results on your device.

edit: one common denominator for bad jitters, in my tests, is iPads running iOS 7.1.2. I'd be interested to hear what device user digitalillusions is using.

Jittery Tracking

September 5, 2014 - 10:12am #10

Thanks for re-running the tests with the updated Dataset, and thanks for the gif animations.

So, to summarize, the issue seems to reveal on iPad 3 and (presumably) on the iPad Air too, while on other devices the performances seem to be good. I'll escalate this to our team to analyze it further. 

Will keep you posted.

EDIT: could you send me (via PM) the original image used to generate the image target used for the tests, so that I can recreate the Dataset on my end and test it?



Jittery Tracking

September 8, 2014 - 2:34am #9

I would stll have one question:

are you using continuous autofocus in your App with 3.0.9 ?

If not, could you try and enable continuous autofocus (FOCUS_MODE_CONTINUOUSAUTO) in the CameraDevice singleton and try again to see if the jitter gets any better ?

It is important to rule out that the issue  is not just  due to a lack of camera focus on the target.



Jittery Tracking

September 9, 2014 - 10:07am #8

Yes, I have tried this. Setting continuous autofocus does not improve the jitters.

Jittery Tracking

September 9, 2014 - 11:48am #7

OK, thanks for confirming.

Jittery Tracking

September 11, 2014 - 5:03pm #6

We tested an iPad3 with 7.1.1 and an iPad Air with 7.1.2 with the ImageTargets sample app (compiled from both the Xcode version and Unity version). We used Vuforia SDK 3.0.9. The tracking appeared to be solid. We didn't see the same kind of jittery movement you posted in the GIF with the orange motor augmentation. Could you post (or PM) a video of your iPad3 tracking which is 10-15 seconds long for us to look at? Also, if you would like to PM the image you used to create the target, we can create a target from that as well and see if we can reproduce.

Jittery Tracking

September 12, 2014 - 3:18am #5

A note: the image used to create the target has already been PMd to us (no need to resend it).


Jittery Tracking

September 15, 2014 - 11:25am #4

I PM'd a video. Thanks for taking a look.

I have yet to try again with the newly released Unity 4.5.4, but I will update when I am able to do so.


edit: Still very jittery in Unity 4.5.4

Jittery Tracking

September 15, 2014 - 8:20pm #3

I tested your motor target with the ImageTargets sample app on an iPad3 with 7.1.1. I compared the tracking of your target side-by-side with the default sample targets. The sample target (stones, chips) tracking was solid, but I was able to reproduce the jittery effect with your motor target. My conclusion is that the issue is with the features of the motor target image. Here's a couple of suggestions for image target adjustments:

1. Crop out the text paragraph from the target image
2. Scale down the image before uploading it to Target Manager

I did these two steps in my own testing and it appeared to reduce the jitter. Small text can be challenging for the image tracker. Also, by scaling the target first, I found that the point data was better aligned with the features in the image. In my tests, I proportionately scaled the image to a width of 320 in an image editor before uploading to the Target Manager.

Also, the source image even at the large resolution you provided is quite jaggy (see the text paragraph, motor heatsink, etc.), which means that it might have been captured from a source like PDF, but at a weird scaling ratio that created some poor aliasing artifacts which could get turned into extra feature points that you don't want.

As for the image itself, it may have received 5 stars for having lots of points spread throughout, but tightly grouped parallel lines and other uniform features that make up the motor image could have a negative impact when it comes to robust tracking. The source image doesn't appear to be anti-aliased (or may have been captured from another source at an odd scaling ratio) and those jagged diagonal lines could generate more clusters of points for features that might not be seen by the device camera. You can view the feature points of an image by clicking "Show Features" in the Target Manager. When I examine the feature points on the motor image, there's a lot of points on some of those long aliased edges and I suspect that they might be competing with each other and thus leading to some jitter. One quick experiment I did was to add a small amount of Gaussian Blur to the image to smooth out the aliased lines. This greatly reduced the feature points along the long edges of the heatsink, but the result was solid tracking with zero jitter (once it acquired the target). It could take a bit of experimenting with the image modifications to fine-tune the results.

Here's some of our Dev-Guide articles that explain ideal image features for tracking along with some steps for improving your images:




Jittery Tracking

September 17, 2014 - 11:02am #2

Thanks a lot for looking into this. I tried your suggestions (cropping out the text and scaling down to 320px width) but this did not improve the jitters much for me, if at all. I tried adding a Guasian blur and this also had little to no effect. 

Hopefully this issue improves with later versions. In the past, pages with lots of text presented no problems with tracking or jittering. Even 0 star targets would still magically work very well. Most of our AR targets involve pages with some text and images on them. I realize fine-tuning and selecting high-quality targets is an important part of the process, but in my experience it was never necessary with previous versions, so it is costly if old targets that were once reliable need to be tweaked to work with newer versions of the SDK. I will stick with Unity 4.3.4 and Vuforia 2.8.7 for now, and continue testing with newer versions when I have some down time.

Jittery Tracking

March 13, 2015 - 8:38am #1

Has there been any updates on this?  Were you able to test this out in Vuforia 4.0 and see if it's still jittery?

We have run into the same experiences as you have.

Log in or register to post comments