Log in or register to post comments

Knock Knock, who's there? Unity 5.5

February 15, 2017 - 10:32am #1

I'm sure you guys are aware of the Warnings that appaear when using Vuforia in Unity5.5?

 

namely:

"OnLevelWasLoaded was found on VuforiaAbstractBehaviour"

"Assets/Vuforia/Scripts/Utilities/VRIntegrationHelper.cs(99,29): warning CS0618: `UnityEngine.Camera.SetStereoProjectionMatrices(UnityEngine.Matrix4x4, UnityEngine.Matrix4x4)' is obsolete: `SetStereoProjectionMatrices is deprecated. Use SetStereoProjectionMatrix(StereoscopicEye eye) instead.'"

along with some Shader warnings...

 

Any idea when the next version of Vurofia will be released?

Knock Knock, who's there? Unity 5.5

June 29, 2017 - 12:11pm #5

cdfoulston wrote:

I'm sure you guys are aware of the Warnings that appaear when using Vuforia in Unity5.5?

 

namely:

"OnLevelWasLoaded was found on VuforiaAbstractBehaviour"

"Assets/Vuforia/Scripts/Utilities/VRIntegrationHelper.cs(99,29): warning CS0618: `UnityEngine.Camera.SetStereoProjectionMatrices(UnityEngine.Matrix4x4, UnityEngine.Matrix4x4)' is obsolete: `SetStereoProjectionMatrices is deprecated. Use SetStereoProjectionMatrix(StereoscopicEye eye) instead.'"

along with some Shader warnings...

 

Any idea when the next version of Vurofia will be released?

Knock Knock, who's there? Unity 5.5

February 16, 2017 - 9:09pm #4

D3st1ny94 wrote:

OnLevelWasLoaded is obsolete. Add a delegate to SceneManager.sceneLoaded instead.

UnityEngine.Camera.SetStereoProjectionMatrices(UnityEngine.Matrix4x4, UnityEngine.Matrix4x4) is obsolete: SetStereoProjectionMatrices is deprecated. Use SetStereoProjectionMatrix(StereoscopicEye eye) instead.





PPS; next time just load the plug-in and warnings will come up right away, where is your QA?

 

We are aware of the deprecated Unity classes and will update in a future Vuforia release. These are just deprecation warnings and can be ignored. Unity 5.5 will prompt to upgrade source accessible scripts when necessary.

Knock Knock, who's there? Unity 5.5

February 16, 2017 - 6:20pm #3

Release 6-2-10

Unity Editor Version: 5.5.1f1

Problems: None; The obsolete/deprecated code is still in the current release and does not have any negative effects, I have successfully used ImageTarget, and Smart Terrain using the AR Camera on unity 5.5.1f1 



PS: Thank god for the dark camera fix on the new release.



Obsolete Code + fixes:

OnLevelWasLoaded is obsolete. Add a delegate to SceneManager.sceneLoaded instead.

UnityEngine.Camera.SetStereoProjectionMatrices(UnityEngine.Matrix4x4, UnityEngine.Matrix4x4) is obsolete: SetStereoProjectionMatrices is deprecated. Use SetStereoProjectionMatrix(StereoscopicEye eye) instead.





PPS; next time just load the plug-in and warnings will come up right away, where is your QA?

 

Knock Knock, who's there? Unity 5.5

February 16, 2017 - 4:35pm #2

Hello,

Do these warnings persist in our latest 6.2 SDK patch release? It will be helpful to understand the exact versions of the Unity Editor and Vuforia Extension that you are using.

Additionally, are there any negative effects from these warnings regarding app development or Vuforia features?

Thanks

Log in or register to post comments