Log in or register to post comments

Landscape rotation has an offset depending on which side

September 7, 2016 - 10:17am #1

Hi guys,

I have this issue regarding the 3d model fixed to the camera. I posted about it in the Unity forum, but wanted to see if someone here had this problem and could solve it already?

http://forum.unity3d.com/threads/on-mobile-device-landscape-rotation-changes-has-an-offset-depending-on-which-side.429987/

Thanks

Landscape rotation has an offset depending on which side

September 14, 2016 - 1:41pm #3

What device are you testing on? Have you tried multiple devices? If so, which ones?

Landscape rotation has an offset depending on which side

September 9, 2016 - 8:50am #2

Hi vuforia devs,

I really need your help fast. The reported problem is a vuforia issue and I could get closer to the cause of the problem. But I'm not able to solve it. I guess it's easy for you and I hope you can reply fast. Thanks!

Have a look at the "vuforia_portrait" and "vuforia_portrait_upside_down" image. You can see that the gray images with text are not centered if the device rotation is changed. In "normal" Unity they are centered, see image "unity_portrait" and "unity_portrait_upside_down". So I was searching for an offset in the ARCamera and Camera transform but couldn't find a solution. Then I started to deactivate some scripts and that's where I saw that the DigitalEyewearBehaviour is causing the offset. The offset makes sense now, because it's used for stereo view...

Check out image "vuforia_without_DigitalEyewearBehaviour", where the gray areas are centered. Unfortunatly I don't have an image anymore...

Looking further into the code I found this and I guess it's causing the offset of the camera:

public abstract class DigitalEyewearAbstractBehaviour : MonoBehaviour, IVideoBackgroundEventHandler
{
//
// Static Fields
//
public const float DEFAULT_CAMERA_OFFSET = 0,06;

How can I solve this issue?

Thanks a lot!

Log in or register to post comments