Topic locked

Migrating to 2.8.7 - AR camera broken

April 10, 2014 - 10:05pm #1

Using latest 4.3x of Unity and the 2.8.7 verison of Vuforia.  I followed the mgiration guide instructions.  But now I get this error from the ARCamera prefab when I run:

Can't add component because class 'PremiumObjectFactoryStarterBehaviour' doesn't exist!

UnityEngine.GameObject:AddComponent(String)
QCARAbstractBehaviour:Awake()
 
And then 
 
Could not initialize the tracker.
UnityEngine.Debug:LogError(Object)
TrackerManagerImpl:InitTracker()
QCARAbstractBehaviour:Start()
 
Do I have to recreate my project from scratch?  Hopefully not..???!
 

 

Migrating to 2.8.7 - AR camera broken

April 11, 2014 - 12:09am #3

Good :-)

Migrating to 2.8.7 - AR camera broken

April 10, 2014 - 10:12pm #2

Actually, forget it.  A reboot of Unity fixed it.  Maybe that's the one step I didn't follow. :)

Topic locked