Log in or register to post comments

Migrating from QCAR 1.0 to 1.5

March 2, 2012 - 4:25am #1

I've just downloaded the latest QCAR version 1.5. Does anyone know the easiest way to change projects that were created with QCAR 1.0 to work with 1.5? What files in the project tree do I need to change? I want to avoid starting with a blank QCAR 1.5 imagetarget prefab and adding in all my objects one by one.

Migrating from QCAR 1.0 to 1.5

July 1, 2013 - 4:52am #9

Can you try one thing then just to test:

Can you see if you can upgrade a copy of the standard video playback sample from 2.0.3 to the 2.5.7 sdk, as it ought to work.

 

Also, it is hard to diagnose as you have not really provided much information from the Xcode log.

N

Migrating from QCAR 1.0 to 1.5

July 1, 2013 - 4:41am #8

No i follow this link

https://developer.vuforia.com/resources/dev-guide/migrating-your-ios-sdk-project

and sorry i forget to post the question in ios forum :)

I face this problem in Xcode not in Unity.The project with QCAR Sdk 2.0.3 is working fine on my side  problem in updation QCAR SDK 2.5.7 :(

 

 

Migrating from QCAR 1.0 to 1.5

July 1, 2013 - 4:25am #7

Well, I am assuming you are using Unity, as this is a Unity forum.

Did you go through the steps for migrating for Unity projects?

https://developer.vuforia.com/resources/dev-guide/migrating-your-unity-project

 

N

Migrating from QCAR 1.0 to 1.5

July 1, 2013 - 3:24am #6

Thanks N

But i replace the Build folder as mentioned in this link for update the latest SDK
https://developer.vuforia.com/resources/dev-guide/migrating-your-ios-sdk-project. Nothing else changed in project.

the Xcode debuger show the latest sdk is updated here is the log sentence "INFO/AR(927) 2013-07-01 15:17:27: QCAR SDK version 2.5.7" it's mean Sdk is updated.
But app crash when i point the render view on a Marker with error messgae "0xa9b9f58:  beq    0x90a1d00" this.
And btw i modified the VideoPlayback ios demo project.

 

Migrating from QCAR 1.0 to 1.5

July 1, 2013 - 2:50am #5

The chances are you may have some old / invalid files from the previous release and/or rebuild the project from scratch.

Failing this you could always try using the Unity Debugger to understand what is actually going on.

 

N

Migrating from QCAR 1.0 to 1.5

July 1, 2013 - 1:41am #4

have you find out issue

i have also problem in Migrating from QCAR 2.0.03 to 2.5.7 but my app crashes when i track the object.Can some one help me to sort out the issue

thanks

Akhtar

 

Re: Migrating from QCAR 1.0 to 1.5

March 5, 2012 - 10:41pm #3

Awesome! Exactly what I needed.

I had another problem but it was 'cos I was also running a project I made in the full trial version with an iPhone basic version. I kept getting an error in Xcode saying "You are not allowed to remove the Unity splash screen from your game" even after I removed my splash screen and I could see that it was replaced with the Unity default splash screen. Just gotta make sure you do a build "Clean" first

Re: Migrating from QCAR 1.0 to 1.5

March 2, 2012 - 5:33am #2

Hi,

A detailed guide on how to migrate you Unity project from from QCAR 1.0 to Vuforia 1.5 can be found in the last section of the developer guide:
https://ar.qualcomm.at/qdevnet/developer_guide

Log in or register to post comments