Log in or register to post comments

No AR Target in Prefabs

May 31, 2011 - 1:48pm #1

I just installed QCAR Unity Extension 1.0 into Unity 3.3, but after inserting FrameMarker or ImageTarget Prefab into the scene, no AR Target property in Marker Behaviour is shown. I can see this instead:

Could you please help me with this problem?

Re: No AR Target in Prefabs

June 21, 2011 - 5:05am #11

Yes I am using Windows 7 Ultimate. I did manage to get it working, I am not sure if this could be responsible, but re-installing the Java JDK and Android SDK solved it for me.

Re: No AR Target in Prefabs

June 20, 2011 - 7:10pm #10

Are you also using Windows 7 Ultimate? Any other details you can provide?

- Kim

Re: No AR Target in Prefabs

June 20, 2011 - 6:54am #9

Was a solution ever reached for this problem? I am experiencing the exact same issue, and have checked my read/write permissions for the whole file path, and that has not fixed it.

Re: No AR Target in Prefabs

June 2, 2011 - 12:34pm #8

That sounds like a permissions issue w/ config.xml - i.e. for some reason, Unity can't read or write to that directory. So it's not writing config.xml for the prefab, and unable to read it in the samples. That's why the inspector isn't reflecting the config info.

So you might check the directory permissions and also the permissions on the config.xml for the sample project. You'll want to allow read and write access for that file. You can also check the Windows Event Viewer to find system errors arising from Unity related to this file. The Windows permissioning scheme for Vista and 7 is more complex than for XP. Though 7 isn't as bad as Vista, which can be a huge PITA. If it's a recurrent problem, you can probably set the necessary permissions on the parent directory and allow your projects to inherit these.

Re: No AR Target in Prefabs

June 2, 2011 - 12:10pm #7

I have exactly the same file list in Project view, but config.xml is missing when I create new project, even after creating new FrameMarker from prefab, config.xml is not created. In the sample projects is config.xml included, but Marker Behaviour is the same as on my screenshot.

I am running Unity on Windows 7 Ultimate, on other PC with Windows XP it is working fine!

I found no error in editor log, you can see log in the attachment.[ATTACH]48[/ATTACH]

Re: No AR Target in Prefabs

June 1, 2011 - 12:57pm #6

The Editor folder is included in the .unitypackage, check to see that your Project view looks similar to Tyro's.

What OS are you running Unity in?

Are there any errors in the Unity editor? Go to Window > Console to see the log.

Even the transform component in your screen grab looks odd, typically it looks more like the one in Tyro's (Position/Rotation/Scale). If you create another Unity object (like a cube) does it look the same?

- Kim

Re: No AR Target in Prefabs

June 1, 2011 - 8:20am #5

Here's a screengrab of my project pane and config.xml after having created a new project, included the QCAR package, and placed a framemarker prefab in the scene. The QCAR import should provide the necessary editor scripts. Do you have all of the files and directories shown below?

* take a look at the attachment if the entire image isn't visible in the post.

and here's the inspector pane..

Re: No AR Target in Prefabs

June 1, 2011 - 12:08am #4

I am using version 3.3.0f4 (63135).

This is inspector view of FrameMarker in the scene. ImageTarget looks the same like this.

I have imported QCAR-1.0.0.unitypackage, isnt it enough? Which editor files should I import?

I tried to import also QCAR-ImageTargets-1.0.0.unitypackage and QCAR-FrameMarkers-1.0.0.unitypackage, but all trackables looks like this.

Configuration is set to Android of course.

Re: No AR Target in Prefabs

May 31, 2011 - 5:09pm #3

Also check your build settings ( File > Build Settings ). Confirm that you're building for Android, and try checking 'Development Build'. Simply adding the QCAR package to a project won't configure these aspects of the build. I'd run into a similar issue w/ the inspector when my environment wasn't configured correctly.

I'd take Kim's advice and try one of the samples as well. These will tell you whether you're working with a correct build environment.

Re: No AR Target in Prefabs

May 31, 2011 - 2:19pm #2

What version of Unity are you using exactly? Go to "About Unity..." for the full version number, e.g. 3.3.0f4 (63135).

Is this the Inspector view of the FrameMarker you dragged into your scene? Frame markers don't have an AR Target property, but should have "Marker ID" and "Preserve child size" properties.

Make sure you've imported the full QCAR package, including the Editor files. You may also want to try importing one of the sample packages (e.g. ImageTargets) into a fresh project, as a test.

- Kim

Log in or register to post comments