Log in or register to post comments

No Camera Image

February 10, 2011 - 9:16pm #1

I have an odd problem. I've been messing around with this for days now without a problem. I just added a second Image Target to one of my projects and increased "Max simultaneous Image Targets" to two.

Built & Ran it and where normally I'd see what the camera was seeing I was only seeing grey. I thought to myself "dang, that sucks that they don't put the camera image through when simultaneous is higher than 1" little did I know.

After messing around a bit I wanted to see the what the camera was seeing again so I set simultaneous back to one. Still a grey background. I loaded up one of the other projects that was still installed on my phone from earlier that was working before. Still a grey background. Reboot the phone. Still a grey background. Did a reimport all. Still a grey background.

Any help is appreciated.

P.S. It is a G2.

Re: No Camera Image

February 11, 2011 - 6:44am #5

It's working now! Thanks!

Gonna name my projects;
Bad Project: The one I originally had the problem with. It just has some basic models and two ImageTargets.

Original Project: One I'd been using for awhile without a problem. I have made changes to the TrackerScript.cs on it and it does have particle effects.

ImageTargets: I created the new project and imported QCAR-ImageTargets.unitypackage.

After creating ImageTargets it didn't work (saw the pots though). Changed to OpenGL ES 2.0 and it worked!

Went back to the Original Project and it still had the grey background. Same for the bad project. Bumped the bad project up to OpenGL 2.0 and it worked.

I'm glad it is working again although I'm awfully curious what could have happened to retroactively break apps that were working before.

Re: No Camera Image

February 11, 2011 - 5:32am #4

This is strange... Let's see if we can narrow down the problem.

Start by creating a fresh project and importing the ImageTargets sample project. Run that on your device, is the video working?

Now, for your project. Have you made any changes to TrackerScript.cs? Have you added a second camera object? Does your scene have any particle systems in it? For this last one, there is a known issue when a particle system is the last object drawn in a scene, see this thread for info and a fix: http://ar.qualcomm.at/node/2000219

If you aren't already, I would suggest using OpenGL ES 2.0 rather than 1.1. Go to Edit > Project Settings > Player, choose the Android tab, and the Other Settings section. Set the Graphics Level to OpenGL ES 2.0 instead of 1.x.

Let me know how it goes!

- Kim

Re: No Camera Image

February 10, 2011 - 9:44pm #3

I remembered that I still had the non-Unity test app on there and I tried that. It works fine. Still no love from my Unity apps though. :(

I'm completely out of ideas. Off to bed but I'll try more in the morning.

Re: No Camera Image

February 10, 2011 - 9:24pm #2

I also tried clearing the data and force stopping both the QCAR apps I have but that didn't help. Nor did uninstalling both and trying again.

Oh, but if I hold the camera over a trackable it does still track. Objects tied to the trackable still appear and move around.

Log in or register to post comments