Topic locked

No marker detected!!!

February 25, 2014 - 3:50pm #1

Dear all,

I created a unity project and added a marker.

When i click on camera object in unity i see a top view image in my scene for the marker and my ar object (a cube) on top of it.

But when i run the solution, the android device dont show anything on the marker.

Any idea?

No marker detected!!!

February 14, 2015 - 12:32pm #23

That might happen if for example your device identifier has not been added to your Provisioning Profile or similar mismatches between your code signing identity and the device you use to deply / test the app;

as this is not a Vuforia-specific topic, you may want to have a look at the Apple docs, for example:

https://developer.apple.com/library/ios/technotes/tn2407/_index.html

https://developer.apple.com/library/ios/technotes/tn2407/_index.html#//apple_ref/doc/uid/DTS40014991-CH1-CODE_SIGNING_ERRORS

https://developer.apple.com/library/ios/technotes/tn2319/_index.html

 

No marker detected!!!

February 12, 2015 - 4:29am #22

sir Alessandro, could you explain:
"at worst, your device would reject running the app."

 

what would be the instances that my device will reject my app?

No marker detected!!!

February 10, 2015 - 6:00pm #21

still not working :3
can I send to you my unity project and try building it to iOS .check what's wrong?

No marker detected!!!

February 5, 2015 - 6:03am #20

Normally Unity and Xcode will perform code signing (as it is a developement build);  in any case, at worst your device would reject running the App, but I am not aware of any such issue that would cause the target not being detected.

 

No marker detected!!!

February 4, 2015 - 2:34am #19

I did all of that before I replied on your post.
I just want to ask one thing,
is code signing required in order for vuforia to work on iOS devices?

No marker detected!!!

February 3, 2015 - 11:18pm #18

Could you check that the Image Target has the DefaultTrackableEventHandler component attached ? (see my previous post)

Also, could you double-check that the Datasets are Loaded and Activated in the ARCamera inspector ?

And last, if you click on the Image Target and you expand the children hierarchy, how many models do you see ? it should only have 1 child, your 3D model.

Also, when you build and run, have you added the Scene in the Build Settings dialog ?

 

See attached screenshot images and feel free to compare with your setup.

AttachmentSize
Image icon ARCameraDataset.png28.07 KB
Image icon DefaultTEH.png40.26 KB
Image icon ImageTargetUnity.png109.79 KB
Image icon BuildSettings.png30.06 KB

No marker detected!!!

February 3, 2015 - 11:10pm #17

nothing's happened. still can't show the model

No marker detected!!!

January 28, 2015 - 7:37pm #16

the only thing I haven't tried is removing the scene manager gameobject from my scene. 
I'll try this. :)

No marker detected!!!

January 28, 2015 - 1:10am #15

Ok, I guess, if you started from the ImageTargets sample, are you trying to show your own 3D model (i.e. replacing the existing ones of the samples)?

If so, you may need to do the following:

- remove the children of the Image Targets

- add your own 3D models and make sure they are well positioned w.r.t n the parent target

- in the Image Targets, remove the "ImageTargetsTrackableEventHandler.cs" component, and replace it with the "DefaultTrackableEventHandler.cs"

- remove the SceneManager gameobject from your scene

- build and run

 

 

No marker detected!!!

January 27, 2015 - 8:44pm #14

I tried it first on iPod Touch 3G(ios 6) .Then on  iPhone 5S and iPhone 5 (ios 8).
 

No marker detected!!!

January 27, 2015 - 5:28am #13

Don't use Unity 5 (that's in beta and not tested with Vuforia 3.0);

if you use Unity 4.6, use Xcode 6 with it (Unity 4.6 + Xcode 6).

What iOS device are you on ?

 

No marker detected!!!

January 26, 2015 - 9:48pm #12

I did all that. but there's nothing that is showing. 
I used unity 4.6 and xcode 5.1, unity 5 and xcode 6, but nothing really appeared

No marker detected!!!

January 26, 2015 - 4:19am #11

@Blank:

...i tried the stones and chips sample of vuforia and built it to ios in a mac os.

I guess by "chips and stones" sample you refer to the Vuforia "ImageTargets" sample (imagetargets-3-0-10.unitypackage);

to build and run the Unity ImageTargets sample on an iOS device you simply need to:

  • import the sample package in a fresh new Unity project
  • load the Vuforia-ImageTargets scene
  • add the scene to the iOS Build Settings
  • select the iOS Player Settings and specify a name (Bundle ID) for your app (e.g. "com.test.imagetargets") 
  • Build and run
  • A tea-pot 3D model should appear when aiming your camera to the "chips" or "stones" target

Note that, with Vuforia 3.0, you'll need Unity 4.3 or above and Xcode 4 or above, but recommended to use Xcode 5.1 at least, or (preferably) Xcode 6, especially if you want to support iOS 8.

See also:

 

No marker detected!!!

January 25, 2015 - 11:22pm #10

hello. i tried the stones and chips sample of vuforia and built it to ios in a mac os. i checked the load dataset and activate. the problem is, the 3d objects doesn't appear. any solutions? TIA 

No marker detected!!!

February 26, 2014 - 3:33am #9

Ok, I'll summarize my previous reply for both of you:

- try the Vuforia Image Targets sample; 

- if the sample works, the issue is with your application code

- in that case, you can do 2 things:

  1. compare your own application code with the one in the sample, to see if you have forgot to do something, or if you do something different with respect to how to load datasets, how to activate, how to attach the augmentation, and so on.

  2. read the developer guide

 

On the other hand, if the Image Targets sample also does not work, then it could be a device specific issue (in which case I need the details of your device, such as Model number and Android OS version installed on your device).

 

No marker detected!!!

February 26, 2014 - 3:14am #8

Hello ,

 

i am developing a sample application in android using unity. my app runs without any errors but no object is loaded on to the marker , i tried the solutions mentioned in this post. can anyone help ?

 

thanks.

No marker detected!!!

February 26, 2014 - 12:57am #7

i am trying on galaxy note2

No marker detected!!!

February 26, 2014 - 12:52am #6

I tried on PC (using Webcam in Play Mode), and on a couple of smartphones.

I consistently get good results (detection occurs almost immediatly and the cube shows up).

To exclude that it is an issue with your specific device, you can try the Image Targets sample (the official Vuforia sample, with the Chips and Stones targets); if that works, this would mean your device has no issue with Vuforia.

 

 

No marker detected!!!

February 26, 2014 - 12:50am #5

did u tried it on pc, tablote, or phone?

No marker detected!!!

February 26, 2014 - 12:43am #4

I tried your marker.jpg using the vuforia project that you have attached, and it works without problem.

See attached image captured from my device screen.

Possible reasons why you don't see the target might be that your device has bad focus, or if the printing quality of your printed target is not good, or if the lighting conditions in your testing environment are bad/low.

To control the Focus mode, you can use the CameraDevice API (see SetFocusMode() method):

https://developer.vuforia.com/resources/api/unity/class_camera_device

Hope this helps.

 

AttachmentSize
Image icon Marker_detected.png329.72 KB

No marker detected!!!

February 26, 2014 - 12:20am #3

Yes it is.

Attached is the marker and this is the solution:

REMOVED

AttachmentSize
Image icon Marker.jpg10.11 KB

No marker detected!!!

February 25, 2014 - 10:37pm #2

Are you using Image Targets or Frame Markers ?

If you are using Image Targets, you need to make sure that your Dataset is "Loaded" and "Activated" in the Inspector panel of the ARCamera (under the Data Set Load Behaviour component).

See also:

https://developer.vuforia.com/resources/dev-guide/trackable-details-unity

 

Topic locked