Log in or register to post comments

Particle System issue

October 18, 2012 - 2:20am #1

I have a problem with the Unity Particle System in Vuforia.

If an image target is tracked, then the position of the particle system is crazy constantly changing. But if this not tracked, then is the Particle System position correctly.

I use OpenGL ES 2.0.

What is wrong?

Particle System issue

September 18, 2016 - 11:57pm #14



Hi Russel,

 

I am facing the problem that you had mentioned in this post (yes, it is in 2011 already).

 

Similar to your situation, i would like to make a partice system with some 3D graphics. After the Target was found, then the result i want to achieve is have some flower falling down from top to bottom on the screen upper layer ( front) and at the back will have the 3D graphics ( which will be appeared after target image found):

-The upper layer : flower falling down, Particle system ( will be fixed the position on the upper layer, not necessary stick with the 3D graphics.)

-The lower layer: the 3D graphics (appeared after target image found)

 

But the result i got is: Before target imaget was found, there is no flower falling in the screen); Once target  image was found, then the flower was sticked with the 2D graphics., which mean the flower was followed with the 2D graphics, but not able to be fixed on the upper layer ( in front of screen).

 

So may i ask do you know can fix the particle system in front of screen), but also can activate the 3D graphic at the back after the target image was found?

 

thanks and looking forward to hearing from your reply.

 

 

Particle System issue

June 20, 2014 - 9:08am #13

Any updates on this. I really need some help using vuforia with shuriken partical system. When I use fullscreen particle effect like rain it show up like camera on top and looking down at the beginning. When an image target found it's direction changes according to image target pose. When I use local effects like thunder on mouse position it displays correctly at the beginning but if an image target found it follow image target unexpectedly.

It would be very helpful if anyone can prepare a small example with shurinken particle effect which follows image target mouse click position correctly.

So far my code which attached to ARCamera is like this

    void Update () {
        if (Input.GetMouseButtonUp (0))
        {
            Debug.Log ("Click OK");

            Ray rayEffect = Camera.main.ScreenPointToRay(Input.mousePosition);

            GameObject goEffect = Instantiate(ShotEffect) as GameObject;
            goEffect.transform.Translate (rayEffect.GetPoint(1000));
            ParticleSystem psEffect = goEffect.GetComponent<ParticleSystem>();
            psEffect.Play();
        }
    }

 

I've also tried to attach a particle system component to image target and it also has some strange behaviour.

Particle System issue

November 28, 2012 - 7:19am #12

sorry - been super busy, but just to check your problem was resolved?

N

Particle System issue

November 28, 2012 - 7:02am #11

there are updates?

Particle System issue

October 29, 2012 - 3:36am #10

Sorry, not yet - maybe later this week.

N

Particle System issue

October 29, 2012 - 3:15am #9

Have you already looked at it?

Particle System issue

October 25, 2012 - 3:06am #8

Cheers Oli,

Look forward to seeing it run :)

N

Particle System issue

October 24, 2012 - 7:37am #7

Hey NalinS,

I have sent you a PM with a little Project.

Thank you for your help.

Regards, Oli

Particle System issue

October 19, 2012 - 9:11am #6

Next week I will produce a small sample ;). UICamera.lastHit.point of Ngui gives the Last raycast hit prior to sending out the event. This is useful if you want detailed information about what was actually hit in your OnClick, OnHover, and other event functions. This point triggers the error. I don't no why. I use now:

Ray ray = Camera.main.ScreenPointToRay (position);

RaycastHit hit;

if (Physics.Raycast (ray.origin, ray.direction, out hit)) {

if (click == true) {

shockwave.transform.localPosition = hit.point;

....

}

Particle System issue

October 18, 2012 - 8:14am #5

Good to hear Russel.

If you can share the issue/problem and shed any more light then that would be great :)

N

Particle System issue

October 18, 2012 - 7:13am #4

The Particle Issue is a NGUI with Vuforia problem. I solved the problem. Thank you.

Particle System issue

October 18, 2012 - 3:46am #3

Hi Russel,

If you can prepare a small repro project based on ImageTargets and PM me with a link to download then I would be happy to take a look...

N

Particle System issue

October 18, 2012 - 2:55am #2

If I put the World Center Mode to None, then it works. But the physics of my object is doing problems on "None" World Center Mode.

Log in or register to post comments