Log in or register to post comments

problem when run application, a black screen appears

December 4, 2010 - 12:58pm #1

Hello,
I built an AR application by using QCAR Unity3 Extension. The application works fine when I run it from Unity but when I disconnect my phone from USB and try to run it from my phone, a black screen appears and my phone freezes and I canÂ’t back or remove that screen. I faced this problem even with the QCAR-ImageTargets sample.
- What is the reason of this problem?
- Did anyone else face similar problems?
- Is the huge size of the installed application effect ( my application file is 17.5 MB , the QCAR-ImageTargets sample 16.3 MB)
- Is there a possibility that the problem is in my phone?
- How to reduce the size of the installed application when I use QCAR Unity3 Extension?

Thank you ,,,,

Re: problem when run application, a black screen appears

December 14, 2010 - 12:24pm #14

Thanks. I will upgrade it right away and try this out. Hope this solves the problem.

Edit: Indeed, it worked after I updated. Thanks a lot.

Re: problem when run application, a black screen appears

December 14, 2010 - 6:18am #13

Yes, you need to upgrade to Unity 3.1 for the QCAR extension to work. That error should then go away.

If you're still having problems after that, please set Unity to use OpenGL ES 2.0 instead of 1.1. Go to Edit > Project Settings > Player, choose the Android tab, expand the Other Settings section, and set the Graphics Level to OpenGL ES 2.0.

- Kim

Re: problem when run application, a black screen appears

December 14, 2010 - 2:31am #12

I am having the same problem with Nexus one. It loads to the phone and then shows powered by unity and then blank. Cant see anything.

I already have it in SD card and the app size is 9.3 MB. Anyone can help?

Oh and by the way, as I am using 3.0, I disabled Assets/Qualcomm Augmented Reality/Scripts/TrackerScript.cs(231,12): error CS0117: `UnityEngine.GL' does not contain a definition for `InvalidateState'

as I was getting error on that. Can that be the cause?

Re: problem when run application, a black screen appears

December 13, 2010 - 6:15am #11

Please see the Android docs for more info on the "installLocation" manifest setting:

http://developer.android.com/guide/appendix/install-location.html

Note that the option will only be available on Android OS 2.2+ devices.

- Kim

Re: problem when run application, a black screen appears

December 13, 2010 - 1:41am #10

is there a way to directly specify to have the app install on SD card, instead of default on internal phone mem? it looks like most devices don't have the luxury of 20mb+ of internal phone mem

Re: problem when run application, a black screen appears

December 12, 2010 - 9:18pm #9

There is a known issue when the application is resumed from a backgrounded state. That's what this sounds like. A fix is ready and will be included in the next release, which should be within the next couple weeks.

- Kim

Re: problem when run application, a black screen appears

December 12, 2010 - 6:52am #8

ksiva,

I'm running into the same issues, but mainly OnApplicationPause(). My company has the HTC Evo, and we're seeing that issue on both devices. So I tried to force the Application to quit when it goes to sleep (I know this isn't the best method to try but I have a prototype due very very soon), and that was suboptimal because the AndroidOS believed the application was crashing.

Is this a bug in the SDK, and if so, do you have any ideas on how to work around this issue for the interim?

Re: problem when run application, a black screen appears

December 5, 2010 - 4:06pm #7

I just tried this on an HTC Desire, OS 2.2, and it seemed to work. Make sure you add the android:installLocation="preferExternal" to the Manifest file located in Assets/Plugins/Android.

If you're still not seeing the video, try setting Unity to use OpenGL ES 2.0 (some people have had problems with 1.1). Go to Edit > Project Settings > Player, choose the Android tab, expand the Other Settings section, and set the Graphics Level to OpenGL ES 2.0.

- Kim

Re: problem when run application, a black screen appears

December 5, 2010 - 3:42pm #6

Thank you gnoblin
When I moved my application to SD card, the application size decrease to 10.3 MB, but it didn't work as expected - only 3D object appear without camera background- when I moved the application again to the internal storage it works properly but its size increase to 17.3 MB.

This is critical problem because it is not expected that the end user will try to move the application between phone and SD card in order to run the application properly.
any help please ,,,

Re: problem when run application, a black screen appears

December 5, 2010 - 2:40pm #5

" by adding android:installLocation="preferExternal" to the manifest, as explained here: http://developer.android.com/guide/appendix/install-location.html "

Re: problem when run application, a black screen appears

December 5, 2010 - 2:21pm #4

My device is htc desire.
Today I upgrade to android 2.2 , and I tested the application so many times with different level of battery and it works mostly Ok. ( only one time the problem occurred after updating to 2.2) . I observed also the sound is working ( I read in this forum, Sound is missing in the current Unity Extension). Sound was not work before updating even when I run the application from Unity.
Thank you gnoblin ,
But “Move to SD card” option from manage applications is disable , how can I active this option?

Thank you all

Re: problem when run application, a black screen appears

December 5, 2010 - 6:35am #3

you can install Unity game on SD-card :)

Re: problem when run application, a black screen appears

December 4, 2010 - 3:27pm #2

What device are you using? We have seen some issues with the application resuming from a backgrounded state, and this will be fixed in the next release.

I'm looking into the size issue now. It seems that a completely empty Unity Android application is around 9.3 MB. Adding the base QCAR extension does push it to 16.3 MB. 7 MB does seem a bit much, considering that the sum total of the assets folder is only 1.8 MB. Let me ask around internally to see if there is anything we can do about this.

- Kim

Log in or register to post comments