Log in or register to post comments

Region Capture

April 9, 2016 - 3:52pm #186

RegionCapture 1.8.0  (Free version)

Small fixes

________________________________________________

https://github.com/maximrouf

Region Capture

April 11, 2016 - 6:03pm #185

Hello maximrouf,

Is there anything in particular that I should take into consideration while implementing?

Thanks in advance!

Region Capture

April 12, 2016 - 9:15am #184

Works great on iPhone!!! I had a little shift in the iPad Air, but corrected it by using the setTextureOffset on the material.

Thanks a bunch, great plugin!

Region Capture

April 13, 2016 - 5:59am #183

Hi Richmerren. Could you take a screenshot from Ipad Air ?

Region Capture

April 18, 2016 - 12:59am #182

Hi, 

 

Great plugin. However we ran into some shift problem when playing the script. The shader keeps changing when playing. Is anybody having this same problem? Please advise.  

 

also , screenshot attached. 

AttachmentSize
Image icon 1.pic_.jpg54.16 KB
Image icon 2.pic_.jpg52.57 KB

Region Capture

April 18, 2016 - 3:17am #181

SHSORATECH, Hi.  Please give me more details -

1. The device name (Iphone5, Iphone6+, Ipad Air...)
2. Orientation option in the build settings (Portrait, Landscape Left ...)

Region Capture

April 18, 2016 - 7:23pm #180

Hi Maximrouf, 

 

Thank you for your quick reply. the build setting attached. 

 

the device is Coolpad 7620L, Android4.3 

 

 

AttachmentSize
Image icon build_setting.png26.2 KB

Region Capture

April 19, 2016 - 7:18pm #179

Hi Maximrouf, 

 

Is there any update on this issue? updated related info yesterday. 

 

highly appreciate for your help. 

 

 

Region Capture

April 21, 2016 - 7:57am #178

Hi,

is possible to use Region Capture with a MultiTarget ?

Another question: can I use it with stereo cams (setup is like Stereo Rendering sample using a generic cardboard).

Thanks

Akira

Region Capture

April 21, 2016 - 8:28am #177

Hi Akira. Yes it's possible. For example – 3 ImageTargets  = 3 RegionCapture prefabs in the scene.

Both modes (Mono and Stereo) work fine.

Region Capture

April 21, 2016 - 8:33am #176

Thanks maximrouf,

have you same samples or tutorial to setup multitarget and stereo cam with the plugin?

 

Region Capture

May 2, 2016 - 3:43am #175

Hi maximrouf,

 

Thanks for the amazing work. I am using your latest prefab 1.8 with unity 5x and vuforia 5. with you previous builds i was able to implment region capture on my 3d model without any issues, but now i wanted to add region capture on multiple image targets in this case 2, in my get texture window the region is caputred correctly but it is not applied on my model. Could I be missing something? Is there some new settings to be done for version 1.8?

Please  see the attached image.

Thanks for the help.

Region Capture

May 2, 2016 - 4:10am #174

Got that working!

 

But now is the texture shift issue! using macbook pro to test in unity.

 

Please this the attached image.

 

Region Capture

May 4, 2016 - 12:42am #173

Hello. i have sama problem with SHSORATECH

the shader goes red and green. i am using 2 devices and it happened on both of them.
ASUS zenfone C. Meizu M2note.
Orientation : Landscape Left
Latest Unity version 5.3 and Latest Vuforia version
 

Region Capture

May 4, 2016 - 4:36am #172

your UV map is wrong

Region Capture

May 6, 2016 - 6:53am #171

I use Unity 5.3.4 and Vuforia 5.5.9 and latest Region Capture 1.8.0.

Mac and Android tests works fine, but on iPhone seems that it doesn't working. Textures not applying to model. iPhone 5S, iOS 9.3.1, Orientation: All, Auotorotation: ON.

The only thing I added to RenderTextureCamera.cs was:

   using System.Runtime.InteropServices;

because without that line Xcode 7.3 was rejecting to build some IL2CPP stuff.

 

On iPad 4 iOS 9.2.1 textures applied normaly.

 

Does anyone have some suggestions?

Region Capture

May 9, 2016 - 6:58pm #170

I am using cube gameobject unity default. and its turn green and red. so i think it doesn't trouble with UV map.
What version of unity and vuforia that can be use to build this? I really need help :)

Region Capture

May 9, 2016 - 11:30pm #169

mbaj6. I am also stuck in the problem u were facing with the texture not applying on the model.

How did u solved the problem ? Was it a specific setting that needs to be done.

 

Region Capture

May 11, 2016 - 6:45am #168

So, looks like on the latest iOS (9.3.1) something is wrong with texture mapped on the model. Because I can reproduce it on ipad/iphone, and on earlier versions everything seem to work fine.

Does anyone have same issue?

Region Capture

May 11, 2016 - 6:32pm #167

 

Hi.. Im new in this.. How to apply RenderTextureCamera.CameraOutputTexture to material of the object?

Region Capture

May 11, 2016 - 6:37pm #166

Hi.... i've got the same problem with you. The texture is not applied to the 3d model. Can you give me some hints what's the problem... Thanks.

Region Capture

May 13, 2016 - 4:35am #165

could anybody give your unity project as example

Region Capture

May 13, 2016 - 4:35am #164

could anybody give your unity project as example

Region Capture

May 16, 2016 - 1:23am #163

With texture not applying on 3d model on iOS 9 - I've changed in Unity project to use OpenGL ES 2, instead of "Automatic". I guess it tries to use Metal features and fails somewhere on the road.

 

Does anybody tried to integrate Vuforia+RegionCapture in existing iOS app?

 

Region Capture

June 21, 2016 - 2:24am #162

I am making a Vuforia App on Unity and I need to get a texture on a 3D model. I have followed the tutorial but the 3D model stays white and no texture.

I am using a Samsung Galaxy S4 with Android 5.0.1.

I have Unity 5.3.4 with Vuforia 5.5.9 and Region Capture 1.8.0. I do not know what is wrong.

Region Capture

June 22, 2016 - 1:55am #161

Ok I got the texture to work but it is all black. Does anyone have a solution for it?

Region Capture

July 23, 2016 - 7:28am #160

Hi maximrouf,Thanks for the amazing work. I am using your latest prefab 1.8 with unity 5x and vuforia 5.I got the texture to work but it is all black. Does anyone have a solution for it?

Region Capture

July 24, 2016 - 12:27am #159

Hi maximrouf, I am using your latest prefab 1.8 with unity 5.3.4p3 with vuforia 5.5.9 and windows 32 bit got the texture to work but it is all black. please help me.

Region Capture

August 18, 2016 - 6:30am #158

Maybe you have bad UV map on your model. My model is also was black, but after i add a correct uv everything was fine.

Region Capture

August 21, 2016 - 6:40pm #157



just un check debug color/color debug to solve this problem .

Region Capture

August 29, 2016 - 11:55pm #156

Currently I have the project in Unity editor. But its not showing anything.. 

A texture is blinking always. Should I have to take build and play it on phone??

 

Also is it necessary that the target-image should be taken from the model itself??

For testing purpose, I used a empty cube image as target-image and Unity-Cube model as the model. Is that an issue??

Region Capture

August 30, 2016 - 3:11am #155

Currently I have the project in Unity editor. But its not showing anything..

A texture is blinking always. Should I have to take build and play it on phone??

Also is it necessary that the target-image should be taken from the model itself??

For testing purpose, I used a empty cube image as target-image and Unity-Cube model as the model. Is that an issue??

Region Capture

August 30, 2016 - 3:15am #154

Currently I have the project in Unity editor. But its not showing anything..

A texture is blinking always. Should I have to take build and play it on phone??

Also is it necessary that the target-image should be taken from the model itself??

For testing purpose, I used a empty cube image as target-image and Unity-Cube model as the model. Is that an issue??

Region Capture

September 3, 2016 - 6:16am #153

Dear maximrouf

Thank you for the the great plugin. .

i want your help to make some changes . This plugin maps texture at real time  (live). i want it to be still for example once it correctly maps the texture with model  i want to stop live texturing. Please guide me through this problem . you can see quiver app  for reference  

Thank you 

Region Capture

September 10, 2016 - 7:49pm #152

Me too, did you solve it???

Region Capture

September 15, 2016 - 4:42pm #151

Hi Maxim,

Can we use blender 3d instead of 3dsMax? if so how?

Region Capture

November 6, 2016 - 7:20pm #150

Hi Maxim,

I'm using this library in my project but when I run app on iOs 10, it seems this library doesn't work. The model is not colored. Can you tell me how to fix it please?

(On other os, the library works greatly :D)

Region Capture

November 15, 2016 - 7:56am #149

im facing this error can you give me a solution 

 

 

Assets/Region_Capture/Scripts/Region_Capture.cs(133,13): error CS0266: Cannot implicitly convert type `UnityEngine.Texture' to `UnityEngine.Texture2D'. An explicit conversion exists (are you missing a cast?)

Region Capture

November 15, 2016 - 8:00am #148

hi maxim,

 i'm facing this error when i import this to unity

Assets/Region_Capture/Scripts/Region_Capture.cs(133,13): error CS0266: Cannot implicitly convert type `UnityEngine.Texture' to `UnityEngine.Texture2D'. An explicit conversion exists (are you missing a cast?)

 

can you give me a solution

Region Capture

November 16, 2016 - 9:52am #147

in line 33 change

    public static Texture2D VideoBackgroundTexure;

for



    public static Texture VideoBackgroundTexure;

Region Capture

November 17, 2016 - 8:52am #146

thanks mr.Philippe89 the error is solved but texture capturing is not working can you give me any solution??

Region Capture

November 20, 2016 - 9:05am #145

????????????????????????

Region Capture

November 22, 2016 - 5:46am #144

anybody have working source code ?? github source code not working :(

Region Capture

November 24, 2016 - 3:55am #143

help me region capture not working

 

Region Capture

November 25, 2016 - 5:32am #142

Hi, Thnx for amazing plugin! I got it working in mono mode, but i stereo it starts capturing texture before whole is visible. Sould I change anything, set one camera only?

I've tried to find where in the script "full marker" is detected ( green color with ColorMode on ). The condition checks if the marker ( Region object ) is outside the bounds, otherwise checks only MarkerIn state. Could anyone point me how to properly check the stae of "full marker" in stereo ( vr ) mode?

 

Region Capture

November 27, 2016 - 3:22am #141

Looks like this thread already abandoned, but if anyone else could help, it will be good.

My question, is it possible to save the the colored drawing as the texture for the object?

 

Thanks.

Region Capture

December 7, 2016 - 1:39am #140

I had the same issue as sriram115 and Philippe89, however just replacing Texture2D with Texture didn't seem to work on Android. Apparently these aren't as interchangeable as it seems. So instead I converted the VuforiaRenderer Texture to a Texture2D, which can then be used as _MainTex. 

On line 133, replace

VideoBackgroundTexure = VuforiaRenderer.Instance.VideoBackgroundTexture;

with

Texture2D PreVideoBackgroundTexure = (VuforiaRenderer.Instance.VideoBackgroundTexture as Texture2D);

VideoBackgroundTexure = PreVideoBackgroundTexure;

It's a workaround, but solved it for now. 

AttachmentSize
Image icon Screenshot_20161207-104714.jpg130.13 KB

Region Capture

December 16, 2016 - 12:11pm #139

Hello 

can u send me a sample of the project that has worked with you!!

Region Capture

December 17, 2016 - 1:59am #138

Hi, 

I want to make sample project using this library, on some rect marker create cube and color it. 

I want t ask if I need any special 3d object? I created simple 3d object cube from Unity and it does not render anything when I check on scene start or android device. 

 

edit: I made some improvements in code, I also downloaded some free package from assets store. It render now but and I can see something on my phone and also there is help camera that shows my marker but this cube prototype ive downloaded does not change color

 

Thanks for any help

King regards

Region Capture

January 31, 2017 - 9:42pm #137

hi. i'm using this asset in my thesis project now and its working fine except that the model is shaking.. can you please help me to fix it? thank you so much for this :)

Pages

Log in or register to post comments