Log in or register to post comments

Region Capture

January 28, 2018 - 1:54pm #86

Thank you Maxim,

everything is OK...

Region Capture

January 28, 2018 - 3:15pm #85

A new version 2.0.8 was uploaded.

https://github.com/maximrouf/RegionCapture

That's new:

- Small fixes in code

- "RegionCapture" plane has an orange color in the Editor.

- Added Readme.txt

Region Capture

March 4, 2018 - 8:04pm #84

1. Unity version: 2017.3.0f3

2. Vuforia version: 7.0.36

3. RegionCapture version: 2.0.9

4. Device name: Apple iPhone 7 Plus

5. Device OS version: 11.2.6

6. Orientation of the device: landscape



I'm using Region Capture in my project which works fine on Android Devices but iOS devices are having some issues. Please refer screenshots below. 

Thanks in Advance.



Android Screenshot: https://ibb.co/fPdnQ7

iOS Screenshot: https://ibb.co/jGtyXn

AttachmentSize
Image icon android screenshot.jpg196.77 KB
Image icon iPhone Screnshot.jpg482.4 KB

Region Capture

March 5, 2018 - 3:32am #83

Does this work only with image targets or also user defined targets

Region Capture

March 20, 2018 - 12:03am #82

Hello Maxim,

I am facing the same issue like chinnuabhi.

On iOS Region_Capture prefab is not aligned to the image target. It moves when the camera is moved .

Faced the issue on iPad pro and iPhone 7

Is there a solution for this???

Region Capture

March 20, 2018 - 10:25am #81

Hi Pavan1607 and Chinnuabhi..

I need time to check it. (5-7 days)

Stay tuned.

Regards, Maxim Rouf

Region Capture

April 13, 2018 - 9:26am #80

Hello maximrouf;

 

I've been trying to use Region Capture but Unity complains about a missing Vuforia function (removed some versions ago):



`Vuforia.VuforiaUnity' does not contain a definition for `GetProjectionGL'

 

Is there a workaround? Thanks!

Region Capture

May 20, 2018 - 12:40am #79

Dear Maximrouf,

 

Thank you for your reply and support in here. I am trying to use the region capture in Unity, ( my software version:)

-Unity2017.3.1f1

-RegionCapture_2.0.9

-Window 10

 

I had a problem about the mapping display on the 3d model.  Since i had completed to arrange the mapping texture on the 3d model ( a rectangule shape with 6 faces) in 3dmax and i had export to FBX. Then the model is ok after import to Unity ( before attached with RC_get texture script, please refer to image "before script"jpg) but once i attached with the RC_get texture script, then the mapping on the model will be changed and not in the right position, please refer to image "after script" jpg).

 

May i know do you know how can i change/ adjust/ rescale texture on the model ? or is it any places can change the size of  texture image?

 

Hope anyone can share any solution.

 

Thank you for your attention.

 

AttachmentSize
Image icon before script.JPG112.09 KB
Image icon after script.JPG103.1 KB

Region Capture

May 24, 2018 - 3:42pm #78

Hi everyone,

 

I want to be able to save multiple textures and reapply them to my model when I reopen the app.

I already know how I can actually read in all the pixels of a texture and how it is encoded to PNG. And saved afterwards.

All of this can be achieved using the MakeScreen() function of RenderTextureCamera.cs class.

 

We know that the model is being fed this type of information when its texture gets changed live.

How can I feed the model this saved pixels information?

As everyone can guess, it does not have to be live when remodeling from a saved texture.

It can just be one function where it takes the saved pixels information and applies the info to the model.

 

Thanks!!!

Region Capture

June 8, 2018 - 12:40am #77

Hello, 

I am using Unity 2017.3.0 and Region capture Ver. 2.0.9. 

I am facing a weird problem, when I am using my model, it is not getting live texture but when I use default models like cube and Sphere, I can see the live texture on them. 

Can anybody have solution for this. 

I am attaching screenshot for the reference. 

 

Thanks,

Vanshika 

 

Region Capture

June 16, 2018 - 8:58pm #76

Hello,

I am using Unity 2017.3.0 and Region capture Ver. 2.0.9. The region capture is not working on the Vuforia version. I am trying to create a AR coloring page. Not able to find a few settings in Victoria as shown in the tutorial video. Does anyone have solution for this?

Thanks

Region Capture

June 27, 2018 - 3:33am #75

Dear maximrouf,

I am using Vuforia 7.1.35, Region Capture 2.0.9, Unity 2018.2.

I want to create a coloring page, I've tried to run the sample scene and the texture renders the camera instead of the image target.

Could you give me some suggestion for this?, Please

here is the video showing the problem.

https://youtu.be/nPkWOTWXWNw

Region Capture

July 22, 2018 - 11:58pm #74

If anyone wants to use region capture with vuforia, below link explains it all how you can create an ar sketch application.

link

Region Capture

August 1, 2018 - 3:15am #73

thienbaomoon wrote:

Dear maximrouf,

I am using Vuforia 7.1.35, Region Capture 2.0.9, Unity 2018.2.

I want to create a coloring page, I've tried to run the sample scene and the texture renders the camera instead of the image target.

Could you give me some suggestion for this?, Please

here is the video showing the problem.

https://youtu.be/nPkWOTWXWNw

 

Yes. I also meet this issue in Unity 2018.2

Region Capture

August 9, 2018 - 3:01am #72

tomtomtongtong wrote:

thienbaomoon wrote:

Dear maximrouf,

I am using Vuforia 7.1.35, Region Capture 2.0.9, Unity 2018.2.

I want to create a coloring page, I've tried to run the sample scene and the texture renders the camera instead of the image target.

Could you give me some suggestion for this?, Please

here is the video showing the problem.

https://youtu.be/nPkWOTWXWNw

 

Yes. I also meet this issue in Unity 2018.2

 

I tried below tutorial with Unity 2018.2 and Vuforia 7.1.35 and it seemed to be working. If you still face any problem then contact me on sushanta1991(@)rediffmail(dot)com

https://sushanta1991.blogspot.com/2018/07/how-to-make-ar-coloring-application-in.html

Region Capture

September 17, 2018 - 11:09am #71

Hi @maximrouf, @Pavan1607,

Do you have any work around on solving this issue? I'm facing the same problem on IOS Devices.

On iOS Region_Capture prefab is not aligned to the image target. It moves when the camera is moved .

Faced the issue on iPad pro and iPhone 7

Vuforia 7.0.36, Region Capture 2.0.9, Unity 2017.3.0f3

Any help will be appreciated.

 

SOLVED: 09/10/2017

 

Solved using Unity 2018.2.11f1 with Region Capture v2.0.9 and Vuforia V7.2.23

 

 

 

 

Region Capture

October 3, 2018 - 12:34am #70

Hi @maximrouf,

 

I'm using Unity 2018.2.2f with Region Capture v2.0.9 and Vuforia V7.1.35

I encountered an issue on iOS where the render camera seems to stop capturing after flipping the camera via Vuforia API:

        CameraDevice.Instance.Stop();

        CameraDevice.Instance.Deinit();

        bool result = CameraDevice.Instance.Init(newDirection);

        CameraDevice.Instance.Start();

        Debug.Log((result) ? "Successfully changed" : "Failed to change cam");

        VuforiaUnity.OnPause();

        VuforiaUnity.OnResume();

        return result;

Here are the steps:

1. Start camera (Default = back camera)

2. Scan image target, model appears with the region mapped as texture correctly.

3. Flip the camera (now = front camera)

4. Flip the camera again (now = back camera)

5. Scan image target, notice that the model appears to have a distorted texture.

 

In step 6, the texture that seems to be mapped is the last camera frame captured before the first camera flip happens. 

Any help will be appreciated.

 

Thanks.

Region Capture

October 9, 2018 - 8:23am #69

I fixed the issue by updating Unity and Vuforia.

Unity 2018.211f1 with Region Capture v2.0.9 and Vuforia V7.2.23

Best regards

 

How to auto stop capturing on first tracking Found

October 13, 2018 - 3:13pm #68

Hi @maximrouf,

 

I tried to edit the script for auto stop capturing after first tracking found,

I want to disable "Stop Capturing" button and change the trigger to script but it doesn't success.

Any example for that?

 

Thanks 

AttachmentSize
Image icon Screen Shot 2018-10-14 at 05.02.08.png303.82 KB

Region Capture

November 18, 2018 - 11:17pm #67

Hi! Does this work with multiple image targets including ones that don't need region capture? It seems camera world center mode is defined by the first image... 

Region Capture

November 23, 2018 - 3:06am #66

Hello maximrouf,

Your plugin is great as it looks.

But unfortunately live coloring is not working for me.

I'm using Unity 2018.2.1f1, Vuforia 7.5.20 and Region Capture 2.0.9.

I'm running it on iPhone 7 and iOS 12.1.

 

Want a help on this...

 

Thanks in advance if anyone could help.

Region Capture

December 3, 2018 - 3:49am #65

Hello all,

I can run Region Capture, but the problem is Live Texuturing is not working properly. If I try to color the 3d model at bottom it colors slightly up from there. And also if I try to color at the top it colors bottom of the 3d model.

 

Please help as soon as possible. As I'm trying since so many days still not getting any solution.

 

Thanks in advance.

Region Capture

December 10, 2018 - 9:06am #64

Hi maximrouf,

First of all, I would like to thank you for this amazing plugin !

BTW, I'm currently working on porting an app on Universal Windows Platform. Everything works find in Unity Editor, but not when I build as an appx, RegionCapture seems to return an empty texture.

 

Here is my configuration :

Unity version : 2018.2.6f1 (64bit)

Vuforia version : 7.2.23

RegionCapture version : 

Device name : MSI GS65

Device OS version : Windows 10 Pro

Orientation of the device : Landscape

 

Thanks !

Region Capture

January 19, 2019 - 10:45pm #63

Hi Maximrouf,



I adopted "Region_Capture" before and it works great.

https://github.com/maximrouf/RegionCapture.

But after i update my unity "2018.3.1" and vuforia "8.0.10". The AR coloring now works in editor but not in android. 

Could you please suggest how to solve it. Many many thanks. I am in urgent.

Region Capture

February 12, 2019 - 2:19am #62

I have same issue :(

Region Capture

February 12, 2019 - 11:06pm #61

Please fix this bug : " Vuforia "8.0.10". The AR coloring (REGION CAPTURE, GET-TEXTURE) works in editor but not in android.

Region Capture

February 13, 2019 - 7:00am #60

Same issue with region capture not working with Android.

Unity 2018.2.5f1, Vuforia 8.0.10, Region Capture 2.0.9



Works on iOS and in Unity Editor, just not on Android devices.

Region capture no longer wrapping on 3D object correctly. (worked fine in earlier version of Unity and Vuforia)

Region Capture

February 13, 2019 - 11:07am #59

Same issue here, working in editor but not in android device, any workaround?

Region Capture

February 17, 2019 - 9:05pm #58

This android problem is really frustrating :( 



Hope someone psots a fix for it here soon. Still not working.

Region Capture

February 26, 2019 - 10:27pm #57

Same issue. RegionCapture is not wrapping on 3D objects properly

Unity 2018.3.6f1, Vuforia 8.0.10, Region Capture 2.0.9

But wraps properly on Unity 2018.2.20f1, Vuforia 6.2-10, Region Capture 1.8.0

AttachmentSize
Image icon Untitled.png324.03 KB

Region Capture

March 2, 2019 - 9:27pm #56

How did you manage to implement it in ARToolKit? Any instructions or source code perhaps? Thanks!

Region Capture

March 7, 2019 - 3:09am #55

Same issue here..! Does someone fixed this??

Unity 2018.3.6f1 / Vuforia 8.0.10 / Region Capture 2.0.9

Region Capture

March 7, 2019 - 4:02am #54

Hi,

I'm having trouble updating unity to version 8.0.10 - the installer just seems to remove all reference of Vuforia from the editor.

Anyone had the same problem? I'm using unity 2018.2.21f1 via unity hub.

 

Any help would be much appreciated!

 

Thanks.

Region Capture

March 7, 2019 - 11:38am #53

Hello @pmullins3,

Can you confirm that you're issue is similar to this one?: https://developer.vuforia.com/forum/issues-and-bugs/vuforia-upgrade-installer-breaks-support-users

Thanks,

Vuforia Engine Support

Region Capture

March 27, 2019 - 4:24am #52

Hello,

 

after upgrade to Unity 2018.3 and Vuforia 8.1.7 RC textures from RenderTextureCamera are rendered "reddish". Screenshot attached. It's standard white paper with black ink print on it.

It occurs only on mobile devices (both Android and iOS), no problem when trying out in Untiy Editor. Had no troubles using older vuforia and Unity 2017.

 

Anyone facing similar problems?

AttachmentSize
Image icon Screenshot_20190327-122032.jpg48.74 KB

Region Capture

April 2, 2019 - 5:31am #51

I also have similar problem in unity 2018.3 .. :(



maybe anyone have solution?

 

Region Capture

April 3, 2019 - 6:44am #50

Did anyone manage to get this to work with EasyAR in android?

I've tried using the "modified" unitypackage especially for EasyAR and put the RenderCamera with the RealityPlane in the appropriate slots but as soon as I compile and run to my android device I get a black background (not the camera feed) and the AR object appears without the camera capture material, just the material I have applied inside the Unity Editor.

I used Unity 2018.2.15.f1 and RegionCapture2.0.6_EasyAR.

 

For what it's worth it works kinda ok in the Editor since I understood I had to modify the marked parts in the RegionCapture.cs

Region Capture

April 5, 2019 - 9:02am #49

Hello @vufer1980,

A friendly reminder that this is a support community for the Vuforia Engine SDK, Unity Extension, associated tools and sample applications.

I suggest you refer your experiences and questions for EasyAR to their forum: https://forum.easyar.com/portal.php?mod=list&catid=1

Thanks,

Vuforia Engine Support

Region Capture

April 10, 2019 - 1:44am #48

I apologize. I only asked because I saw some relevant references on older posts.

Anyway, on a Vuforia question, does the "freeze" feature works well on everyone? Changing the bool value on the "Freeze Enable" variable doesn't seem to make any difference on Unity 2018 with the latest Vuforia version.

Region Capture

April 10, 2019 - 3:39am #47

michalSBIT wrote:

Hello,

 

after upgrade to Unity 2018.3 and Vuforia 8.1.7 RC textures from RenderTextureCamera are rendered "reddish". Screenshot attached. It's standard white paper with black ink print on it.

It occurs only on mobile devices (both Android and iOS), no problem when trying out in Untiy Editor. Had no troubles using older vuforia and Unity 2017.

 

Anyone facing similar problems?

Hello,

I am having the same issues with a red texture on Android (LG G4), but not on iOS (iPhone 6) and not in the Editor.

What I found out so far is that the following line is where the 'magic' happens:

Line 71 RegionCapture.cs:

VideoBackgroundTexure = BackgroundPlane.GetComponent<MeshRenderer>().material.mainTexture;

The Texture of the BackgroundPlane (containing the video feed) is shown correctly as background video, but when assigned / referenced to another Material it turns red. Does anyone have a clue why this might happen? An unsupported color format of the texture maybe? And if so, can it be converted?

The only possible solution I can imagine right now is not to use the BackgroundPlane texture in the RegionCapture script and instead reference our own WebCamTexture, but I have not tested that yet.

Also, even when the Video Background in the VuforiaConfiguration is disabled, a BackgroundPlane with the camera feed is attached to the ARCamera (just not fullscreen in the Editor) and the Video Background is still visible. Seems like a bug to me.

Region Capture

April 12, 2019 - 5:20am #46

I found a fix

And I was writing about my journey to fix this.

But someone deleted my post, so good luck all.

Region Capture

April 23, 2019 - 12:39am #45

Ok enough people asked me in messages to post the solution here so now I feel bad for not sharing, damn you all.

 

Short story, you need to convert the background plane texture format to the appropriate one based on the platform it is running on.

 

Easiest way is to use the background plane shader to render the region capture mesh (or you can use the conversion maths in there to edit your currently used shaders)

after this you'll still have to set the correct shader keywords, https://docs.unity3d.com/ScriptReference/Shader.EnableKeyword.html



in the latest vuforia version notes it tells you how to check what texture format vuforia is currently using.

 

After this you should all be set, hoping i didn't miss anything since I don't have the solution at hand right now, I had to revert the whole project to the previous version of unity and vuforia because they totally messed up the background plane texture acquisition. it works fine if you access it once in the whole lifetime of your app, but if you start and stop vuforia after accessing it it won't work anymore.

Region Capture

April 25, 2019 - 3:38am #44

Doesn't anyone try vuforia version 8.0.10? I just try it and region capture still not working in android

Doesn't anyone find out how to fix region capture yet? i really need this to finish my project, please help!!!

Incorrect texture position on Android

April 27, 2019 - 8:29am #43

Thanks maximrouf for a great plugin.  Are there any planned fixes for the Android shift in the latest version?

  • .2.0a13
  • Vuforia 8.0.10
  • RegionCapture - latest

Region Capture

May 2, 2019 - 5:14pm #42

So I'm dealing with the same issue and it seems from examining the BackgroundPlane video texture and the material on the Region_Capture that the video texture is inset with large areas of black on the top and on the right. As a temporary measure I set up a secondary Region Capture that takes the un-uv mapped texture and renders that to a texture, and then crop the resulting texture excluding the, what seems to me, consistent black areas, and then rather than having the video texture applied to the main region capture I'm applying the cropped texture to that mesh. I'm sure there's a better way to do this to figure out why Android is adding black areas to the video texture when applied to a mesh but I haven't been able to figure it out. Unity 2019/Vuforia8.10/Region Capture latest.

Region Capture

May 5, 2019 - 11:50pm #41

What you are describing happens only in 8.0.10, then fixed in 8.1.7



But something else broke in 8.1.7 (https://developer.vuforia.com/forum/unity/bug-accessing-background-plane-texture-bug)



My advice is to just stick with 7.5.26 until we get a more stable release

Region Capture

May 6, 2019 - 2:50pm #40

I'm using 8.1.10 and the issue was in that version.

Region Capture

May 22, 2019 - 11:45pm #39

HI

i have some problem, i get textures from RenderTextureCamera are rendered "reddish", anyone know how to fixed this issue?

in this case i using vuforia 8.1.10 and unity 2018.3.14 for android platform.

here the step :

- After add ARcamera and import vuforia,

- setting xr for vuforia,

- add Capture_Region layer,

- swith to android,

- and import capture region package, and then try sample(get texture) and build to apk file



here the result (attach)...i get textures  rendered "reddish" from RenderTextureCamera. 

note: why video videobackground is small , because  videobackground in ARcamera is disable

AttachmentSize
Image icon sample.png595.27 KB

Region Capture

May 29, 2019 - 8:44am #38

I'm still having the same issue. Red Textures on Android with Vuforia 8.1.11 and Unity 2018.4.0.

It might have something to do with the OpenGL rendering on Android and textures being treated differently, but I couldn't figure out a solution yet.

I tried to access the background texture directly via VuforiaRenderer.VideoBackgroundTexture and give it to RegionCapture, but could net get it to work.

Does anyone have a clue or example how to obtain that Texture? I assume this will also be a red texture and therefore it would definitely be a Vuforia bug.

Region Capture

May 31, 2019 - 12:43am #37

Guys please read the answers below, I have already answered this, the textures are red  because RegionCapture assumes the texture is in RGB format, and this was true for the video background before vuforia 8, now you have to convert from YUV to RGB in the region capture shaders, use the VideoBackground shader from vuforia as an example on how to convert the values.

Pages

Log in or register to post comments