Log in or register to post comments

SoccerBall Tutorial VirtualButtonBehaviour

March 24, 2012 - 1:20pm #1

Hello,

I've been playing with the Soccerball Tutorial and for some reason the Vitrtual Button keeps getting triggered?

On start the ball stays where it is, and the ball stays n the middle of the image target (which is good) then when I first interact with the Virtual Button the ball will roll like its supposed to but here comes the strange part:

Once the ball is rolling it will move in a different direction without me interacting with it and will do this 3 or 4 times before it comes to a stop (as if I kept trying to interact with it when I only touched the virtual button once at the start).

So my question is whats going on here? and how would I attempt to solve this?

I just noticed The Sensitivity Setting (on the Virtual Button) was set to high, Im going to try medium and low and see if t makes a difference but Im thinking its something else.

Does anyone have any suggestions or input?

Sincerely,
Michael

Re: SoccerBall Tutorial VirtualButtonBehaviour

March 27, 2012 - 6:30pm #7

@ksiva
Will do, I'll make sure there are some features behind it and not a solid colored background.

@DavidBeard
I sent you a link, thank you my friend.

Thank you Both!!! What an awesome forum!

Re: SoccerBall Tutorial VirtualButtonBehaviour

March 26, 2012 - 10:38pm #6

One important note is that virtual buttons depend on feature points to work. You can't place a button on top of a solid-colored background, make sure you have some features behind it.

- Kim

Re: SoccerBall Tutorial VirtualButtonBehaviour

March 26, 2012 - 8:21pm #5

White it fine. It's really the contrast that's important. That's why the Tracker uses a greyscale version of the image, as you can see in the TMS interface online.

Does your target have repeated patterns (e.g. tessellation )? - this can sometimes lead to unpredictable behavior.

Feel free to post your target, or PM it to me.

Re: SoccerBall Tutorial VirtualButtonBehaviour

March 26, 2012 - 7:57pm #4

Hi ksiva,

Thanks for the reply its greatly appreciated!

I am printing the target and testing in good lighting. It seems the problem is my image target? I changed the image target to a custom one I created and downloaded from the website(which had a 3 star rating).

I just went back and changed it from myImage target back to the stones image target and now it seems to be working fine :)

Im going to go back and try and create an image target with a 4 or 5 star rating and see if it will work then.

I do have another question, when Im creating my image target does it matter if there is white space in the background? I noticed all of the images I've seen so far have a full colored background such as the stones & wood imageTargets. Also are there any tricks to creating ImageTargets or Trackables? It seems difficult to get a 4 or 5 star image (Im using photoshop).

Sincerely,
Michael

Re: SoccerBall Tutorial VirtualButtonBehaviour

March 25, 2012 - 6:04pm #3

Are you tracking off a computer screen? I suggest printing the target if you haven't already. Make sure you are testing in an environment with good lighting.

Does the teapot sample (tracking off the wood target) experience the same issue? Also, what device are you testing with?

The orientation shouldn't have an effect here.

- Kim

Re: SoccerBall Tutorial VirtualButtonBehaviour

March 24, 2012 - 1:48pm #2

I've changed the Sensitivity Setting (of the Virtual Button Behavior script) to LOW and still have the same issue?

I also created a entirely new scene and EventHandlerScript and still have the same issue. Could it be the camera settings in Edit > Project Settings > Player > Resolution and Presentation > Default Orientation?

I have mine set to Auto Rotation but Im going to try the others eg.(Portrait, Landscape Left).

Im just trying everything because Im not sure whats making it do this or how to fix it any suggestions would be greatly appreciated!

Sincerely,
Michael

Log in or register to post comments