Log in or register to post comments

Strange AR image on Samsung S6

September 3, 2015 - 1:32am #1

My app works fine on iPhone 6+ and iPad but I find on the Samsung S6 I get a weird looking screen until I rotate the phone and then everything kicks in and works fine.

See attached image.

I have set the required settings for the graphics api and opengles2 

 

AttachmentSize
Image icon Screenshot_2015-09-01-15-44-01.png824.31 KB

Strange AR image on Samsung S6

October 7, 2016 - 2:56am #49

Hi, I'm also experiencing this issue on Samsung SM-G920F. The app runs without problems at the beginning and after a while the camera image glitches. sometimes it stays in the weird-mode until I either flip the screen or defocus the app.

Strange AR image on Samsung S6

October 7, 2016 - 2:03am #48

bump. :(

Strange AR image on Samsung S6

October 4, 2016 - 5:21am #47

Hey,

patch seemed to work for me on a SM-G920F (at least, after following the instructions here i had no more glitches...)

But I do still have glitches on SM-G928F.

Could you provide a patch for this model as well? thanks!

 

edit: well, also glitches on SM-G920F, just not as quickly noticeable...

Strange AR image on Samsung S6

July 7, 2016 - 3:20pm #46

Thanks medabit, that's fixed it.

Strange AR image on Samsung S6

July 7, 2016 - 12:32pm #45

@BraveSirAndrew: I have uploaded patch for Samsung SM-G925X. It will be applied after performing the following:

  1.     Make sure that the device's Wifi is enabled and can connect to the Internet
  2.     Uninstall your test app with Vuforia integrated
  3.     Reinstall the same test app
  4.     Start the same test app and let it run in idle state for 30 seconds
  5.     Stop the same test app
  6.     Restart the same test app

This patch is only valid for Vuforia 5.0 or 5.5. Note that this update will only persist for as long as that version of the test app is installed. Reinstallation *may* over-write the patch. If so, you'll then need to redo the steps above.

Thanks.

Strange AR image on Samsung S6

July 7, 2016 - 8:12am #44

Hi, I'm currently seeing this issue on a Galaxy S6 Edge, model number SM -G925X. Is there a profile for that model?

Strange AR image on Samsung S6

May 17, 2016 - 7:31am #43

On init(), the SDK will execute a 'best effort' to download this device specific patch before camera start. This depends upon network connectivity, latency, etc. Once downloaded, the patch will persist in your app's private data space until the it is uninstalled or the data cache is cleared (by the user). My expectation is that it should also persist during upgrade, but I cannot guarantee how the OS will behave.

To clarify:

  1. App starts
  2. Vuforia init() is called
  3. SDK makes best effort to download patch before camera start
  4. Camera starts - with or without patch
  5. SDK makes additional attempts in background to download patch
  6. When patch is successfully downloaded, it will be applied for next camera start

Of course, this all depends upon the device being able to connect to the Internet.

Thanks.

Strange AR image on Samsung S6

May 17, 2016 - 3:42am #42

Ok thank you, now I don't really understand, will I need to do this every time I install an application I make on my phone, and will people who download my application from the Google Play Store need to do the same thing?

Strange AR image on Samsung S6

May 16, 2016 - 8:00am #41

@dahburj: I have uploaded patch for Samsung SM-G928C. It will be applied after performing the following:

  1. Make sure that the device's Wifi is enabled and can connect to the Internet
  2. Uninstall your test app with Vuforia integrated
  3. Reinstall the same test app
  4. Start the same test app and let it run in idle state for 30 seconds
  5. Stop the same test app
  6. Restart the same test app

This patch is only valid for Vuforia 5.0 or 5.5. Note that this update will only persist for as long as that version of the test app is installed. Reinstallation *may* over-write the patch. If so, you'll then need to redo the steps above.

Thanks.

Strange AR image on Samsung S6

May 15, 2016 - 8:56am #40

So will this fix work with galaxy s6 edge plus model number SM-G928C?? 

Strange AR image on Samsung S6

May 9, 2016 - 2:58pm #39

Got it.  Thank you for resolving it so quickly.

Strange AR image on Samsung S6

May 9, 2016 - 2:47pm #38

Vuforia device profiles are targeted per device. They control things like the camera's capture and render resolution while Vuforia is running. I don't recognize your "texture size" setting, but would expect the image size to have changed with the update.

Consider that when Samsung releases devices (like the Galaxy S6), there are 20+ unique device model names that fall under that line. The change is that we did not have a profile for your specific device's model name.

Thanks.

Strange AR image on Samsung S6

May 9, 2016 - 2:26pm #37

The texture size is now 1024, 512.

I have run the app for a few minutes and I haven't seen it happen again.

So, assuming that it really isn't happening anymore, what made the difference? Previous posts mentioned the app downloading a new device profile.  What made it happen this time versus previous runs? Uninstalling and reinstalling didn't make a difference before.  Stopping and restarting the app didn't help before either.

Strange AR image on Samsung S6

May 9, 2016 - 2:06pm #36

@vrm714

Can you please try to reproduce the problem again on Samsung-SM-G920V after performing the following:

  1. Make sure that the device's Wifi is enabled and can connect to the Internet
  2. Uninstall your test app with Vuforia integrated
  3. Reinstall the same test app
  4. Start the same test app and let it run in idle state for 30 seconds
  5. Stop the same test app
  6. Restart the same test app

Assuming you are running Vuforia 5.0 or 5.5, this will apply a device specific update that may help with the problem. You can verify this change by running @AlessandroB script again.

Note that this update will only persist for as long as that version of the test app is installed. Reinstallation *may* over-write the patch. If so, you'll then need to redo the steps above.

Thanks and please reply with your results.

Strange AR image on Samsung S6

May 9, 2016 - 1:29pm #35

Samsung-SM-G920V

Strange AR image on Samsung S6

May 9, 2016 - 1:27pm #34

Can you also please provide the exact model name for this S6 as found in the Android about screen?

Thanks.

Strange AR image on Samsung S6

May 9, 2016 - 1:12pm #33

Running your script returned:

Camera video feel: - image size: 1280, 720 - texture size: 2048, 1024

Strange AR image on Samsung S6

May 9, 2016 - 12:03pm #32

vrm714,

could you also validate the camera image size  by taking the script from my previous post ?

 

 

 

Strange AR image on Samsung S6

May 9, 2016 - 12:00pm #31

Has there been any further resolution on this?  I am seeing the problem in all my new apps using Unity 5/ Vuforia 5.5.9. Older projects - built with Unity 4/ Vuforia 4.0.103 - do not seem to exhibit the same behavior. 

Strange AR image on Samsung S6

March 21, 2016 - 1:30am #30

@pvirtual 

Could you verify the resolution that you get from Vuforia, using this script and checking the ADB device logs (you can use the command "adb logcat -s Unity"):

using UnityEngine;
using System.Collections;
using Vuforia;

public class CameraInfo : MonoBehaviour {
	
  void Update () {
    VuforiaRenderer.Vec2I imgSize = VuforiaRenderer.Instance.GetVideoTextureInfo().imageSize;
    VuforiaRenderer.Vec2I texSize = VuforiaRenderer.Instance.GetVideoTextureInfo().textureSize;

    Debug.Log("Camera video feed: " +
            " - image size: " + imgSize.x + ", " + imgSize.y +
            " - texture size: " + texSize.x + ", " + texSize.y);
  }
}

 

Also, could you share your exact device model number and OS version ?

 

Strange AR image on Samsung S6

March 19, 2016 - 2:58pm #29

Nope... I can confirm the glitches are still happening with the new version. Tested with Vuforia 5.5.9 and Unity v 5.3.4 on a Samsung Galaxy s6 Edege+

Strange AR image on Samsung S6

March 9, 2016 - 10:38am #28

Vuforia 5.5.9 has been released and should provide correct behaviour on the Galaxy S6:

https://developer.vuforia.com/library/articles/Release_Notes/Vuforia-SDK-Release-Notes

https://developer.vuforia.com/downloads/sdk

Also, make sure to check the Unity Migration Guide before upgrading to Vuforia 5.5:

https://developer.vuforia.com/library/articles/Solution/Migrating-Unity-Projects-to-Vuforia-5-5

Strange AR image on Samsung S6

March 7, 2016 - 2:29am #27

We have the same problem with the S6. Is there any final solution for this issue?

Strange AR image on Samsung S6

December 14, 2015 - 4:21am #26

I understand that the issue appears randomly on the screen for a few seconds, then sometimes disappears and re-appears again;

however, this behaviour is supposed to disappear completely after the first run (on a given device); that's where my question comes from.

 

Strange AR image on Samsung S6

December 14, 2015 - 3:36am #25

AlessandroB,

This bug occurs sometimes. I do not understand your question.

Strange AR image on Samsung S6

December 11, 2015 - 9:30am #24

What if you run the app a second time (on the same device) ?

Strange AR image on Samsung S6

December 11, 2015 - 7:42am #23

We removed the app. And reinstall. This is not enough? Vuforiya something caches yet?

Strange AR image on Samsung S6

December 10, 2015 - 6:41am #22

What if you connect your device to the Internet, clear the App cache (under the Application Manager) and restart the App ?

 

Strange AR image on Samsung S6

December 8, 2015 - 11:12pm #21

Hi,

We set Camera Device Mode = MODE_OPTIMIZE_SPEED

set targetFrameRate = 30 fps

But sometimes we see digital noise.

There are variants for correcting this?
It appears on different phones S6/S6 Edge
 
Thx,
Anton

 

Strange AR image on Samsung S6

November 5, 2015 - 6:13pm #20

railon wrote:

Can you implement the profile in the Unity package in the next release?

Profile updates are included in new SDK releases.

Strange AR image on Samsung S6

November 4, 2015 - 7:00am #19

I forgot to mention that for the GS6, you can achieve the same result by selecting Camera Mode = MODE_OPTIMIZE_SPEED (you can set this in the ARCamera inspector panel in the Unity Editor);  the device profile fix would only be needed  if you were using Camera Mode = MODE_DEFAULT.

 

 

Strange AR image on Samsung S6

November 4, 2015 - 4:24am #18

Hi, thanks for the fast response.

Good to hear that the issue can be solved that way. But that gets me interested in what logic you're in place there. This means that every vuforia App "calls" home to get this or other updates, right?

And that explains why the issue can happen at the first start of the App because the profile wasn't updated yet. Which is still not good. Can you implement the profile in the Unity package in the next release?

Thanks

Strange AR image on Samsung S6

November 4, 2015 - 4:00am #17

The problem was caused by an issue with the hardware in question when using a specific camera resolution;  when the Vuforia app is installed, Vuforia will download an updated device profile with the correct camera resolution.

 

 

 

Strange AR image on Samsung S6

November 4, 2015 - 1:35am #16

Hi @AlessandroB,

can you give me some more input about "The issues should now be resolved"?
So do you mean with the new 5.0.6 samples and Unity package? What was the problem exactly and how did you resolve it?

Also what about the "on first run you might still see the issue once"? That's not perfect for consumers who get in contact with AR the first time. If it's broken or seams broken that is bad. Also we develop for high end b2b customers and can't tell them "You know, the App can be buggy the at the first start".
Can you describe the problem in detail and is there a workaround for it?

Thanks

Strange AR image on Samsung S6

October 14, 2015 - 6:42am #15

The issue should now be resolved; you can verify this by uninstalling the app from your device, re-install it and re-run

(note, on first run you might still see the issue once,   then on the second run and on any subsequent runs you should not observe it anymore)

 

Strange AR image on Samsung S6

October 6, 2015 - 4:03am #14

Thanks for the detailed investigation, ;-)

I will try these suggestions and see how it goes

 

Thanks again

Strange AR image on Samsung S6

October 6, 2015 - 3:59am #13

It seems the issue affects specifically some of the GS6 models (SM-G920F and SM-G925F, based on our tests) and it seems to originate likely from a driver/hardware issue on that specific device which seems to show up occasionally (not in a predictable way) under some combinations of heavy GPU load, and/or device overheating and/or handling of large textures in GPU memory.

At a first analysis, the Video Playback sample seems to be able to trigger this issue more easily, as in this sample the GPU is loaded with (1) video background rendering and (2) the playback-on-texture (video-on-texture update).  

Selecting Camera mode "MODE_OPTIMIZE_SPEED" seems to make the issue disappear;

additionally, you may also want to try setting the frame rate to 30 fps via this code, which can also help mitigating this:

  Application.targetFrameRate = 30;

 

 

 

 

Strange AR image on Samsung S6

October 5, 2015 - 4:26am #12

Hi,  I still get the same as 60days in that it works but then after some while it goes ape!  Not always after same amount of time either.

My GS6 is on 5.1.1

Strange AR image on Samsung S6

October 5, 2015 - 2:28am #11

@ 60days (and anyone else in this thread):

could you confirm the Android version running on you GS6 ?  dm3d mentions testing a device on Android 5.1.1, it would be great if you coul confirm your Android version too.

 

Strange AR image on Samsung S6

October 1, 2015 - 2:29pm #10

60days wrote:

Heres a shot confirming it in the currently available book sample, built in Unity 5.2.0f3.

After a frequent bit of auto-rotating the device while running the Books sample app, I've been able to trigger the pixelated video background. It will sometimes jump back to normal and then back to static. Seems to need the device to heat up in order to reproduce, which might indicate a hardware issue.

 

Strange AR image on Samsung S6

October 1, 2015 - 1:54pm #9

60days wrote:

Heres a shot confirming it in the currently available book sample, built in Unity 5.2.0f3. I will also attach the apk in case it is specific to each build : https://www.dropbox.com/s/t6o0bkmwzs730vy/s6Test.apk?dl=1

I tested your s6Test.apk file (aka Books sample) on a Galaxy S6 Edge (SM-G925F) running Android 5.1.1 and it worked fine. Screenshots attached.

Strange AR image on Samsung S6

September 23, 2015 - 11:28pm #8

I was going to post that very same issue with pielation but am currentlymigrating my app to the latest Vuforia video playback package and will report back, but in a way reassures me that it is not just my code if other are getting it also....

Strange AR image on Samsung S6

September 23, 2015 - 10:00pm #7

I did some testing with a Samsung Galaxy S6 edge (SM-G925F) with Android 5.1.1 and have been able to see some of the pixelated areas, but not during normal app behavior. Switching camera modes at runtime can trigger some interesting results and sometimes can offset the frame, leaving displaced areas with black regions, but in this device, pixelated regions. You might want to try switching to MODE_OPTIMIZE_SPEED (800x450 for this device) and see if you can reproduce the pixelated video background.

To display your mode dimensions on screen, here's some steps and code:

https://developer.vuforia.com/forum/android/lenovo-yoga-tablet-2-stretched-camera-no-2#comment-2051631

 

Strange AR image on Samsung S6

September 23, 2015 - 7:39pm #6

Hi dm3d - wish it was that easy for us! Unfortunately the issue we have occurs (intermittently) regardless of the build process we use.

 

Heres a shot confirming it in the currently available book sample, built in Unity 5.2.0f3. I will also attach the apk in case it is specific to each build : https://www.dropbox.com/s/t6o0bkmwzs730vy/s6Test.apk?dl=1

 

 

AttachmentSize
Image icon VuforiaError.jpg1.16 MB

Strange AR image on Samsung S6

September 23, 2015 - 5:10pm #5

vamshi wrote:

Sometimes am also getting the same poblem only with the Build and run (Unity3d and Vuforia). Not on all android devices.

If i open the app with lanch icon there is no problem. Working fine.

Yes, if experiencing issues with "Build And Run" from Unity, just use "Build" and then manually install apk file to device:

adb install -r sampleapp.apk

 

Strange AR image on Samsung S6

September 22, 2015 - 1:22am #4

We are also seeing this issue on an S6 Edge with our app, and will be trying to replicate it with the sample app.

Please let us know if any progress has been made in the meantime in identifying it - its quite sporadic so difficult to replicate, but we're willing to help test potential solutions.

Strange AR image on Samsung S6

September 18, 2015 - 2:01am #3

Sometimes am also getting the same poblem only with the Build and run (Unity3d and Vuforia). Not on all android devices.

If i open the app with lanch icon there is no problem. Working fine.

 

Strange AR image on Samsung S6

September 8, 2015 - 4:26pm #2

Are you able to reproduce this with our sample apps? You can try using the Books sample app which supports auto-rotation.

Log in or register to post comments