Log in or register to post comments

Strange MeshRenderers!

December 24, 2010 - 2:37am #1

Hey guys,

So I was trying to make a cube that is parented to the ImageTarget in my scene invisible. But, even after I uncheck/disable the Mesh Renderer, the cube still appears when I run the app on my phone. I tried to set the cube's renderer to false in code as well, but didn't work.

However, when I tried turning off the Mesh Renderer of the cube when attached to the ARCamera in the scene, it worked as expected--was invisible when I unchecked Mesh renderer.

Has anyone else experienced a similar problem? :confused:

thanks,
kedar

Re: Strange MeshRenderers!

December 24, 2010 - 6:22am #3

The issue here is the default behavior of the OnTrackingFound() method, located in TrackableScript.cs. This method currently turns on the renderer component of each child object, while OnTrackingLost() turns off the renderer components. You can open up this script and change the default behavior to suit your application's needs.

- Kim

Re: Strange MeshRenderers!

December 24, 2010 - 2:52am #2

well, a workaround would be to swap the gameobject's texture with a transparent png when you want to make it invisible.

Log in or register to post comments