Log in or register to post comments

Unity 4.3 videoplayback compatibility

December 27, 2013 - 11:58am #1

Hi, I have this problem  with the videoplayback. It turns out I decided to update my unity installations from 4.1.3 to 4.3, I had this app where video playback worked just fine but when I changed to unity 4.3 it has the sand clock as if it where loading the video but it never plays, I already checked the video path and it's all in order. If any one can tell me if it is compatible with unity 4.3 I'd really apreciate the answer.

Unity 4.3 videoplayback compatibility

March 8, 2014 - 7:12am #4

Could you make this test:

- using the Vuforia VideoPlayback sample, replace one of the 2 videos in the sample with one of your own videos (the video files that you would use in your custom App);

- run the VideoPlayback sample with the replaced video file on your Android 4.3+ devices

- could you then report back the list of results (which video did fail on which device, with exact model number and OS version of the device) ?

 

Unity 4.3 videoplayback compatibility

March 7, 2014 - 1:25pm #3

I am still experience some video playback issues, but it seems to be a lot more specific. Only certain videos won't play on the the texture on Android devices at the Android 4.3+ 

Using Vuforia 2.8.7 and Unity 4.3.0 the videos run fine on iOS and earlier versions of Android (4.2 tested) yet they won't run (continuous egg timer) and Android 4.3 devices.

Any suggestions?

Unity 4.3 videoplayback compatibility

December 27, 2013 - 12:02pm #2

Be sure to upgrade to the latest Vuforia Unity Extension version, 2.8.7 - there was an incompatibility w/ the prior 2.6.7 release.

Also you might try re-importing your project ( Assets > Reimport All ) in case Unity corrupted the video references when upgrading.

Log in or register to post comments