Log in or register to post comments

Unity 5.4 with Vuforia 5 IOS doesn't cloud recognize any trackers

October 7, 2016 - 1:18pm #1

Hello everyone,

I'm developing an application for iOS using Unity 5.4 with Vuforia 5. I have already built the app for android and works fine, but on iOS, The camera opens no problem and the scanner is working but it doesn't recognize any of the images in my cloud database.

I know Vuforia 5 is a bit outdated and the recommendations are to upgrade to the latest versions but it is critical that the application is built and published on itunes so time isn't really my friend here.

I have no errors on either of the platforms while building or any crashes during runtime, on iOS, the camera works but no recognition. Can someone help me with that or tell me how to troubleshoot the problem?

Thanks

Unity 5.4 with Vuforia 5 IOS doesn't cloud recognize any trackers

October 11, 2016 - 5:30am #4

I have tried to build the application with Unity 5.3 32 bit on windows. I tested it on Android but the Camera isn't opening, its just black screen. That seem to me like a step back. I don't think this is the problem.

Unity 5.4 with Vuforia 5 IOS doesn't cloud recognize any trackers

October 9, 2016 - 12:32pm #3

I don't think Unity 5.4 existed at the time of Vuforia 5. As an experiment, you might try copying the Unity project (as a backup) and building with Unity 5.3

see here: http://library.vuforia.com/articles/Release_Notes/Vuforia-SDK-Release-Notes

Unity 5.4 with Vuforia 5 IOS doesn't cloud recognize any trackers

October 9, 2016 - 8:18am #2

One thing worth mentioning. When we were trying to build for XCode and market the QCARWrapper to iOS, the application showed errors (not in building on Unity or Xcode but when trying to publish) and we researched the problem and it was said that we should mark it as Standalone. When we marked it as Standalone, it was produced fine. But it didn't recognize any of the trackers.

 

Could this be the issue?

Log in or register to post comments