Log in or register to post comments

Updated Android SDK 2.3 App Crashes

December 13, 2010 - 1:09am #1

I've updated my Unity to the new 3.1.2 alpha, as well as my SDK to r8 and added SDK 2.3 / API 9.

But when I try to run my Unity game, which was working fine before on my phones (Desire and Nexus One), I get an instant crash.
I did some testing and this only occures when the game features AR.
Building and pushing goes fine, so I made a bugreport with ADB.

It gave me the following line at FATAL EXCEPTION:

java.lang.RuntimeException: Unable to start activity ComponentInfo{com.BeyondReality.Test/com.qualcomm.QCARUnityPlayer.PlayerActivity}: android.content.res.Resources$NotFoundException: Resource ID #0x0

I managed to trace it back to the AndroidManifest.xml. However, I'm not a die-hard programmer (hence why I use Unity), so I am stuck at that point.

Re: Updated Android SDK 2.3 App Crashes

December 15, 2010 - 2:42am #6

Alright, it runs again!
Although a new issues has arrised!

I get a few warnings saying:

The class defined in script file named '_scriptname_' does not match the file name!

They are javascripts, I've seen this occur at C Sharp scripts but it shouldnt apply to javascripts, should it?

UPDATE: Lol, I just had to open those scripts and save them again so they got recompiled, that fixed it.

Re: Updated Android SDK 2.3 App Crashes

December 15, 2010 - 12:10am #5

I'll give that a try, and work with that version then!

Re: Updated Android SDK 2.3 App Crashes

December 14, 2010 - 6:29am #4

We'll look into this issue, but we can't guarantee that the QCAR extension will work with all beta versions of Unity, at least not when they first come out. For now we suggest using the official version of Unity 3.1.

- Kim

Re: Updated Android SDK 2.3 App Crashes

December 14, 2010 - 12:16am #3

I got it from here:

https://sites.google.com/a/unity3d.com/unity-beta/

I thought the ADB executable was only there for pushing the game to the phone, which works fine.
I'll give it a try.

Update: No luck there, still crashes.

Re: Updated Android SDK 2.3 App Crashes

December 13, 2010 - 6:10am #2

Hmm, I'm trying to figure out which version of Unity this is. When/where did you get it? We're building against the latest official release, 3.1.0f4. To get this version to work with Android SDK r8, we found that you need to copy the adb executable from the platform-tools to the tools directory. See more info here:

http://forum.unity3d.com/threads/69870-Android-SDK-2.3-Gingerbread-regression-with-Unity-3.1

- Kim

Log in or register to post comments